aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2013-08-29 23:39:49 +0800
committerrm <rm@FreeBSD.org>2013-08-29 23:39:49 +0800
commit8da66d535e8f8afd1cbd142532ddcc23b4e08273 (patch)
tree1de5a4facfd9b0bf601429e4b0f734ec25c86a78 /devel
parent3c66077b34eb521d2a6b80b3b3686e43c58feeb7 (diff)
downloadfreebsd-ports-gnome-8da66d535e8f8afd1cbd142532ddcc23b4e08273.tar.gz
freebsd-ports-gnome-8da66d535e8f8afd1cbd142532ddcc23b4e08273.tar.zst
freebsd-ports-gnome-8da66d535e8f8afd1cbd142532ddcc23b4e08273.zip
Serpent is a simple serialization library based on ast.literal_eval.
Because it only serializes literals and recreates the objects using ast.literal_eval(), the serialized data is safe to transport to other machines (over the network for instance) and de-serialize it there. WWW: http://pypi.python.org/pypi/serpent
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-serpent/Makefile27
-rw-r--r--devel/py-serpent/distinfo2
-rw-r--r--devel/py-serpent/pkg-descr7
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f8c55bcebc7e..3877599763a8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3715,6 +3715,7 @@
SUBDIR += py-rtree
SUBDIR += py-ruledispatch
SUBDIR += py-sanetime
+ SUBDIR += py-serpent
SUBDIR += py-setproctitle
SUBDIR += py-setuptools-git
SUBDIR += py-setuptools_darcs
diff --git a/devel/py-serpent/Makefile b/devel/py-serpent/Makefile
new file mode 100644
index 000000000000..28a5c48fa3b0
--- /dev/null
+++ b/devel/py-serpent/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= serpent
+PORTVERSION= 1.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Simple serialization library based on ast.literal_eval
+
+LICENSE= MIT
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/serpent.py \
+ %%PYTHON_SITELIBDIR%%/serpent.pyc \
+ %%PYTHON_SITELIBDIR%%/serpent.pyo
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} >= 320
+.include "${PORTSDIR}/devel/py-virtualenv/files/py3k-fix-pkg-plist.inc"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/py-serpent/distinfo b/devel/py-serpent/distinfo
new file mode 100644
index 000000000000..b1b2ecf8d7ac
--- /dev/null
+++ b/devel/py-serpent/distinfo
@@ -0,0 +1,2 @@
+SHA256 (serpent-1.3.tar.gz) = 45560ada9e07e1400304870210c64c2de14ab414e23ec7a1271d673fa92104e2
+SIZE (serpent-1.3.tar.gz) = 7896
diff --git a/devel/py-serpent/pkg-descr b/devel/py-serpent/pkg-descr
new file mode 100644
index 000000000000..09f9d1ed0e4e
--- /dev/null
+++ b/devel/py-serpent/pkg-descr
@@ -0,0 +1,7 @@
+Serpent is a simple serialization library based on ast.literal_eval.
+
+Because it only serializes literals and recreates the objects using
+ast.literal_eval(), the serialized data is safe to transport to other
+machines (over the network for instance) and de-serialize it there.
+
+WWW: http://pypi.python.org/pypi/serpent