aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2015-05-17 04:36:16 +0800
committerjohans <johans@FreeBSD.org>2015-05-17 04:36:16 +0800
commit8e72ad11ed6fcfcfe41fd46db9f02ae38272e920 (patch)
treeb3004846360b9250fab848cce96e153c0afd68e0 /devel
parent4fe3e04826462fa6dc26ac4c7c45f0224358b646 (diff)
downloadfreebsd-ports-gnome-8e72ad11ed6fcfcfe41fd46db9f02ae38272e920.tar.gz
freebsd-ports-gnome-8e72ad11ed6fcfcfe41fd46db9f02ae38272e920.tar.zst
freebsd-ports-gnome-8e72ad11ed6fcfcfe41fd46db9f02ae38272e920.zip
- Update ocaml-react to 1.2.0
- Manual build and install - Adopt port
Diffstat (limited to 'devel')
-rw-r--r--devel/ocaml-react/Makefile20
-rw-r--r--devel/ocaml-react/distinfo4
-rw-r--r--devel/ocaml-react/files/patch-src_META7
3 files changed, 8 insertions, 23 deletions
diff --git a/devel/ocaml-react/Makefile b/devel/ocaml-react/Makefile
index 67d727477c8b..be0c779f4422 100644
--- a/devel/ocaml-react/Makefile
+++ b/devel/ocaml-react/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= react
-PORTVERSION= 0.9.4
-PORTREVISION= 1
+PORTVERSION= 1.2.0
CATEGORIES= devel
MASTER_SITES= http://erratique.ch/software/react/releases/
PKGNAMEPREFIX= ocaml-
EXTRACT_SUFX= .tbz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= johans@FreeBSD.org
COMMENT= OCaml module for functional reactive programming
LICENSE= BSD3CLAUSE
@@ -28,22 +27,15 @@ OCAMLC_DEPEND= ocaml>=3.11:${OCAMLC_PORT}
.endif
USE_OCAML_FINDLIB= yes
+USE_OCAMLFIND_PLIST= yes
USE_OCAML_LDCONFIG= yes
-post-patch:
- @${REINPLACE_CMD} -e 's,"install" :: findlib_name,"install" :: "-destdir ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib" :: "-ldconf /dev/null" :: findlib_name,' \
- ${WRKSRC}/setup.ml
-
-do-configure:
- @cd ${WRKSRC} && ocaml setup.ml -configure ${CONFIGURE_ARGS}
-
do-build:
- (cd ${WRKSRC} && ocaml setup.ml -build)
- (cd ${WRKSRC} && ocamlbuild src/react.cmxs)
+ cd ${WRKSRC} && ocamlbuild react.cmxs react.cma react.a
do-install:
- ${MKDIR} ${STAGEDIR}${OCAMLFIND_DESTDIR}
- (cd ${WRKSRC} && ocaml setup.ml -install)
+ ${MKDIR} ${STAGEDIR}${OCAMLFIND_DESTDIR}/react
+ cd ${WRKSRC} && ocamlfind install -destdir ${STAGEDIR}${PREFIX}/lib/ocaml/site-lib react pkg/META _build/src/react.a _build/src/react.cma _build/src/react.cmi _build/src/react.cmx _build/src/react.cmxa _build/src/react.cmxs _build/src/react.mli
${INSTALL_LIB} ${WRKSRC}/_build/src/react.cmxs \
${STAGEDIR}${OCAMLFIND_DESTDIR}/react
diff --git a/devel/ocaml-react/distinfo b/devel/ocaml-react/distinfo
index 866d4973a96a..9a50ba54479a 100644
--- a/devel/ocaml-react/distinfo
+++ b/devel/ocaml-react/distinfo
@@ -1,2 +1,2 @@
-SHA256 (react-0.9.4.tbz) = 466ad4e2e7ff57c93c4e51511f53f2bdf32df46354458f4a158cd13bf3fbd4ab
-SIZE (react-0.9.4.tbz) = 82964
+SHA256 (react-1.2.0.tbz) = 887aaea9191870bc0f37f945c02ec4c90497d949cd4dedc3d565c3fbec7ad04e
+SIZE (react-1.2.0.tbz) = 64665
diff --git a/devel/ocaml-react/files/patch-src_META b/devel/ocaml-react/files/patch-src_META
deleted file mode 100644
index 0521ae20b089..000000000000
--- a/devel/ocaml-react/files/patch-src_META
+++ /dev/null
@@ -1,7 +0,0 @@
---- src/META.orig 2011-12-14 09:50:28.517512351 +0100
-+++ src/META 2011-12-14 09:50:32.213463093 +0100
-@@ -3,4 +3,3 @@
- archive(byte) = "react.cmo"
- archive(native) = "react.cmx"
- archive(plugin,native) = "react.cmxs"
--directory = "+react"