aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2013-06-11 23:41:13 +0800
committerskreuzer <skreuzer@FreeBSD.org>2013-06-11 23:41:13 +0800
commit8f33868e2a266493eb326114fe3ec8efab7fba9b (patch)
tree228afe355ecbbe9b9665f95e3c1fc75b3560b4ce /devel
parent0b99c02708b1420a7e41974a4842943f5c4c79e8 (diff)
downloadfreebsd-ports-gnome-8f33868e2a266493eb326114fe3ec8efab7fba9b.tar.gz
freebsd-ports-gnome-8f33868e2a266493eb326114fe3ec8efab7fba9b.tar.zst
freebsd-ports-gnome-8f33868e2a266493eb326114fe3ec8efab7fba9b.zip
Python module for building and describing deterministic finite-state automata.
WWW: http://code.google.com/p/python-fsm/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-fsm/Makefile22
-rw-r--r--devel/py-fsm/distinfo2
-rw-r--r--devel/py-fsm/pkg-descr3
-rw-r--r--devel/py-fsm/pkg-plist3
5 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e061443633d8..c794a5680634 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3498,6 +3498,7 @@
SUBDIR += py-fortran
SUBDIR += py-freebsd
SUBDIR += py-fs
+ SUBDIR += py-fsm
SUBDIR += py-fudge
SUBDIR += py-funcparserlib
SUBDIR += py-fusefs
diff --git a/devel/py-fsm/Makefile b/devel/py-fsm/Makefile
new file mode 100644
index 000000000000..d49234446e12
--- /dev/null
+++ b/devel/py-fsm/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= fsm
+PORTVERSION= 0.01
+CATEGORIES= devel python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PROJECTHOST= python-${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= skreuzer@FreeBSD.org
+COMMENT= Pure Python Implementation of a Finite State Machine
+
+LICENSE= BSD
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}graphviz>=1.0:${PORTSDIR}/graphics/py-graphviz
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_EGGINFO= python_${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg-info
+
+.include <bsd.port.mk>
diff --git a/devel/py-fsm/distinfo b/devel/py-fsm/distinfo
new file mode 100644
index 000000000000..2c079b41feab
--- /dev/null
+++ b/devel/py-fsm/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-fsm-0.01.tar.gz) = 0cd9303d50d5b449a46069b73c5c7f67399af4579652dbdfdec5aeac5d9e5689
+SIZE (python-fsm-0.01.tar.gz) = 4038
diff --git a/devel/py-fsm/pkg-descr b/devel/py-fsm/pkg-descr
new file mode 100644
index 000000000000..6cbe26558b2c
--- /dev/null
+++ b/devel/py-fsm/pkg-descr
@@ -0,0 +1,3 @@
+Python module for building and describing deterministic finite-state automata.
+
+WWW: http://code.google.com/p/python-fsm/
diff --git a/devel/py-fsm/pkg-plist b/devel/py-fsm/pkg-plist
new file mode 100644
index 000000000000..ee52d345bd44
--- /dev/null
+++ b/devel/py-fsm/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/fsm.py
+%%PYTHON_SITELIBDIR%%/fsm.pyc
+%%PYTHON_SITELIBDIR%%/fsm.pyo