aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-01-02 02:25:01 +0800
committerglewis <glewis@FreeBSD.org>2010-01-02 02:25:01 +0800
commit907b6c419017c495d1485220363f10801b3f8cc7 (patch)
treef6d8cd5fcfd0b29cbf88f8805e6eea558863c52c /devel
parent0a7e77835461f781469a069aba29355950600431 (diff)
downloadfreebsd-ports-gnome-907b6c419017c495d1485220363f10801b3f8cc7.tar.gz
freebsd-ports-gnome-907b6c419017c495d1485220363f10801b3f8cc7.tar.zst
freebsd-ports-gnome-907b6c419017c495d1485220363f10801b3f8cc7.zip
. Add a port of log4net:
log4net is a tool to help the programmer output log statements to a variety of output targets. In case of problems with an application, it is helpful to enable logging so that the problem can be located. With log4net it is possible to enable logging at runtime without modifying the application binary. The log4net package is designed so that log statements can remain in shipped code without incurring a high performance cost. It follows that the speed of logging (or rather not logging) is crucial. At the same time, log output can be so voluminous that it quickly becomes overwhelming. One of the distinctive features of log4net is the notion of hierarchical loggers. Using these loggers it is possible to selectively control which log statements are output at arbitrary granularity. log4net is designed with two distinct goals in mind: speed and flexibility. Features: * Support for multiple frameworks * Output to multiple logging targets * Hierarchical logging architecture * XML Configuration * Dynamic Configuration * Logging Context * Proven architecture * Modular and extensible design * High performance with flexibility WWW: http://logging.apache.org/log4net/ PR: 141441 Submitted by: Romain Tartiere <mono@FreeBSD.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/log4net/Makefile53
-rw-r--r--devel/log4net/distinfo3
-rw-r--r--devel/log4net/files/log4net.pc.in8
-rw-r--r--devel/log4net/pkg-descr26
-rw-r--r--devel/log4net/pkg-plist5
6 files changed, 96 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 84661122064d..a3cc2f5d258c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -827,6 +827,7 @@
SUBDIR += log4cpp
SUBDIR += log4cxx
SUBDIR += log4j
+ SUBDIR += log4net
SUBDIR += log4sh
SUBDIR += log4shib
SUBDIR += loki
diff --git a/devel/log4net/Makefile b/devel/log4net/Makefile
new file mode 100644
index 000000000000..798c24c62ce8
--- /dev/null
+++ b/devel/log4net/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: log4net
+# Date created: July 8th, 2005
+# Whom: Christopher Nehren <apeiron@coitusmentis.info>
+#
+# $FreeBSD$
+# $Id: Makefile,v 1.13 2006/10/10 00:26:57 killfill Exp $
+#
+
+PORTNAME= log4net
+PORTVERSION= 1.2.10
+PORTREVISION= 1
+CATEGORIES= devel
+MASTER_SITES= APACHE
+MASTER_SITE_SUBDIR= incubator/log4net/${PORTVERSION}
+DISTNAME= incubating-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= mono@FreeBSD.org
+COMMENT= Port for .NET of the Apache Logging Services project
+
+BUILD_DEPENDS= mono:${PORTSDIR}/lang/mono
+RUN_DEPENDS= mono:${PORTSDIR}/lang/mono
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+SUB_FILES= log4net.pc
+SUB_LIST+= PORTVERSION=${PORTVERSION}
+
+.if !defined (NOPORTDOCS)
+PORTDOCS= *
+.endif
+.if !defined (NOPORTEXAMPLES)
+PORTEXAMPLES= *
+.endif
+
+do-install:
+ @(cd ${INSTALL_WRKSRC}/bin/mono/2.0/release && ${SETENV} MONO_SHARED_DIR=${WRKDIR} ${LOCALBASE}/bin/gacutil /root ${PREFIX}/lib/ /gacdir ${PREFIX}/lib /package 2.0 /i log4net.dll)
+ ${INSTALL_DATA} ${WRKDIR}/log4net.pc ${PREFIX}/libdata/pkgconfig/log4net.pc
+.if !defined (NOPORTDOCS)
+ @${ECHO_CMD} "Installing documentation..."
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR}
+.endif
+.if !defined (NOPORTEXAMPLES)
+ @${ECHO_CMD} "Installing examples..."
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+.endif
+
+.include "${.CURDIR}/../../lang/mono/bsd.mono.mk"
+.include <bsd.port.mk>
diff --git a/devel/log4net/distinfo b/devel/log4net/distinfo
new file mode 100644
index 000000000000..69dcfb53d1ea
--- /dev/null
+++ b/devel/log4net/distinfo
@@ -0,0 +1,3 @@
+MD5 (incubating-log4net-1.2.10.zip) = 0085970684888a5dfb1d59b2831f8d7e
+SHA256 (incubating-log4net-1.2.10.zip) = 50f6124dd01febb7716625aced1727b3db200d589af2d84c99ee22d5ab34fb3f
+SIZE (incubating-log4net-1.2.10.zip) = 8203576
diff --git a/devel/log4net/files/log4net.pc.in b/devel/log4net/files/log4net.pc.in
new file mode 100644
index 000000000000..578714173cb8
--- /dev/null
+++ b/devel/log4net/files/log4net.pc.in
@@ -0,0 +1,8 @@
+prefix=%%PREFIX%%
+exec_prefix=${prefix}
+libdir=${exec_prefix}/lib
+
+Name: Log4net
+Description: Log4net - Logging library for C# and VB.NET
+Version: %%PORTVERSION%%
+Libs: -r:${libdir}/mono/2.0/log4net.dll
diff --git a/devel/log4net/pkg-descr b/devel/log4net/pkg-descr
new file mode 100644
index 000000000000..00ddc519a58c
--- /dev/null
+++ b/devel/log4net/pkg-descr
@@ -0,0 +1,26 @@
+log4net is a tool to help the programmer output log statements to a variety of
+output targets. In case of problems with an application, it is helpful to
+enable logging so that the problem can be located. With log4net it is possible
+to enable logging at runtime without modifying the application binary. The
+log4net package is designed so that log statements can remain in shipped code
+without incurring a high performance cost. It follows that the speed of logging
+(or rather not logging) is crucial.
+
+At the same time, log output can be so voluminous that it quickly becomes
+overwhelming. One of the distinctive features of log4net is the notion of
+hierarchical loggers. Using these loggers it is possible to selectively control
+which log statements are output at arbitrary granularity.
+
+log4net is designed with two distinct goals in mind: speed and flexibility.
+Features:
+* Support for multiple frameworks
+* Output to multiple logging targets
+* Hierarchical logging architecture
+* XML Configuration
+* Dynamic Configuration
+* Logging Context
+* Proven architecture
+* Modular and extensible design
+* High performance with flexibility
+
+WWW: http://logging.apache.org/log4net/
diff --git a/devel/log4net/pkg-plist b/devel/log4net/pkg-plist
new file mode 100644
index 000000000000..21e95cfd2934
--- /dev/null
+++ b/devel/log4net/pkg-plist
@@ -0,0 +1,5 @@
+lib/mono/2.0/log4net.dll
+lib/mono/gac/log4net/1.2.10.0__1b44e1d426115821/log4net.dll
+libdata/pkgconfig/log4net.pc
+@dirrm lib/mono/gac/log4net/1.2.10.0__1b44e1d426115821
+@dirrm lib/mono/gac/log4net