aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2004-05-25 01:22:09 +0800
committermat <mat@FreeBSD.org>2004-05-25 01:22:09 +0800
commit90e3d3bd1cd7489f1181e9302958edb002dd33d1 (patch)
tree5e591e2058dd5bc70a386b1fa2157b6ad37a449f /devel
parentfa35f4498112d02fee47a798e38eee88aa8251c6 (diff)
downloadfreebsd-ports-gnome-90e3d3bd1cd7489f1181e9302958edb002dd33d1.tar.gz
freebsd-ports-gnome-90e3d3bd1cd7489f1181e9302958edb002dd33d1.tar.zst
freebsd-ports-gnome-90e3d3bd1cd7489f1181e9302958edb002dd33d1.zip
Add p5-Params-CallbackRequest 1.13, provide callbacks to method and
function parameters. PR: ports/67022 Submitted by: Rod Taylor <ports@rbt.ca>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Params-CallbackRequest/Makefile34
-rw-r--r--devel/p5-Params-CallbackRequest/distinfo2
-rw-r--r--devel/p5-Params-CallbackRequest/pkg-descr9
-rw-r--r--devel/p5-Params-CallbackRequest/pkg-plist5
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 20022d380260..b12f5c36ecd9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -854,6 +854,7 @@
SUBDIR += p5-PPerl
SUBDIR += p5-PV
SUBDIR += p5-Parallel-ForkManager
+ SUBDIR += p5-Params-CallbackRequest
SUBDIR += p5-Params-Validate
SUBDIR += p5-Parse-CPAN-Packages
SUBDIR += p5-Parse-PerlConfig
diff --git a/devel/p5-Params-CallbackRequest/Makefile b/devel/p5-Params-CallbackRequest/Makefile
new file mode 100644
index 000000000000..b1f3e07e0ded
--- /dev/null
+++ b/devel/p5-Params-CallbackRequest/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: Params::CallbackRequest
+# Date created: 21 May 2004
+# Whom: Rod Taylor <ports@rbt.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Params-CallbackRequest
+PORTVERSION= 1.13
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Params/DWHEELER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@rbt.ca
+COMMENT= Provide callbacks to method and function parameters
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Params/Validate.pm:${PORTSDIR}/devel/p5-Params-Validate \
+ ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Params::Callback.3 Params::CallbackRequest.3 \
+ Params::CallbackRequest::Exceptions.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ @${PERL} -i -pe 's/(sub \S+) : .+ {/$$1 {/g' ${WRKSRC}/lib/Params/Callback.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Params-CallbackRequest/distinfo b/devel/p5-Params-CallbackRequest/distinfo
new file mode 100644
index 000000000000..b13883428b92
--- /dev/null
+++ b/devel/p5-Params-CallbackRequest/distinfo
@@ -0,0 +1,2 @@
+MD5 (Params-CallbackRequest-1.13.tar.gz) = 69183af032eebccd5a7d734ab084b823
+SIZE (Params-CallbackRequest-1.13.tar.gz) = 35264
diff --git a/devel/p5-Params-CallbackRequest/pkg-descr b/devel/p5-Params-CallbackRequest/pkg-descr
new file mode 100644
index 000000000000..d2973640f608
--- /dev/null
+++ b/devel/p5-Params-CallbackRequest/pkg-descr
@@ -0,0 +1,9 @@
+The idea behind this module is to provide a sort of plugin architecture for
+Perl templating systems. Callbacks are executed by the contents of a request
+to the Perl templating server, before the templating system itself executes.
+This approach allows you to carry out logical processing of data submitted
+from a form, to affect the contents of the request parameters before they're
+passed to the templating system for processing, and even to redirect or abort
+the request before the templating system handles it.
+
+WWW: http://search.cpan.org/dist/Params-CallbackRequest/
diff --git a/devel/p5-Params-CallbackRequest/pkg-plist b/devel/p5-Params-CallbackRequest/pkg-plist
new file mode 100644
index 000000000000..ebbe21a6fb89
--- /dev/null
+++ b/devel/p5-Params-CallbackRequest/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Params/CallbackRequest.pm
+%%SITE_PERL%%/Params/Callback.pm
+%%SITE_PERL%%/Params/CallbackRequest/Exceptions.pm
+@dirrm %%SITE_PERL%%/Params/CallbackRequest
+@unexec rmdir %D/%%SITE_PERL%%/Params 2>/dev/null || true