aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-07-03 04:23:00 +0800
committerjgh <jgh@FreeBSD.org>2013-07-03 04:23:00 +0800
commit95419a868edcf89199441b74b6be64ca1a14cd73 (patch)
treef61ddce117e4a8871b57ba9d36b9393ca93499c1 /devel
parent5a59d49b86e773ee27970e933705de3305873863 (diff)
downloadfreebsd-ports-gnome-95419a868edcf89199441b74b6be64ca1a14cd73.tar.gz
freebsd-ports-gnome-95419a868edcf89199441b74b6be64ca1a14cd73.tar.zst
freebsd-ports-gnome-95419a868edcf89199441b74b6be64ca1a14cd73.zip
- update to 1.1.0 and bump shared libraries in respective ports
- while here: - fix option check in sysutils/cfengine34 - move devel/libvirt-glib to use glib20 in favor of gio-fam-backend (suggested by kwm@) - restore ABI version in net-mgmt/collectd5
Diffstat (limited to 'devel')
-rw-r--r--devel/libvirt-glib/Makefile7
-rw-r--r--devel/libvirt-java/Makefile6
-rw-r--r--devel/libvirt/Makefile37
-rw-r--r--devel/p5-Sys-Virt/Makefile3
4 files changed, 22 insertions, 31 deletions
diff --git a/devel/libvirt-glib/Makefile b/devel/libvirt-glib/Makefile
index cec1062f85db..ee0c84d33fb3 100644
--- a/devel/libvirt-glib/Makefile
+++ b/devel/libvirt-glib/Makefile
@@ -3,20 +3,21 @@
PORTNAME= libvirt-glib
PORTVERSION= 0.1.6
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://libvirt.org/libvirt/glib/
MAINTAINER= jgh@FreeBSD.org
COMMENT= Glib bindings for Libvirt virtualization API
-BUILD_DEPENDS= gio-fam-backend>=0:${PORTSDIR}/devel/gio-fam-backend \
- gobject-introspection>=1.34.2:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS= virt.1000:${PORTSDIR}/devel/libvirt
+BUILD_DEPENDS= gobject-introspection>=1.34.2:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS= virt.1001:${PORTSDIR}/devel/libvirt
GNU_CONFIGURE= yes
USES= pathfix pkgconfig
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool
+USE_GNOME= glib20
USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
diff --git a/devel/libvirt-java/Makefile b/devel/libvirt-java/Makefile
index 20a7393f697b..6e93eafca80d 100644
--- a/devel/libvirt-java/Makefile
+++ b/devel/libvirt-java/Makefile
@@ -3,17 +3,17 @@
PORTNAME= libvirt-java
PORTVERSION= 0.4.9
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel java
MASTER_SITES= http://libvirt.org/sources/java/ \
ftp://libvirt.org/libvirt/java/
MAINTAINER= jgh@FreeBSD.org
-COMMENT= Java bindings for the libvirt virtualization API
+COMMENT= Java bindings for Libvirt virtualization API
LICENSE= MIT
-LIB_DEPENDS= virt.1000:${PORTSDIR}/devel/libvirt
+LIB_DEPENDS= virt.1001:${PORTSDIR}/devel/libvirt
BUILD_DEPENDS= jna>=3.2.7:${PORTSDIR}/devel/jna \
junit>=4.8.2:${PORTSDIR}/java/junit
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index ddd73589e1e7..60ccd85e7b78 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libvirt
-PORTVERSION= 1.0.6
-PORTREVISION= 1
+PORTVERSION= 1.1.0
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -19,9 +18,18 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
gnutls:${PORTSDIR}/security/gnutls \
ssh2:${PORTSDIR}/security/libssh2
-OPTIONS_DEFINE= QEMU DOCS
+OPTIONS_DEFINE= QEMU DOCS NLS
QEMU_DESC= QEMU bindings
+OPTIONS_SUB= yes
+
+QEMU_CONFIGURE_ON= --with-qemu
+QEMU_CONFIGURE_OFF= --without-qemu
+
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+NLS_CONFIGURE_ON= --with-libintl-prefix=${LOCALBASE}
+
GNU_CONFIGURE= yes
USE_PERL5_BUILD= yes
CONFIGURE_ARGS= --without-sasl \
@@ -33,7 +41,7 @@ CONFIGURE_ARGS= --without-sasl \
--without-netcf \
--without-network \
--without-sysctl \
- --with-libssh2
+ --with-ssh2
#limit to non-stable release x.x.x
PORTSCOUT= limit:\d+\.\d+\.\d+$$
@@ -44,32 +52,13 @@ USES= charsetfix pathfix
USE_GMAKE= yes
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
-SHLIB_VER= 1000
+SHLIB_VER= 1001
PLIST_SUB= PORTVERSION="-${PORTVERSION}" \
SHLIB_VER=${SHLIB_VER}
PORTDOCS= *
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MQEMU}
-CONFIGURE_ARGS+= --with-qemu
-PLIST_SUB+= QEMU=""
-QEMU_CONFIG= qemu
-.else
-CONFIGURE_ARGS+= --without-qemu
-PLIST_SUB+= QEMU="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-CONFIGURE_ARGS+= --enable-nls \
- --with-libintl-prefix=${LOCALBASE}
-.else
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
MAN1= virsh.1 virt-pki-validate.1 virt-xml-validate.1 virt-host-validate.1
MAN8= libvirtd.8
diff --git a/devel/p5-Sys-Virt/Makefile b/devel/p5-Sys-Virt/Makefile
index d7a2182d330f..e54572ddd9af 100644
--- a/devel/p5-Sys-Virt/Makefile
+++ b/devel/p5-Sys-Virt/Makefile
@@ -3,6 +3,7 @@
PORTNAME= Sys-Virt
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,7 +12,7 @@ MAINTAINER= fw@moov.de
COMMENT= Perl bindings for libvirt
BUILD_DEPENDS= p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath
-LIB_DEPENDS= virt.1000:${PORTSDIR}/devel/libvirt
+LIB_DEPENDS= virt.1001:${PORTSDIR}/devel/libvirt
RUN_DEPENDS= p5-XML-XPath>=0:${PORTSDIR}/textproc/p5-XML-XPath
TEST_DEPENDS= p5-CPAN-Changes>=0:${PORTSDIR}/devel/p5-CPAN-Changes \
p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \