aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-28 02:27:38 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-28 02:27:38 +0800
commit9765657fdf2eb14331ba5555fca4f3e83dc817be (patch)
tree38416e14ebc3b98739f1eee7b5fa5abd6fdf234a /devel
parentae34cb84c7895e42b8e4f5d4e86cebf48c240809 (diff)
downloadfreebsd-ports-gnome-9765657fdf2eb14331ba5555fca4f3e83dc817be.tar.gz
freebsd-ports-gnome-9765657fdf2eb14331ba5555fca4f3e83dc817be.tar.zst
freebsd-ports-gnome-9765657fdf2eb14331ba5555fca4f3e83dc817be.zip
- Switch to USES=libtool, drop .la files
- Strip libraries
Diffstat (limited to 'devel')
-rw-r--r--devel/xxl/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/xxl/Makefile b/devel/xxl/Makefile
index 8aa27c3334f7..b6211dd2fe2c 100644
--- a/devel/xxl/Makefile
+++ b/devel/xxl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xxl
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://launchpadlibrarian.net/39195019/ \
http://www.zork.org/software/
@@ -13,11 +13,12 @@ COMMENT= C/C++ library for exception handling and asset management
LICENSE= BSD3CLAUSE
-USE_AUTOTOOLS= libtool
+USES= libtool
+GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-PLIST_FILES= include/xxl.h lib/libxxl.a lib/libxxl.la lib/libxxl.so \
- lib/libxxl.so.2
+PLIST_FILES= include/xxl.h lib/libxxl.a lib/libxxl.so \
+ lib/libxxl.so.1 lib/libxxl.so.1.1.0
PORTDOCS= xxl.html xxl.pdf
OPTIONS_DEFINE= THREADS DOCS
@@ -28,7 +29,7 @@ THREADS_CONFIGURE_WITH= threads
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libxxl.so.2
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libxxl.so
regression-test test: build
@(cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} \