aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2012-04-26 02:13:59 +0800
committersunpoet <sunpoet@FreeBSD.org>2012-04-26 02:13:59 +0800
commit9f2046aaef2c22b46a44e47dfee11add4f0ea642 (patch)
treeb859959863b95c5e1f75b3e01512611e6b97fd65 /devel
parent9a7fc2e600e186949e7f2b5d26705f20e541ce2e (diff)
downloadfreebsd-ports-gnome-9f2046aaef2c22b46a44e47dfee11add4f0ea642.tar.gz
freebsd-ports-gnome-9f2046aaef2c22b46a44e47dfee11add4f0ea642.tar.zst
freebsd-ports-gnome-9f2046aaef2c22b46a44e47dfee11add4f0ea642.zip
- Add p5-MooseX-App 1.02
MooseX-App is a highly customizeable helper to write user-friendly command-line applications without having to worry about most of the annoying things usually involved. Just take any existing Moose class, add a single line (use MooseX-App qw(PluginA PluginB ...)) and create one class for each command in an underlying namespace. MooseX-App will then take care of - Finding, loading and initializing the command classes - Creating automated doucumentation - Reading and validating the command line options entered by the user Read the Tutorial[1] for getting started with a simple MooseX::App command line application. [1] http://search.cpan.org/dist/MooseX-App/lib/MooseX/App/Tutorial.pod WWW: http://search.cpan.org/dist/MooseX-App/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MooseX-App/Makefile49
-rw-r--r--devel/p5-MooseX-App/distinfo2
-rw-r--r--devel/p5-MooseX-App/pkg-descr17
-rw-r--r--devel/p5-MooseX-App/pkg-plist34
5 files changed, 103 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 08509ad00782..a126fb28902e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2121,6 +2121,7 @@
SUBDIR += p5-Moose-Autobox
SUBDIR += p5-Moose-Policy
SUBDIR += p5-MooseX-Aliases
+ SUBDIR += p5-MooseX-App
SUBDIR += p5-MooseX-App-Cmd
SUBDIR += p5-MooseX-Async
SUBDIR += p5-MooseX-Attribute-Chained
diff --git a/devel/p5-MooseX-App/Makefile b/devel/p5-MooseX-App/Makefile
new file mode 100644
index 000000000000..9900c11e6f04
--- /dev/null
+++ b/devel/p5-MooseX-App/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: p5-MooseX-App
+# Date created: 2012-04-19
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MooseX-App
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Write user-friendly command line apps with even less suffering
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Config-Any>=0:${PORTSDIR}/devel/p5-Config-Any \
+ p5-Moose>=2:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Getopt>=0:${PORTSDIR}/devel/p5-MooseX-Getopt \
+ p5-MooseX-Types-Path-Class>=0:${PORTSDIR}/devel/p5-MooseX-Types-Path-Class \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-Pod-Elemental>=0:${PORTSDIR}/textproc/p5-Pod-Elemental \
+ p5-String-CamelCase>=0:${PORTSDIR}/textproc/p5-String-CamelCase \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Most>=0:${PORTSDIR}/devel/p5-Test-Most \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
+
+PERL_CONFIGURE= 5.10.0+
+
+MAN3= MooseX::App.3 \
+ MooseX::App::Command.3 \
+ MooseX::App::Message::Block.3 \
+ MooseX::App::Message::Envelope.3 \
+ MooseX::App::Meta::Role::Class::Base.3 \
+ MooseX::App::Meta::Role::Class::Command.3 \
+ MooseX::App::Plugin::BashCompletion.3 \
+ MooseX::App::Plugin::Color.3 \
+ MooseX::App::Plugin::Config.3 \
+ MooseX::App::Plugin::ConfigHome.3 \
+ MooseX::App::Role.3 \
+ MooseX::App::Tutorial.3 \
+ MooseX::App::WritingPlugins.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooseX-App/distinfo b/devel/p5-MooseX-App/distinfo
new file mode 100644
index 000000000000..e4ee05a91cd9
--- /dev/null
+++ b/devel/p5-MooseX-App/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MooseX-App-1.02.tar.gz) = 7d7657ecd235dd1ebe4c4f4a7c5ca989dca61d3f8d550076d20837661ec59544
+SIZE (MooseX-App-1.02.tar.gz) = 46206
diff --git a/devel/p5-MooseX-App/pkg-descr b/devel/p5-MooseX-App/pkg-descr
new file mode 100644
index 000000000000..9a5a3120aa8b
--- /dev/null
+++ b/devel/p5-MooseX-App/pkg-descr
@@ -0,0 +1,17 @@
+MooseX-App is a highly customizeable helper to write user-friendly command-line
+applications without having to worry about most of the annoying things usually
+involved. Just take any existing Moose class, add a single line (use MooseX-App
+qw(PluginA PluginB ...)) and create one class for each command in an underlying
+namespace.
+
+MooseX-App will then take care of
+- Finding, loading and initializing the command classes
+- Creating automated doucumentation
+- Reading and validating the command line options entered by the user
+
+Read the Tutorial[1] for getting started with a simple MooseX::App command line
+application.
+
+[1] http://search.cpan.org/dist/MooseX-App/lib/MooseX/App/Tutorial.pod
+
+WWW: http://search.cpan.org/dist/MooseX-App/
diff --git a/devel/p5-MooseX-App/pkg-plist b/devel/p5-MooseX-App/pkg-plist
new file mode 100644
index 000000000000..de5aba7a6d14
--- /dev/null
+++ b/devel/p5-MooseX-App/pkg-plist
@@ -0,0 +1,34 @@
+%%SITE_PERL%%/MooseX/App.pm
+%%SITE_PERL%%/MooseX/App/Base.pm
+%%SITE_PERL%%/MooseX/App/Command.pm
+%%SITE_PERL%%/MooseX/App/Message/Block.pm
+%%SITE_PERL%%/MooseX/App/Message/BlockColor.pm
+%%SITE_PERL%%/MooseX/App/Message/Envelope.pm
+%%SITE_PERL%%/MooseX/App/Meta/Role/Attribute.pm
+%%SITE_PERL%%/MooseX/App/Meta/Role/Class/Base.pm
+%%SITE_PERL%%/MooseX/App/Meta/Role/Class/Command.pm
+%%SITE_PERL%%/MooseX/App/Plugin/BashCompletion.pm
+%%SITE_PERL%%/MooseX/App/Plugin/BashCompletion/Command.pm
+%%SITE_PERL%%/MooseX/App/Plugin/BashCompletion/Meta/Class.pm
+%%SITE_PERL%%/MooseX/App/Plugin/Color.pm
+%%SITE_PERL%%/MooseX/App/Plugin/Color/Meta/Class.pm
+%%SITE_PERL%%/MooseX/App/Plugin/Config.pm
+%%SITE_PERL%%/MooseX/App/Plugin/ConfigHome.pm
+%%SITE_PERL%%/MooseX/App/Role.pm
+%%SITE_PERL%%/MooseX/App/Tutorial.pod
+%%SITE_PERL%%/MooseX/App/Utils.pm
+%%SITE_PERL%%/MooseX/App/WritingPlugins.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/App/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX/App
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/MooseX
+@dirrmtry %%SITE_PERL%%/MooseX/App/Plugin/Color/Meta
+@dirrmtry %%SITE_PERL%%/MooseX/App/Plugin/Color
+@dirrmtry %%SITE_PERL%%/MooseX/App/Plugin/BashCompletion/Meta
+@dirrmtry %%SITE_PERL%%/MooseX/App/Plugin/BashCompletion
+@dirrmtry %%SITE_PERL%%/MooseX/App/Plugin
+@dirrmtry %%SITE_PERL%%/MooseX/App/Meta/Role/Class
+@dirrmtry %%SITE_PERL%%/MooseX/App/Meta/Role
+@dirrmtry %%SITE_PERL%%/MooseX/App/Meta
+@dirrmtry %%SITE_PERL%%/MooseX/App/Message
+@dirrmtry %%SITE_PERL%%/MooseX/App
+@dirrmtry %%SITE_PERL%%/MooseX
44/cgit/freebsd-ports-gnome/commit/multimedia/mythtv?h=dependabot/npm_and_yarn/devel/electron6/files/ini-1.3.8&id=f7653cb423fcf47cc35d8fba3fe04e2454d2cb41'>- Update to 0.24.2decke2012-02-013-7/+6 * Update lame to 3.99.3.netchild2012-01-151-1/+1 * In the rc.d scripts, change assignments to rcvar to use thedougb2012-01-141-1/+1 * - Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)amdmi32011-09-241-1/+2 * - Update again because they rerolled the distfile and fixed the directory str...decke2011-05-232-3/+3 * - Update to 0.24.1decke2011-05-203-6/+9 * Remove painful examples of foo="", with particular prejudice againstdougb2011-05-151-1/+0 * Update to GNU make 3.82 after numerous -exp runs.ade2011-04-121-41/+11 * Bump PORTREVISION for ports linking to default libmysqlclient.ale2011-03-191-0/+1 * - Update comms/lirc to 0.9.0p1_4 in order to be able to use the lircnox2011-02-271-1/+1 * - Update to 0.24decke2011-01-0510-336/+845 * - Update MythTV MASTER_SITES for old releasesdecke2010-12-091-1/+3 * - Fix build with upcoming Qt 4.7decke2010-12-033-0/+89 * Switch libvdpau dependency from x11/nvidia-driver to multimedia/libvdpaumakc2010-09-251-3/+2 * - Update to 0.23.1decke2010-08-06