aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2011-09-20 16:41:24 +0800
committerbapt <bapt@FreeBSD.org>2011-09-20 16:41:24 +0800
commita03d31a9b21c3f1d10ea7d704f0b48712138167d (patch)
tree06610a0bd9faedfa670cd5b297409b69b7718a9f /devel
parent74e03bba1782856abfe43f9d6f0bbc3b611f7dcb (diff)
downloadfreebsd-ports-gnome-a03d31a9b21c3f1d10ea7d704f0b48712138167d.tar.gz
freebsd-ports-gnome-a03d31a9b21c3f1d10ea7d704f0b48712138167d.tar.zst
freebsd-ports-gnome-a03d31a9b21c3f1d10ea7d704f0b48712138167d.zip
String::Formatter is a tool for building sprintf-like formatting
routines. It supports named or positional formatting, custom conversions, fixed string interpolation, and simple width-matching out of the box. WWW: http://search.cpan.org/dist/String-Formatter/ Submitted by: Geraud CONTINSOUZAS <geraud@gcu.info> (by private mail)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-String-Formatter/Makefile28
-rw-r--r--devel/p5-String-Formatter/distinfo2
-rw-r--r--devel/p5-String-Formatter/pkg-descr6
-rw-r--r--devel/p5-String-Formatter/pkg-plist8
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ce0e3db9224d..0c4cb20ce73c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2291,6 +2291,7 @@
SUBDIR += p5-String-Checker
SUBDIR += p5-String-Diff
SUBDIR += p5-String-Ediff
+ SUBDIR += p5-String-Formatter
SUBDIR += p5-String-LRC
SUBDIR += p5-String-Parity
SUBDIR += p5-String-Random
diff --git a/devel/p5-String-Formatter/Makefile b/devel/p5-String-Formatter/Makefile
new file mode 100644
index 000000000000..d7e656142147
--- /dev/null
+++ b/devel/p5-String-Formatter/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-String-Formatter
+# Date created: 2011-09-19
+# Whom: Geraud CONTINSOUZAS <geraud@gcu.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= String-Formatter
+PORTVERSION= 0.102082
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= geraud@gcu.info
+COMMENT= Build sprintf-like functions of your own
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= p5-Params-Util>=0:${PORTSDIR}/devel/p5-Params-Util \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= String::Formatter.3 \
+ String::Formatter::Cookbook.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-String-Formatter/distinfo b/devel/p5-String-Formatter/distinfo
new file mode 100644
index 000000000000..9012d1889088
--- /dev/null
+++ b/devel/p5-String-Formatter/distinfo
@@ -0,0 +1,2 @@
+SHA256 (String-Formatter-0.102082.tar.gz) = 93d787dd8f13832a3683d219e086eaf4eb6c5391e396bfcc364c414423b0051a
+SIZE (String-Formatter-0.102082.tar.gz) = 17608
diff --git a/devel/p5-String-Formatter/pkg-descr b/devel/p5-String-Formatter/pkg-descr
new file mode 100644
index 000000000000..3177c6d5a342
--- /dev/null
+++ b/devel/p5-String-Formatter/pkg-descr
@@ -0,0 +1,6 @@
+String::Formatter is a tool for building sprintf-like formatting
+routines. It supports named or positional formatting, custom
+conversions, fixed string interpolation, and simple width-matching out
+of the box.
+
+WWW: http://search.cpan.org/dist/String-Formatter/
diff --git a/devel/p5-String-Formatter/pkg-plist b/devel/p5-String-Formatter/pkg-plist
new file mode 100644
index 000000000000..11f276d432f8
--- /dev/null
+++ b/devel/p5-String-Formatter/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/String/bench.pl
+%%SITE_PERL%%/String/Formatter.pm
+%%SITE_PERL%%/String/Formatter/Cookbook.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Formatter/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String/Formatter
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/String
+@dirrmtry %%SITE_PERL%%/String/Formatter
+@dirrmtry %%SITE_PERL%%/String