aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-11-12 17:12:35 +0800
committerrafan <rafan@FreeBSD.org>2008-11-12 17:12:35 +0800
commita0d960eaf384a8fe04bcea19a5dcb4663fd57406 (patch)
tree47cfb395c46f3f137e86dd065e667d93d70dbc07 /devel
parent57d9a1ca81bfc48cda98d8a3bf3f1983f5df0aa6 (diff)
downloadfreebsd-ports-gnome-a0d960eaf384a8fe04bcea19a5dcb4663fd57406.tar.gz
freebsd-ports-gnome-a0d960eaf384a8fe04bcea19a5dcb4663fd57406.tar.zst
freebsd-ports-gnome-a0d960eaf384a8fe04bcea19a5dcb4663fd57406.zip
- Add an option to enable 256 color support
Requested by: Kevin Kobb <kkobb at skylinecorp.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/ncurses/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/ncurses/Makefile b/devel/ncurses/Makefile
index 7cf956b84e9a..fcb206bca26a 100644
--- a/devel/ncurses/Makefile
+++ b/devel/ncurses/Makefile
@@ -30,6 +30,8 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share/misc --disable-overwrite \
--enable-rpath --disable-root-environ \
--with-manpage-format=gzip --srcdir=../
+OPTIONS= EXTCOLORS "Enable 256-color support (only for ncursesw)" off
+
# needed by devel/py-ncurses port
.if defined(WITH_TRACE)
CONFIGURE_ARGS+= --with-trace
@@ -80,6 +82,11 @@ EXAMPLES_CPP= Makefile NEWS PROBLEMS README-first cursesapp.cc \
WITHOUT_WIDEC= yes
.endif
+CONFIGURE_ARGS_WIDEC=--enable-widec
+.if defined(WITH_EXTCOLORS)
+CONFIGURE_ARGS_WIDEC+=--enable-ext-colors
+.endif
+
.if !defined(WITHOUT_PROFILE) && !defined(NO_PROFILE) && !defined(NOPROFILE)
CONFIGURE_ARGS+=--with-profile
PLIST_SUB+= PROFILE=""
@@ -122,7 +129,7 @@ post-configure:
.if !defined(WITHOUT_WIDEC)
cd ${.CURDIR} && \
${MAKE} ${.MAKEFLAGS} CONFIGURE_WRKSRC=${WIDEC_WRKSRC} \
- CONFIGURE_ARGS="${CONFIGURE_ARGS} --enable-widec" \
+ CONFIGURE_ARGS="${CONFIGURE_ARGS} ${CONFIGURE_ARGS_WIDEC}" \
do-configure
.endif
.for d in test c++