aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordbaio <dbaio@FreeBSD.org>2017-08-30 08:25:10 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:26:58 +0800
commita6077139d30dbfcfb7e2e4b8e77fa0b5879aa880 (patch)
treecfc58a030e5f689fc316c2ffcfb5e4b2ba09a5f8 /devel
parent0cbbde607df24e440bc87be193189d2a56a232c0 (diff)
downloadfreebsd-ports-gnome-a6077139d30dbfcfb7e2e4b8e77fa0b5879aa880.tar.gz
freebsd-ports-gnome-a6077139d30dbfcfb7e2e4b8e77fa0b5879aa880.tar.zst
freebsd-ports-gnome-a6077139d30dbfcfb7e2e4b8e77fa0b5879aa880.zip
New port devel/py-pyqtree: Pure Python quad tree spatial index for GIS or rendering usage
Pyqtree is a pure Python spatial index for GIS or rendering usage. It storesand quickly retrieves items from a 2x2 rectangular grid area, and grows in depth and detail as more items are added. The actual quad tree implementation is adapted from Matt Rasmussen's compbio library and extended for geospatial use. WWW: https://github.com/karimbahgat/Pyqtree PR: 221730 Submitted by: lbartoletti@tuxfamily.org
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyqtree/Makefile21
-rw-r--r--devel/py-pyqtree/distinfo3
-rw-r--r--devel/py-pyqtree/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 72cc31ea3692..3ec6b4743e6c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4685,6 +4685,7 @@
SUBDIR += py-pyperclip
SUBDIR += py-pypugjs
SUBDIR += py-pyqi
+ SUBDIR += py-pyqtree
SUBDIR += py-pyral
SUBDIR += py-pyrfc3339
SUBDIR += py-pyro
diff --git a/devel/py-pyqtree/Makefile b/devel/py-pyqtree/Makefile
new file mode 100644
index 000000000000..f1b0dc976bf9
--- /dev/null
+++ b/devel/py-pyqtree/Makefile
@@ -0,0 +1,21 @@
+# Created by: Loïc BARTOLETTI <lbartoletti@tuxfamily.org>
+# $FreeBSD$
+
+PORTNAME= pyqtree
+PORTVERSION= 0.24
+CATEGORIES= devel python geography
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= Pyqtree-${PORTVERSION}
+
+MAINTAINER= lbartoletti@tuxfamily.org
+COMMENT= Pure Python quad tree spatial index for GIS or rendering usage
+
+LICENSE= MIT
+
+NO_ARCH= yes
+
+USES= python zip
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyqtree/distinfo b/devel/py-pyqtree/distinfo
new file mode 100644
index 000000000000..abdff697b59c
--- /dev/null
+++ b/devel/py-pyqtree/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1503871819
+SHA256 (Pyqtree-0.24.zip) = e20a8e53a2ce0db9c824eba3144a550a804bd57c28454f18f2948db9ce97b555
+SIZE (Pyqtree-0.24.zip) = 8824
diff --git a/devel/py-pyqtree/pkg-descr b/devel/py-pyqtree/pkg-descr
new file mode 100644
index 000000000000..8f76ef125cfb
--- /dev/null
+++ b/devel/py-pyqtree/pkg-descr
@@ -0,0 +1,6 @@
+Pyqtree is a pure Python spatial index for GIS or rendering usage. It storesand
+quickly retrieves items from a 2x2 rectangular grid area, and grows in depth and
+detail as more items are added. The actual quad tree implementation is adapted
+from Matt Rasmussen's compbio library and extended for geospatial use.
+
+WWW: https://github.com/karimbahgat/Pyqtree