aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-07-04 01:46:11 +0800
committerrm <rm@FreeBSD.org>2012-07-04 01:46:11 +0800
commitb0ec23e875ae7b4858a8b11faef238816e1fca43 (patch)
tree7130ee93f555567d255ce642432d576b37f62696 /devel
parentb4d784cec20d5bbd8940cea3d406bd56db3d5718 (diff)
downloadfreebsd-ports-gnome-b0ec23e875ae7b4858a8b11faef238816e1fca43.tar.gz
freebsd-ports-gnome-b0ec23e875ae7b4858a8b11faef238816e1fca43.tar.zst
freebsd-ports-gnome-b0ec23e875ae7b4858a8b11faef238816e1fca43.zip
- add patch to fix import of twisted/internet/gtk2reactor.py (to fix runtime of
net-p2p/deluge at least) [1] - remove BUILD_DEPENDS and LICENSE_FILE - strict to python 2.x only - tab twiddling - bump PORTREVISION Reported by: many (via python@) [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/py-twistedCore/Makefile14
-rw-r--r--devel/py-twistedCore/files/patch-twisted-internet_gtk2reactor.py11
-rw-r--r--devel/py-twistedCore/pkg-descr8
3 files changed, 22 insertions, 11 deletions
diff --git a/devel/py-twistedCore/Makefile b/devel/py-twistedCore/Makefile
index 4642171201f1..a484cee3c146 100644
--- a/devel/py-twistedCore/Makefile
+++ b/devel/py-twistedCore/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: py-twisted
-# Date created: 13 April 2005
-# Whom: Neal Nelson <neal@nelson.name>
+# Date created: 13 April 2005
+# Whom: Neal Nelson <neal@nelson.name>
#
# $FreeBSD$
#
PORTNAME= twistedCore
PORTVERSION= 12.1.0
+PORTREVISION= 1
CATEGORIES= devel net python
MASTER_SITES= http://twistedmatrix.com/Releases/Core/${PORTVERSION:R}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,10 +17,8 @@ MAINTAINER= python@FreeBSD.org
COMMENT= An asynchronous networking framework for Python - Core module
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.3.0_1:${PORTSDIR}/devel/py-zope.interface
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}zope.interface>=3.3.0:${PORTSDIR}/devel/py-zope.interface
# - Note that Twisted ships with some graphical examples and clients that
# require PyGNOME to run. These are not central to the funcitoning of
@@ -27,12 +26,15 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
# separately if desired.
USE_BZIP2= yes
-USE_PYTHON= yes
+USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= ${PORTNAME:S/twisted/Twisted_/}
MAN1= manhole.1 pyhtmlizer.1 tap2deb.1 tap2rpm.1 tapconvert.1 trial.1 twistd.1
+post-patch:
+ @${FIND} ${WRKSRC} -type f -name "*.orig" -delete
+
post-install:
# permission safeness
@${CHMOD} -R ${SHAREMODE} ${PYTHONPREFIX_SITELIBDIR}/twisted/
diff --git a/devel/py-twistedCore/files/patch-twisted-internet_gtk2reactor.py b/devel/py-twistedCore/files/patch-twisted-internet_gtk2reactor.py
new file mode 100644
index 000000000000..4a0c2c0b0282
--- /dev/null
+++ b/devel/py-twistedCore/files/patch-twisted-internet_gtk2reactor.py
@@ -0,0 +1,11 @@
+--- twisted/internet/gtk2reactor.py.orig 2012-07-03 21:24:23.000000000 +0400
++++ twisted/internet/gtk2reactor.py 2012-07-03 21:24:45.000000000 +0400
+@@ -27,7 +27,7 @@
+ ["gi"],
+ "Introspected and static glib/gtk bindings must not be mixed; can't "
+ "import gtk2reactor since gi module is already imported.",
+- preventImports=["gi"])
++ preventImports=[""])
+
+ try:
+ if not hasattr(sys, 'frozen'):
diff --git a/devel/py-twistedCore/pkg-descr b/devel/py-twistedCore/pkg-descr
index 704ea5bbdb28..370c18c93ce8 100644
--- a/devel/py-twistedCore/pkg-descr
+++ b/devel/py-twistedCore/pkg-descr
@@ -4,16 +4,14 @@ Twisted projects.
* twisted.cred, a pluggable authentication system for servers;
* twisted.enterprise, an asynchronous adapter of Python DB-API 2.0 database
- interfaces;
+ interfaces;
* twisted.internet, the Twisted event loop;
* twisted.manhole, a debugging service;
* twisted.persisted, a collection of object persistence systems
* twisted.protocols, a collection of simple network protocols and helper
- utilities;
+ utilities;
* twisted.python, a set of Twisted programming abstractions;
* twisted.spread, a network transport, serializer and object broker;
* twisted.trial, a unit-testing framework; and
-Twisted is available under the MIT Free Software licence.
-
-WWW: http://twistedmatrix.com/
+WWW: http://twistedmatrix.com/