aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2016-07-20 19:09:09 +0800
committerolgeni <olgeni@FreeBSD.org>2016-07-20 19:09:09 +0800
commitb5dfe82353403716c90a602e8dbb1d3b6168d489 (patch)
tree3975a1f4ce2dd8927fd26316a924122eb7f0efb2 /devel
parent2afcd3b6ad5f06d3067961169a53647734b3e377 (diff)
downloadfreebsd-ports-gnome-b5dfe82353403716c90a602e8dbb1d3b6168d489.tar.gz
freebsd-ports-gnome-b5dfe82353403716c90a602e8dbb1d3b6168d489.tar.zst
freebsd-ports-gnome-b5dfe82353403716c90a602e8dbb1d3b6168d489.zip
Add devel/elixir-nimble_csv, a simple and fast CSV parsing and
dumping library for Elixir.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/elixir-nimble_csv/Makefile20
-rw-r--r--devel/elixir-nimble_csv/distinfo3
-rw-r--r--devel/elixir-nimble_csv/pkg-descr3
-rw-r--r--devel/elixir-nimble_csv/pkg-plist6
5 files changed, 33 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 421f4652a71c..0422a9d21713 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -454,6 +454,7 @@
SUBDIR += elixir-lager_logger
SUBDIR += elixir-msgpax
SUBDIR += elixir-nadia
+ SUBDIR += elixir-nimble_csv
SUBDIR += elixir-paratize
SUBDIR += elixir-plug
SUBDIR += elixir-poison
diff --git a/devel/elixir-nimble_csv/Makefile b/devel/elixir-nimble_csv/Makefile
new file mode 100644
index 000000000000..875b3844ab5b
--- /dev/null
+++ b/devel/elixir-nimble_csv/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= nimble_csv
+PORTVERSION= 0.1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+PKGNAMEPREFIX= elixir-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= CSV parsing and dumping library for Elixir
+
+LICENSE= APACHE20
+
+USES= elixir
+USE_GITHUB= yes
+GH_ACCOUNT= plataformatec
+
+MIX_REWRITE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/elixir-nimble_csv/distinfo b/devel/elixir-nimble_csv/distinfo
new file mode 100644
index 000000000000..746229055080
--- /dev/null
+++ b/devel/elixir-nimble_csv/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1469007729
+SHA256 (plataformatec-nimble_csv-v0.1.0_GH0.tar.gz) = cf3fb18786dac4ca5c805b307dfdfc5557eb04ec14269d8fd7242f0d26c742ac
+SIZE (plataformatec-nimble_csv-v0.1.0_GH0.tar.gz) = 5257
diff --git a/devel/elixir-nimble_csv/pkg-descr b/devel/elixir-nimble_csv/pkg-descr
new file mode 100644
index 000000000000..787b65ed37d9
--- /dev/null
+++ b/devel/elixir-nimble_csv/pkg-descr
@@ -0,0 +1,3 @@
+A simple and fast CSV parsing and dumping library for Elixir.
+
+WWW: https://github.com/plataformatec/nimble_csv
diff --git a/devel/elixir-nimble_csv/pkg-plist b/devel/elixir-nimble_csv/pkg-plist
new file mode 100644
index 000000000000..8413d0729344
--- /dev/null
+++ b/devel/elixir-nimble_csv/pkg-plist
@@ -0,0 +1,6 @@
+lib/elixir/lib/nimble_csv/ebin/Elixir.NimbleCSV.ParseError.beam
+lib/elixir/lib/nimble_csv/ebin/Elixir.NimbleCSV.RFC4180.beam
+lib/elixir/lib/nimble_csv/ebin/Elixir.NimbleCSV.beam
+lib/elixir/lib/nimble_csv/ebin/nimble_csv.app
+lib/elixir/lib/nimble_csv/lib/nimble_csv.ex
+%%PORTDOCS%%%%DOCSDIR%%/README.md