aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2015-05-16 19:54:51 +0800
committerkuriyama <kuriyama@FreeBSD.org>2015-05-16 19:54:51 +0800
commitb87b4ddf6992d88978b18b12e185f0fd3de346c9 (patch)
tree3b8ba1d9089e21fc588d73813ce2eb271e99f5df /devel
parent9c406e85c23bbaeea3deab382106447955a0e127 (diff)
downloadfreebsd-ports-gnome-b87b4ddf6992d88978b18b12e185f0fd3de346c9.tar.gz
freebsd-ports-gnome-b87b4ddf6992d88978b18b12e185f0fd3de346c9.tar.zst
freebsd-ports-gnome-b87b4ddf6992d88978b18b12e185f0fd3de346c9.zip
This is a sister module of Parse::PMFile. This module parses local
.pm files (and a META file if any) in a specific (current if not specified) directory, and returns a hash reference that represents "provides" information (with some extra meta data). This is almost the same as Module::Metadata does (which has been in Perl core since Perl 5.13.9). The main difference is the most of the code of this module is directly taken from the PAUSE code as of June 2013. If you need better compatibility to PAUSE, try this. If you need better performance, safety, or portability in general, Module::Metadata may be a better and handier option (Parse::PMFile (and thus Parse::LocalDistribution) actually evaluates code in the $VERSION line (in a Safe compartment), which may be problematic in some cases). WWW: http://search.cpan.org/dist/Parse-LocalDistribution/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Parse-LocalDistribution/Makefile24
-rw-r--r--devel/p5-Parse-LocalDistribution/distinfo2
-rw-r--r--devel/p5-Parse-LocalDistribution/pkg-descr14
-rw-r--r--devel/p5-Parse-LocalDistribution/pkg-plist2
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 244d8caf0f0b..0392bcf2ddb8 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2685,6 +2685,7 @@
SUBDIR += p5-Parse-CPAN-Packages-Fast
SUBDIR += p5-Parse-ErrorString-Perl
SUBDIR += p5-Parse-ExuberantCTags
+ SUBDIR += p5-Parse-LocalDistribution
SUBDIR += p5-Parse-Method-Signatures
SUBDIR += p5-Parse-PMFile
SUBDIR += p5-Parse-PerlConfig
diff --git a/devel/p5-Parse-LocalDistribution/Makefile b/devel/p5-Parse-LocalDistribution/Makefile
new file mode 100644
index 000000000000..3b53722d5ac3
--- /dev/null
+++ b/devel/p5-Parse-LocalDistribution/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= Parse-LocalDistribution
+PORTVERSION= 0.15
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to parses local .pm files as PAUSE does
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+RUN_DEPENDS= \
+ p5-Parse-PMFile>=0.35:${PORTSDIR}/devel/p5-Parse-PMFile
+BUILD_DEPENDS= ${RUN_DEPENDS} \
+ p5-ExtUtils-MakeMaker-CPANfile>0:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker-CPANfile
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH= YES
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Parse-LocalDistribution/distinfo b/devel/p5-Parse-LocalDistribution/distinfo
new file mode 100644
index 000000000000..b90c085c2936
--- /dev/null
+++ b/devel/p5-Parse-LocalDistribution/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Parse-LocalDistribution-0.15.tar.gz) = 8b0f5bf64c6f45bb9706bd526ec2a91a58fc874ef8d2f5df6236980a03ccc68a
+SIZE (Parse-LocalDistribution-0.15.tar.gz) = 8204
diff --git a/devel/p5-Parse-LocalDistribution/pkg-descr b/devel/p5-Parse-LocalDistribution/pkg-descr
new file mode 100644
index 000000000000..8270b4d26d2a
--- /dev/null
+++ b/devel/p5-Parse-LocalDistribution/pkg-descr
@@ -0,0 +1,14 @@
+This is a sister module of Parse::PMFile. This module parses local
+.pm files (and a META file if any) in a specific (current if not
+specified) directory, and returns a hash reference that represents
+"provides" information (with some extra meta data). This is almost
+the same as Module::Metadata does (which has been in Perl core since
+Perl 5.13.9). The main difference is the most of the code of this
+module is directly taken from the PAUSE code as of June 2013. If you
+need better compatibility to PAUSE, try this. If you need better
+performance, safety, or portability in general, Module::Metadata may
+be a better and handier option (Parse::PMFile (and thus
+Parse::LocalDistribution) actually evaluates code in the $VERSION line
+(in a Safe compartment), which may be problematic in some cases).
+
+WWW: http://search.cpan.org/dist/Parse-LocalDistribution/
diff --git a/devel/p5-Parse-LocalDistribution/pkg-plist b/devel/p5-Parse-LocalDistribution/pkg-plist
new file mode 100644
index 000000000000..0e516a1631a3
--- /dev/null
+++ b/devel/p5-Parse-LocalDistribution/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Parse/LocalDistribution.pm
+%%PERL5_MAN3%%/Parse::LocalDistribution.3.gz