aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-08-06 22:20:08 +0800
committerlofi <lofi@FreeBSD.org>2004-08-06 22:20:08 +0800
commitb93b462748fa3294fce396a4f20d3045d2a369dc (patch)
tree209f2e60cae5e2b4dada096ae568769d0a3552fc /devel
parentcb44c5412dbad2df42c8b941553ae7581b8eecad (diff)
downloadfreebsd-ports-gnome-b93b462748fa3294fce396a4f20d3045d2a369dc.tar.gz
freebsd-ports-gnome-b93b462748fa3294fce396a4f20d3045d2a369dc.tar.zst
freebsd-ports-gnome-b93b462748fa3294fce396a4f20d3045d2a369dc.zip
Instead, depend on it if WITH_OPTIONAL_DEPENDS is defined and ARCH is i386.
Submitted by: Simon Barner <barner@in.tum.de> Pointy hat for missing that patch while reading the mail: me
Diffstat (limited to 'devel')
-rw-r--r--devel/kdesdk3/Makefile19
-rw-r--r--devel/kdesdk4/Makefile19
2 files changed, 34 insertions, 4 deletions
diff --git a/devel/kdesdk3/Makefile b/devel/kdesdk3/Makefile
index ec66ba5f9e42..d84d501240dd 100644
--- a/devel/kdesdk3/Makefile
+++ b/devel/kdesdk3/Makefile
@@ -31,9 +31,24 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+pre-everything::
+.if !defined(WITH_OPTIONAL_DEPENDS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You may define WITH_OPTIONAL_DEPENDS (make WITH_OPTIONAL_DEPENDS=YES)"
+ @${ECHO_MSG} "to automatically build the suggested programs to complement kdesdk3."
+ @${ECHO_MSG}
+.endif
+
+# calltree is optional. It depends on valgrind, which is i386 only.
+.if defined(WITH_OPTIONAL_DEPENDS) && ${ARCH} == "i386"
+RUN_DEPENDS+= calltree:${PORTSDIR}/devel/calltree
+.endif
+
pre-configure:
@${REINPLACE_CMD} -e 's|-I$$ac_db_includes|-I${LOCALBASE}/include/db4|g' \
-e 's|ac_db_name="db"|ac_db_name="db4"|g' ${WRKSRC}/configure
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/kdesdk4/Makefile b/devel/kdesdk4/Makefile
index ec66ba5f9e42..d84d501240dd 100644
--- a/devel/kdesdk4/Makefile
+++ b/devel/kdesdk4/Makefile
@@ -31,9 +31,24 @@ GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/kde3
+.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
+.include <bsd.port.pre.mk>
+
+pre-everything::
+.if !defined(WITH_OPTIONAL_DEPENDS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You may define WITH_OPTIONAL_DEPENDS (make WITH_OPTIONAL_DEPENDS=YES)"
+ @${ECHO_MSG} "to automatically build the suggested programs to complement kdesdk3."
+ @${ECHO_MSG}
+.endif
+
+# calltree is optional. It depends on valgrind, which is i386 only.
+.if defined(WITH_OPTIONAL_DEPENDS) && ${ARCH} == "i386"
+RUN_DEPENDS+= calltree:${PORTSDIR}/devel/calltree
+.endif
+
pre-configure:
@${REINPLACE_CMD} -e 's|-I$$ac_db_includes|-I${LOCALBASE}/include/db4|g' \
-e 's|ac_db_name="db"|ac_db_name="db4"|g' ${WRKSRC}/configure
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>