aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-12 02:06:41 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-12 02:06:41 +0800
commitbc405a91614e3d391faf567ec9312cfa29605541 (patch)
tree963698efd1567a114e621875553508100d5a416e /devel
parent911aad1f956f8193797a5af28658a413274d2642 (diff)
downloadfreebsd-ports-gnome-bc405a91614e3d391faf567ec9312cfa29605541.tar.gz
freebsd-ports-gnome-bc405a91614e3d391faf567ec9312cfa29605541.tar.zst
freebsd-ports-gnome-bc405a91614e3d391faf567ec9312cfa29605541.zip
- Update to 3.12.0
- Convert to new LIB_DEPENDS format Changes: - Moved server functions out of libdap; they are now stored in a BES module. - Added support for building large (constant) arrays to be used in server functions. The arrays are defined using a new special form that the ConstraintEvaluator class supports. The server side functions are now in their own BES module (built as part of the BES for now) and it's possible to name the constant arrays. Arrays of 1 million elements can be made in a fraction of a second (although it will take longer to send the constraint to the server). See the README file for more details.
Diffstat (limited to 'devel')
-rw-r--r--devel/libdap/Makefile9
-rw-r--r--devel/libdap/distinfo4
-rw-r--r--devel/libdap/pkg-plist33
3 files changed, 28 insertions, 18 deletions
diff --git a/devel/libdap/Makefile b/devel/libdap/Makefile
index 2e0017212b82..a0f21a6d17e2 100644
--- a/devel/libdap/Makefile
+++ b/devel/libdap/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libdap
-PORTVERSION= 3.11.7
-PORTREVISION= 1
+PORTVERSION= 3.12.0
CATEGORIES= devel
MASTER_SITES= http://www.opendap.org/pub/source/ \
LOCAL/sunpoet
@@ -11,9 +10,9 @@ MASTER_SITES= http://www.opendap.org/pub/source/ \
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= SDK which contains an implementation of DAP 2.0 and 3.1
-LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl \
- uuid:${PORTSDIR}/misc/e2fsprogs-libuuid \
- xml2:${PORTSDIR}/textproc/libxml2
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
+ libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid \
+ libxml2.so:${PORTSDIR}/textproc/libxml2
CONFIGURE_ARGS= --with-zlib=/usr
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/libdap/distinfo b/devel/libdap/distinfo
index 032ac648d355..0dc4045c207c 100644
--- a/devel/libdap/distinfo
+++ b/devel/libdap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libdap-3.11.7.tar.gz) = 24aae62e76609b2738fbc25ec60661e2c76af06890057d4529a89a320a7eccea
-SIZE (libdap-3.11.7.tar.gz) = 1503698
+SHA256 (libdap-3.12.0.tar.gz) = e80401f9f5710b4e297d9e6d337617f025203c6883117805609b3f09c1f5aa7b
+SIZE (libdap-3.12.0.tar.gz) = 1505398
diff --git a/devel/libdap/pkg-plist b/devel/libdap/pkg-plist
index b677be90cf6a..fa28b13875c2 100644
--- a/devel/libdap/pkg-plist
+++ b/devel/libdap/pkg-plist
@@ -4,7 +4,6 @@ bin/getdap
include/libdap/AlarmHandler.h
include/libdap/Ancillary.h
include/libdap/Array.h
-include/libdap/ArrayGeoConstraint.h
include/libdap/AttrTable.h
include/libdap/BaseType.h
include/libdap/BaseTypeFactory.h
@@ -13,7 +12,6 @@ include/libdap/Clause.h
include/libdap/Connect.h
include/libdap/ConstraintEvaluator.h
include/libdap/Constructor.h
-include/libdap/DAPCache3.h
include/libdap/DAS.h
include/libdap/DDS.h
include/libdap/DDXExceptions.h
@@ -28,11 +26,8 @@ include/libdap/EventHandler.h
include/libdap/Float32.h
include/libdap/Float64.h
include/libdap/GNURegex.h
-include/libdap/GSEClause.h
-include/libdap/GeoConstraint.h
include/libdap/GetOpt.h
include/libdap/Grid.h
-include/libdap/GridGeoConstraint.h
include/libdap/HTTPCache.h
include/libdap/HTTPCacheDisconnectedMode.h
include/libdap/HTTPCacheInterruptHandler.h
@@ -52,9 +47,10 @@ include/libdap/RCReader.h
include/libdap/RValue.h
include/libdap/Resource.h
include/libdap/Response.h
-include/libdap/ResponseBuilder.h
include/libdap/ResponseTooBigErr.h
include/libdap/Sequence.h
+include/libdap/ServerFunction.h
+include/libdap/ServerFunctionsList.h
include/libdap/SignalHandler.h
include/libdap/SignalHandlerRegisteredErr.h
include/libdap/StdinResponse.h
@@ -71,7 +67,6 @@ include/libdap/XDRStreamMarshaller.h
include/libdap/XDRStreamUnMarshaller.h
include/libdap/XDRUtils.h
include/libdap/XMLWriter.h
-include/libdap/ce_functions.h
include/libdap/ce_parser.h
include/libdap/cgi_util.h
include/libdap/debug.h
@@ -79,26 +74,42 @@ include/libdap/dods-datatypes.h
include/libdap/dods-limits.h
include/libdap/escaping.h
include/libdap/expr.h
-include/libdap/gse_parser.h
include/libdap/mime_util.h
include/libdap/parser.h
+include/libdap/test/TestArray.h
+include/libdap/test/TestByte.h
+include/libdap/test/TestCommon.h
+include/libdap/test/TestFloat32.h
+include/libdap/test/TestFloat64.h
+include/libdap/test/TestGrid.h
+include/libdap/test/TestInt16.h
+include/libdap/test/TestInt32.h
+include/libdap/test/TestSequence.h
+include/libdap/test/TestStr.h
+include/libdap/test/TestStructure.h
+include/libdap/test/TestTypeFactory.h
+include/libdap/test/TestUInt16.h
+include/libdap/test/TestUInt32.h
+include/libdap/test/TestUrl.h
include/libdap/util.h
include/libdap/util_mit.h
include/libdap/xdr-datatypes.h
lib/libdap.a
lib/libdap.la
lib/libdap.so
-lib/libdap.so.15
+lib/libdap.so.16
lib/libdapclient.a
lib/libdapclient.la
lib/libdapclient.so
-lib/libdapclient.so.4
+lib/libdapclient.so.5
lib/libdapserver.a
lib/libdapserver.la
lib/libdapserver.so
-lib/libdapserver.so.11
+lib/libdapserver.so.12
+lib/libtest-types.a
libdata/pkgconfig/libdap.pc
libdata/pkgconfig/libdapclient.pc
libdata/pkgconfig/libdapserver.pc
share/aclocal/libdap.m4
+@dirrm include/libdap/test
@dirrm include/libdap