aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-04-18 01:06:33 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-04-18 01:06:33 +0800
commitc0f8af37ee6cc01a7ecf8d960acdf5f5fe29ad79 (patch)
treeddc1dcd8a68bf3e0ad33d8e482fc33a7d53226d3 /devel
parent05ccf0fb229902922c2dd02c28a77c466291c8f4 (diff)
downloadfreebsd-ports-gnome-c0f8af37ee6cc01a7ecf8d960acdf5f5fe29ad79.tar.gz
freebsd-ports-gnome-c0f8af37ee6cc01a7ecf8d960acdf5f5fe29ad79.tar.zst
freebsd-ports-gnome-c0f8af37ee6cc01a7ecf8d960acdf5f5fe29ad79.zip
- Update to latest snapshot (20130304) and unbreak this port
- Bump PORTREVISION for distfile change Changes: https://code.google.com/p/google-js-test/source/list Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/gjstest/Makefile24
-rw-r--r--devel/gjstest/distinfo4
2 files changed, 15 insertions, 13 deletions
diff --git a/devel/gjstest/Makefile b/devel/gjstest/Makefile
index 6efe5fcbd5fb..b84121bc49af 100644
--- a/devel/gjstest/Makefile
+++ b/devel/gjstest/Makefile
@@ -3,9 +3,11 @@
PORTNAME= gjstest
PORTVERSION= 1.0.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
-MASTER_SITES= GOOGLE_CODE
+MASTER_SITES= GOOGLE_CODE \
+ LOCAL/sunpoet
+DISTNAME= ${PORTNAME}-${PORTVERSION}.${SNAPSHOT}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Lightweight JS unit testing using the V8 engine
@@ -26,17 +28,17 @@ CXXFLAGS+= -L${LOCALBASE}/lib
USE_BZIP2= yes
USE_GMAKE= yes
-BROKEN= fails to build
-
PROJECTHOST= google-js-test
+SNAPSHOT= 20130304
post-patch:
- @${REINPLACE_CMD} -e '/export PREFIX = / s|/usr/local|${PREFIX}|' \
- ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e 's|CLOCK_PROCESS_CPUTIME_ID|CLOCK_PROF|' \
- ${WRKSRC}/base/timer.cc
- @${REINPLACE_CMD} -e '1 s|/bin/bash|${LOCALBASE}/bin/bash|' \
- ${WRKSRC}/gjstest/internal/cpp/generate_builtin_paths.sh \
- ${WRKSRC}/scripts/*.sh
+ @${REINPLACE_CMD} \
+ -e 's|\(Get\)\(PointerFromInternalField\)|\1Aligned\2|' \
+ -e 's|\(Set\)\(PointerInInternalField\)|\1Aligned\2|' \
+ ${WRKSRC}/gjstest/internal/cpp/typed_arrays.cc
+ @${REINPLACE_CMD} -e '/export PREFIX = / s|/usr/local|${PREFIX}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|CLOCK_PROCESS_CPUTIME_ID|CLOCK_PROF|' ${WRKSRC}/base/timer.cc
+ @${REINPLACE_CMD} -e '1 s|/bin/bash|${LOCALBASE}/bin/bash|' ${WRKSRC}/gjstest/internal/cpp/generate_builtin_paths.sh ${WRKSRC}/scripts/*.sh
+ @${REINPLACE_CMD} -e 's|^g++ |${CXX} |' ${WRKSRC}/scripts/cc_binary_build.sh
.include <bsd.port.mk>
diff --git a/devel/gjstest/distinfo b/devel/gjstest/distinfo
index 1cebf33a62a8..aa034a85e845 100644
--- a/devel/gjstest/distinfo
+++ b/devel/gjstest/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gjstest-1.0.8.tar.bz2) = ed9539c82fc7af1569825fea74a1f9bf667e956623f8d99ddebcea9e68e9c53d
-SIZE (gjstest-1.0.8.tar.bz2) = 179261
+SHA256 (gjstest-1.0.8.20130304.tar.bz2) = 8a39417e2b0f076d231ce5839a7a11956e7cc800ca63e040b67c5cc8b5ca4ee4
+SIZE (gjstest-1.0.8.20130304.tar.bz2) = 168087