aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2007-03-22 17:37:55 +0800
committerijliao <ijliao@FreeBSD.org>2007-03-22 17:37:55 +0800
commitc10103e9afd629cc6757a785acd962ddca5e4853 (patch)
treedd73f586f3c3f87bbfb0f6a2db3d2bd2217790f1 /devel
parente49eb0453c0d32d9b51ca09c6b9ba067167fafbf (diff)
downloadfreebsd-ports-gnome-c10103e9afd629cc6757a785acd962ddca5e4853.tar.gz
freebsd-ports-gnome-c10103e9afd629cc6757a785acd962ddca5e4853.tar.zst
freebsd-ports-gnome-c10103e9afd629cc6757a785acd962ddca5e4853.zip
add libruin 0.1.4
Renderer for User Interfaces in Ncurses
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libruin/Makefile29
-rw-r--r--devel/libruin/distinfo3
-rw-r--r--devel/libruin/files/patch-ltmain.sh15
-rw-r--r--devel/libruin/pkg-descr13
-rw-r--r--devel/libruin/pkg-plist18
6 files changed, 79 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9ee985a99b4b..202cd3bcfaa7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -596,6 +596,7 @@
SUBDIR += libpperl
SUBDIR += libpthread-stubs
SUBDIR += libredblack
+ SUBDIR += libruin
SUBDIR += libs11n
SUBDIR += libshbuf
SUBDIR += libshhmsg
diff --git a/devel/libruin/Makefile b/devel/libruin/Makefile
new file mode 100644
index 000000000000..95e1e4802e2e
--- /dev/null
+++ b/devel/libruin/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: libruin
+# Date created: Mar 22, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libruin
+PORTVERSION= 0.1.4
+CATEGORIES= devel scheme
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Renderer for User Interfaces in Ncurses
+
+BUILD_DEPENDS= ${LOCALBASE}/share/guile/site/config/load.scm:${PORTSDIR}/devel/guile-lib
+RUN_DEPENDS= ${LOCALBASE}/share/guile/site/config/load.scm:${PORTSDIR}/devel/guile-lib
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --infodir=${PREFIX}/info \
+ --mandir=${PREFIX}/man
+USE_LDCONFIG= yes
+
+MAN3= ruin.3
+INFO= libruin
+
+.include <bsd.port.mk>
diff --git a/devel/libruin/distinfo b/devel/libruin/distinfo
new file mode 100644
index 000000000000..260dd851a49f
--- /dev/null
+++ b/devel/libruin/distinfo
@@ -0,0 +1,3 @@
+MD5 (libruin-0.1.4.tar.gz) = 8c5668dd324e91b1f25ada1ec88e7526
+SHA256 (libruin-0.1.4.tar.gz) = 9b62981fd7cbe1e3d7103a2196963ebf09d596d35fa28739dd97715b495e5347
+SIZE (libruin-0.1.4.tar.gz) = 525357
diff --git a/devel/libruin/files/patch-ltmain.sh b/devel/libruin/files/patch-ltmain.sh
new file mode 100644
index 000000000000..31bdb265513a
--- /dev/null
+++ b/devel/libruin/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Thu Mar 22 17:12:36 2007
++++ ltmain.sh Thu Mar 22 17:12:52 2007
+@@ -5551,10 +5551,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/libruin/pkg-descr b/devel/libruin/pkg-descr
new file mode 100644
index 000000000000..e2775d811ece
--- /dev/null
+++ b/devel/libruin/pkg-descr
@@ -0,0 +1,13 @@
+libRUIN (Renderer for User Interfaces in Ncurses) is a rendering library for
+various XML-based user interface markup languages (such as XHTML or Mozilla
+XUL), using the Ncurses terminal control library as a rendering target.
+GNU Guile and the SDOM Scheme module are used as the "glue" that manages user
+input and event handling (as such, event handlers must currently be written
+in Guile Scheme; support for ECMAscript event handlers is being considered
+for inclusion). An application programmer passes an XML document (including,
+potentially, a set of CSS stylesheets) and an Ncurses WINDOW structure, and
+libRUIN paints the WINDOW according to the markup and CSS; the programmer may
+subsequently pass Ncurses-style input strings to that WINDOW via libRUIN, and
+libRUIN will handle the resulting event flows.
+
+WWW: http://www.nongnu.org/libruin/
diff --git a/devel/libruin/pkg-plist b/devel/libruin/pkg-plist
new file mode 100644
index 000000000000..92ff999dbaee
--- /dev/null
+++ b/devel/libruin/pkg-plist
@@ -0,0 +1,18 @@
+include/libruin.h
+lib/libruin.a
+lib/libruin.so
+lib/libruin.so.0
+lib/libruin/css/xhtml.css
+lib/libruin/css/xul.css
+lib/libruin/scheme/scss/lexer.scm
+lib/libruin/scheme/scss/parser.scm
+lib/libruin/scheme/scss/scss.scm
+lib/libruin/scheme/sdom/core.scm
+lib/libruin/scheme/sdom/events.scm
+@dirrm lib/libruin/css
+@dirrm lib/libruin/scheme/sdom
+@dirrm lib/libruin/scheme/scss
+@dirrm lib/libruin/scheme
+@dirrm lib/libruin
+%%DATADIR%%/ChangeLog
+@dirrm %%DATADIR%%