aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2014-07-24 23:01:30 +0800
committerashish <ashish@FreeBSD.org>2014-07-24 23:01:30 +0800
commitc3d153b58705899613ecb048a19a4ba948a7bd91 (patch)
tree87daba9076211700070a7956c69f17fc6c99e820 /devel
parent712e2a928d57bf904b935ede548b006b8eeb28fa (diff)
downloadfreebsd-ports-gnome-c3d153b58705899613ecb048a19a4ba948a7bd91.tar.gz
freebsd-ports-gnome-c3d153b58705899613ecb048a19a4ba948a7bd91.tar.zst
freebsd-ports-gnome-c3d153b58705899613ecb048a19a4ba948a7bd91.zip
- Fix bug when subprocess exits with return code 0
- Fix WWW line in pkg-descr - Add LICENSE information - Fix portlint issues PR: 191736 Submitted by: Gasol Wu <gasol.wu at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/phpsh/Makefile6
-rw-r--r--devel/phpsh/files/patch-src____init__.py11
-rw-r--r--devel/phpsh/pkg-descr2
3 files changed, 16 insertions, 3 deletions
diff --git a/devel/phpsh/Makefile b/devel/phpsh/Makefile
index fc093f1c051c..7be7f9bc107e 100644
--- a/devel/phpsh/Makefile
+++ b/devel/phpsh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= phpsh
PORTVERSION= 20110513
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://distfiles.pirateparty.in/%SUBDIR%/ \
${MASTER_SITE_LOCAL}
@@ -12,6 +12,9 @@ MASTER_SITE_SUBDIR= ashish
MAINTAINER= ashish@FreeBSD.org
COMMENT= Interactive shell for PHP
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
USE_BZIP2= yes
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -24,7 +27,6 @@ PLIST_SUB= PORTNAME=${PORTNAME}
PYDISTUTILS_PKGVERSION= 1.3
-
OPTIONS_DEFINE= PCNTL
PCNTL_DESC= Fork on every command (pcntl PHP extension)
diff --git a/devel/phpsh/files/patch-src____init__.py b/devel/phpsh/files/patch-src____init__.py
new file mode 100644
index 000000000000..a74e5fdc561b
--- /dev/null
+++ b/devel/phpsh/files/patch-src____init__.py
@@ -0,0 +1,11 @@
+--- ./src/__init__.py.orig 2014-07-08 19:24:25.000000000 +0800
++++ ./src/__init__.py 2014-07-08 19:24:45.000000000 +0800
+@@ -758,7 +758,7 @@
+ ret_code = self.p.poll()
+ if debug:
+ print "ret_code: " + str(ret_code)
+- if ret_code != None:
++ if ret_code not in (None, 0):
+ if debug:
+ print "NOOOOO"
+ print "subprocess died with return code: " + repr(ret_code)
diff --git a/devel/phpsh/pkg-descr b/devel/phpsh/pkg-descr
index e19f83746a92..52689670df53 100644
--- a/devel/phpsh/pkg-descr
+++ b/devel/phpsh/pkg-descr
@@ -4,4 +4,4 @@ was developed at Facebook and ironically, is written mostly
in python. It is open source and released under a modified
BSD license.
-WWW: http://phpsh.org/
+WWW: http://phpsh.org/