aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2006-08-05 00:05:52 +0800
committeritetcu <itetcu@FreeBSD.org>2006-08-05 00:05:52 +0800
commitc75638e362ff47a57f2b595a23a679c00a148b66 (patch)
tree7ec471eb294c0707e14912b30b94050f81d8fc17 /devel
parent3fe0f56c91fc3e7c1b3d38ad643da736b608136a (diff)
downloadfreebsd-ports-gnome-c75638e362ff47a57f2b595a23a679c00a148b66.tar.gz
freebsd-ports-gnome-c75638e362ff47a57f2b595a23a679c00a148b66.tar.zst
freebsd-ports-gnome-c75638e362ff47a57f2b595a23a679c00a148b66.zip
An extension Library
This is mostly to fill in some gaps in the standard and unix libraries, either for completeness or because they're things I find myself needing a lot of the time, and a few modules that aren't worthy of being their own releases. Enjoy. Most of this used to be part of an old library (stew) that I broke up into a couple of smaller ones. This one /was/ extlib, now annexlib. Its companion is mathlib. See supplied documentation for additional info. Author: Shawn Wagner <shawnw@speakeasy.org> WWW: http://raevnos.pennmush.org/code/extlib/ PR: ports/101207 Submitted by: Stanislav Sedov <ssedov at mbsd.msk.ru>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-annexlib/Makefile57
-rw-r--r--devel/ocaml-annexlib/distinfo3
-rw-r--r--devel/ocaml-annexlib/pkg-descr13
4 files changed, 74 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 31404acf2b6e..bd75ebf7df1f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -691,6 +691,7 @@
SUBDIR += oaf
SUBDIR += obby
SUBDIR += obfuscatejs
+ SUBDIR += ocaml-annexlib
SUBDIR += ocaml-camljava
SUBDIR += ocaml-camomile
SUBDIR += ocaml-camomile-examples
diff --git a/devel/ocaml-annexlib/Makefile b/devel/ocaml-annexlib/Makefile
new file mode 100644
index 000000000000..1263af59168b
--- /dev/null
+++ b/devel/ocaml-annexlib/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: ocaml-annexlib
+# Date created: 2006-08-01
+# Whom: Stanislav Sedov <ssedov@mbsd.msk.ru>
+#
+# $MBSDlabs$
+# $FreeBSD$
+#
+
+PORTNAME= annexlib
+PORTVERSION= 0.13.2
+CATEGORIES= devel
+MASTER_SITES= http://raevnos.pennmush.org/code/extlib/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= ssedov@mbsd.msk.ru
+COMMENT= OCaml subroutines collection
+
+BUILD_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
+RUN_DEPENDS= ${SA_DIR}/pcre/pcre.a:${PORTSDIR}/devel/ocaml-pcre
+
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+USE_OCAML_LDCONFIG=yes
+
+GNU_CONFIGURE= yes
+
+ALL_TARGET= all opt
+SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
+
+.if !defined(NOPORTDOCS)
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+PORTDOCS= *
+.endif
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/ocaml/bsd.ocaml.mk"
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+.if !exists(${OCAMLFIND_LDCONF})
+ ${TOUCH} ${OCAMLFIND_LDCONF}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/html/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-annexlib/distinfo b/devel/ocaml-annexlib/distinfo
new file mode 100644
index 000000000000..d24e05865bb1
--- /dev/null
+++ b/devel/ocaml-annexlib/distinfo
@@ -0,0 +1,3 @@
+MD5 (annexlib-0.13.2.tar.gz) = f328046cb03caf54182a168da896bd23
+SHA256 (annexlib-0.13.2.tar.gz) = 88bd9df5339deb1b22991b8a85e1ffb2d2f4f03c678e2a5b8717f003fc951b7f
+SIZE (annexlib-0.13.2.tar.gz) = 105291
diff --git a/devel/ocaml-annexlib/pkg-descr b/devel/ocaml-annexlib/pkg-descr
new file mode 100644
index 000000000000..472d3a275cc3
--- /dev/null
+++ b/devel/ocaml-annexlib/pkg-descr
@@ -0,0 +1,13 @@
+An extension Library
+
+This is mostly to fill in some gaps in the standard and unix
+libraries, either for completeness or because they're things I find
+myself needing a lot of the time, and a few modules that aren't worthy
+of being their own releases. Enjoy. Most of this used to be part of an
+old library (stew) that I broke up into a couple of smaller ones. This
+one /was/ extlib, now annexlib. Its companion is mathlib.
+
+See supplied documentation for additional info.
+
+Author: Shawn Wagner <shawnw@speakeasy.org>
+WWW: http://raevnos.pennmush.org/code/extlib/