aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2007-01-27 08:35:01 +0800
committernivit <nivit@FreeBSD.org>2007-01-27 08:35:01 +0800
commitc90cc5c124b586fe346255206c45e47cf533c848 (patch)
tree03fc7b06ca1eac698c74c83cd5c7b5cf292704c6 /devel
parent189d86a30c35c3076c4d8276d1832d7d7c972b57 (diff)
downloadfreebsd-ports-gnome-c90cc5c124b586fe346255206c45e47cf533c848.tar.gz
freebsd-ports-gnome-c90cc5c124b586fe346255206c45e47cf533c848.tar.zst
freebsd-ports-gnome-c90cc5c124b586fe346255206c45e47cf533c848.zip
- Added easy_install commands to add/remove simplejson's entry
to/from ${PYTHON_SITELIBDIR}/easy-install.pth (it failed original MD5 checksum) - Added variable PYSIMPLEJSON_EGG - Bumped PORTREVISION PR: ports/108353 Submitted by: Nicola Vitale <nivit at email.it> Approved by: alexbl (mentor, implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/py-simplejson/Makefile6
-rw-r--r--devel/py-simplejson/pkg-plist5
2 files changed, 10 insertions, 1 deletions
diff --git a/devel/py-simplejson/Makefile b/devel/py-simplejson/Makefile
index 15ae9b823678..5ff225371d46 100644
--- a/devel/py-simplejson/Makefile
+++ b/devel/py-simplejson/Makefile
@@ -7,6 +7,7 @@
PORTNAME= simplejson
PORTVERSION= 1.4
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://cheeseshop.python.org/packages/source/s/simplejson/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,4 +21,9 @@ RUN_DEPENDS= easy_install:${PORTSDIR}/devel/py-setuptools
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYSIMPLEJSON_EGG= ${PORTNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+PLIST_SUB+= PYSIMPLEJSON_EGG=${PYSIMPLEJSON_EGG} \
+ EGG_VER="${PORTNAME}==${PORTVERSION}"
+
.include <bsd.port.mk>
diff --git a/devel/py-simplejson/pkg-plist b/devel/py-simplejson/pkg-plist
index d2363b639720..cef763fff859 100644
--- a/devel/py-simplejson/pkg-plist
+++ b/devel/py-simplejson/pkg-plist
@@ -1 +1,4 @@
-%%PYTHON_SITELIBDIR%%/simplejson-1.4-py2.4.egg
+@comment $FreeBSD$
+@unexec easy_install -q -m -S %D/%%PYTHON_SITELIBDIR%% %%EGG_VER%%
+%%PYTHON_SITELIBDIR%%/%%PYSIMPLEJSON_EGG%%
+@exec easy_install -q -N -S %D/%%PYTHON_SITELIBDIR%% %%EGG_VER%%