aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-10-20 02:09:06 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-10-20 02:09:06 +0800
commitcca6c9d535919bf4e38fd680319fc4104c237144 (patch)
treec6326cad8f33571214b464e88e2cc7840b9ff9a0 /devel
parent5f7af81a729f87f7b21d646f557d75cec0d604e5 (diff)
downloadfreebsd-ports-gnome-cca6c9d535919bf4e38fd680319fc4104c237144.tar.gz
freebsd-ports-gnome-cca6c9d535919bf4e38fd680319fc4104c237144.tar.zst
freebsd-ports-gnome-cca6c9d535919bf4e38fd680319fc4104c237144.zip
Add devel/p5-Perl-Unsafe-Signals, allow unsafe handling of signals in selected
blocks.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Perl-Unsafe-Signals/Makefile21
-rw-r--r--devel/p5-Perl-Unsafe-Signals/distinfo3
-rw-r--r--devel/p5-Perl-Unsafe-Signals/pkg-descr16
-rw-r--r--devel/p5-Perl-Unsafe-Signals/pkg-plist9
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b81d1f7287f3..8fa67d455d76 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2024,6 +2024,7 @@
SUBDIR += p5-PathTools
SUBDIR += p5-Penguin
SUBDIR += p5-Penguin-Easy
+ SUBDIR += p5-Perl-Unsafe-Signals
SUBDIR += p5-Perl-Version
SUBDIR += p5-Perl6-Builtins
SUBDIR += p5-Perl6-Export
diff --git a/devel/p5-Perl-Unsafe-Signals/Makefile b/devel/p5-Perl-Unsafe-Signals/Makefile
new file mode 100644
index 000000000000..550854f5c52e
--- /dev/null
+++ b/devel/p5-Perl-Unsafe-Signals/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: p5-Perl-Unsafe-Signals
+# Date created: 19 Oct 2010
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Perl-Unsafe-Signals
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Allow unsafe handling of signals in selected blocks
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Perl::Unsafe::Signals.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Perl-Unsafe-Signals/distinfo b/devel/p5-Perl-Unsafe-Signals/distinfo
new file mode 100644
index 000000000000..29c053c8fcbe
--- /dev/null
+++ b/devel/p5-Perl-Unsafe-Signals/distinfo
@@ -0,0 +1,3 @@
+MD5 (Perl-Unsafe-Signals-0.02.tar.gz) = 294a85ebf53fc047abfa0183e797ebba
+SHA256 (Perl-Unsafe-Signals-0.02.tar.gz) = d321edcb2cd257106de00a2b4305d2e6cb12e7022e3f1e1133ed16733c159afd
+SIZE (Perl-Unsafe-Signals-0.02.tar.gz) = 2552
diff --git a/devel/p5-Perl-Unsafe-Signals/pkg-descr b/devel/p5-Perl-Unsafe-Signals/pkg-descr
new file mode 100644
index 000000000000..5226f74bc326
--- /dev/null
+++ b/devel/p5-Perl-Unsafe-Signals/pkg-descr
@@ -0,0 +1,16 @@
+In Perl 5.8.0 the so-called "safe signals" were introduced. This means that Perl
+no longer handles signals immediately but instead "between opcodes", when it is
+safe to do so. The earlier immediate handling easily could corrupt the internal
+state of Perl, resulting in mysterious crashes.
+
+It's possible since perl 5.8.1 to globally disable this feature by using the
+PERL_SIGNALS environment variables (as specified in "PERL_SIGNALS" in perlrun);
+but there's no way to disable it locally, for a short period of time. That's
+however something you might want to do, if, for example, your Perl program calls
+a C routine that will potentially run for a long time and for which you want to
+set a timeout.
+
+This module therefore allows you to define UNSAFE_SIGNALS blocks in which
+signals will be handled "unsafely".
+
+WWW: http://search.cpan.org/dist/Perl-Unsafe-Signals/
diff --git a/devel/p5-Perl-Unsafe-Signals/pkg-plist b/devel/p5-Perl-Unsafe-Signals/pkg-plist
new file mode 100644
index 000000000000..0fd3489de5f4
--- /dev/null
+++ b/devel/p5-Perl-Unsafe-Signals/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl/Unsafe/Signals/Signals.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl/Unsafe/Signals/Signals.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl/Unsafe/Signals/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Perl/Unsafe/Signals.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl/Unsafe/Signals
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl/Unsafe
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Perl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Perl/Unsafe
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Perl