aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-18 07:10:18 +0800
committerbapt <bapt@FreeBSD.org>2013-03-18 07:10:18 +0800
commitcccf8250facb0dcbdcf707077fa69b9310bc5740 (patch)
tree9e920daa5789e35ba5d31f5cebc934ebc04c88f0 /devel
parentede7034700f758f1d27a5ce98866340106ee1ebd (diff)
downloadfreebsd-ports-gnome-cccf8250facb0dcbdcf707077fa69b9310bc5740.tar.gz
freebsd-ports-gnome-cccf8250facb0dcbdcf707077fa69b9310bc5740.tar.zst
freebsd-ports-gnome-cccf8250facb0dcbdcf707077fa69b9310bc5740.zip
- Fix a regression that prevent graphics/dri to correctly build
Reported by: gpalmer, swills Tested by: zi
Diffstat (limited to 'devel')
-rw-r--r--devel/pkgconf/Makefile1
-rw-r--r--devel/pkgconf/files/patch-pkg.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/pkgconf/Makefile b/devel/pkgconf/Makefile
index 2903bfbf075b..fa1d16249411 100644
--- a/devel/pkgconf/Makefile
+++ b/devel/pkgconf/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pkgconf
PORTVERSION= 0.9.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://rabbit.dereferenced.org/~nenolod/distfiles/ \
http://files.etoilebsd.net/pkgconf/
diff --git a/devel/pkgconf/files/patch-pkg.c b/devel/pkgconf/files/patch-pkg.c
new file mode 100644
index 000000000000..7b6744d01aaa
--- /dev/null
+++ b/devel/pkgconf/files/patch-pkg.c
@@ -0,0 +1,11 @@
+--- ./pkg.c.orig 2013-03-16 02:19:13.000000000 +0100
++++ ./pkg.c 2013-03-17 23:47:38.808630318 +0100
+@@ -890,7 +890,7 @@
+ }
+
+ pkgdep->flags |= PKG_PROPF_SEEN;
+- eflags = pkg_traverse(pkgdep, func, data, depth - 1, flags);
++ eflags |= pkg_traverse(pkgdep, func, data, depth - 1, flags);
+ pkgdep->flags &= ~PKG_PROPF_SEEN;
+ pkg_unref(pkgdep);
+ }