aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-09-26 22:12:56 +0800
committergahr <gahr@FreeBSD.org>2013-09-26 22:12:56 +0800
commitcd1571c852b5eb0a3c04ac30b84919fa18220ff0 (patch)
tree260967f3f32f848d0febae8c126b28dfab241e81 /devel
parent192f23bd5f4af9426c81176b2bdc18b0a78adbe6 (diff)
downloadfreebsd-ports-gnome-cd1571c852b5eb0a3c04ac30b84919fa18220ff0.tar.gz
freebsd-ports-gnome-cd1571c852b5eb0a3c04ac30b84919fa18220ff0.tar.zst
freebsd-ports-gnome-cd1571c852b5eb0a3c04ac30b84919fa18220ff0.zip
- Convert to USES+=tk
- Convert to OPTIONSng - Import a patch from upstream to avoid new virtual events in Tk 8.6 to mess with the history functionality [1] Obtained from: http://tkcon.cvs.sf.net/viewvc/tkcon/tkcon/tkcon.tcl?r1=1.117&r2=1.118 [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/tkcon/Makefile19
-rw-r--r--devel/tkcon/files/patch-tkcon.tcl26
2 files changed, 34 insertions, 11 deletions
diff --git a/devel/tkcon/Makefile b/devel/tkcon/Makefile
index 6e14f214ec77..58b4c00e802c 100644
--- a/devel/tkcon/Makefile
+++ b/devel/tkcon/Makefile
@@ -9,23 +9,26 @@ MASTER_SITES= SF
MAINTAINER= tcltk@FreeBSD.org
COMMENT= Tk console for Tcl
+OPTIONS_DEFINE= DOCS
+
NO_BUILD= yes
-USE_TK_WRAPPER= yes
+USES+= tk
PORTDOCS= *
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e \
- 's|%%DOCSDIR%%|${DOCSDIR}|g' ${WRKSRC}/${PORTNAME}.tcl
+ 's|%%DOCSDIR%%|${DOCSDIR}|g; s|%%WISH%%|${WISH}|g' ${WRKSRC}/${PORTNAME}.tcl
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.tcl ${PREFIX}/bin/${PORTNAME}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/README.${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.tcl ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}/README.${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/tkcon/files/patch-tkcon.tcl b/devel/tkcon/files/patch-tkcon.tcl
index 230bab5f19c0..48d68a50d978 100644
--- a/devel/tkcon/files/patch-tkcon.tcl
+++ b/devel/tkcon/files/patch-tkcon.tcl
@@ -1,6 +1,14 @@
--- tkcon.tcl.orig 2009-02-27 01:17:21.000000000 +0100
-+++ tkcon.tcl 2013-04-16 09:25:50.000000000 +0200
-@@ -194,7 +192,7 @@
++++ tkcon.tcl 2013-09-26 16:10:14.000000000 +0200
+@@ -1,6 +1,6 @@
+ #!/bin/sh
+ # \
+-exec wish "$0" ${1+"$@"}
++exec %%WISH%% "$0" ${1+"$@"}
+
+ #
+ ## tkcon.tcl
+@@ -194,7 +194,7 @@
RCS {RCS: @(#) $Id: tkcon.tcl,v 1.102 2008/02/07 21:02:53 hobbs Exp $}
HEADURL {http://tkcon.cvs.sourceforge.net/tkcon/tkcon/tkcon.tcl?rev=HEAD}
@@ -9,7 +17,7 @@
email {jeff(a)hobbs(.)org}
root .
uid 0
-@@ -1586,8 +1584,8 @@
+@@ -1586,8 +1586,8 @@
foreach m [list [menu $w.help] [menu $w.pop.help]] {
$m add command -label "About " -underline 0 -accel Ctrl-A \
-command ::tkcon::About
@@ -20,3 +28,15 @@
if {![catch {package require ActiveTcl} ver]} {
set cmd ""
if {$tcl_platform(platform) == "windows"} {
+@@ -5018,6 +5018,11 @@
+ ## We really didn't want the newline insertion
+ bind TkConsole <Control-Key-o> {}
+
++ ## in 8.6b3, the virtual events <<NextLine>> and <<PrevLine>>
++ # mess up our history feature
++ bind TkConsole <<NextLine>> {}
++ bind TkConsole <<PrevLine>> {}
++
+ ## Now make all our virtual event bindings
+ foreach {ev key} [subst -nocommand -noback {
+ <<TkCon_Exit>> <Control-q>