aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2010-03-12 22:45:14 +0800
committergahr <gahr@FreeBSD.org>2010-03-12 22:45:14 +0800
commitce6ee9efb3753eeeb7c5770886485b2655ef75bd (patch)
tree135333839bf61a454547677ead251acf9ee63e1b /devel
parentb71088cb72201cbd613bc33032133434068dc971 (diff)
downloadfreebsd-ports-gnome-ce6ee9efb3753eeeb7c5770886485b2655ef75bd.tar.gz
freebsd-ports-gnome-ce6ee9efb3753eeeb7c5770886485b2655ef75bd.tar.zst
freebsd-ports-gnome-ce6ee9efb3753eeeb7c5770886485b2655ef75bd.zip
- New port: devel/py-setproctitle
A setproctitle implementation for Python. The library allows a process to change its title (as displayed by system tools such as ps(1) and top(1). WWW: http://pypi.python.org/pypi/setproctitle/ PR: 144694 Submitted by: Sofian Brabez <sbrabez@gmail.com> (maintainer) Approved by: jadawin (wants his PRs, can't commit right now)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-setproctitle/Makefile32
-rw-r--r--devel/py-setproctitle/distinfo3
-rw-r--r--devel/py-setproctitle/pkg-descr6
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e2663d778de6..74bfa7664d42 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2673,6 +2673,7 @@
SUBDIR += py-rtree
SUBDIR += py-ruledispatch
SUBDIR += py-sendfile
+ SUBDIR += py-setproctitle
SUBDIR += py-setuptools
SUBDIR += py-setuptools_darcs
SUBDIR += py-shapely
diff --git a/devel/py-setproctitle/Makefile b/devel/py-setproctitle/Makefile
new file mode 100644
index 000000000000..4fbe821b1a10
--- /dev/null
+++ b/devel/py-setproctitle/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: py-setproctitle
+# Date created: 2010-03-12
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= setproctitle
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= Allow customization of the process title
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/${PORTNAME}.so
+
+PORTDOCS= COPYRIGHT HISTORY README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-setproctitle/distinfo b/devel/py-setproctitle/distinfo
new file mode 100644
index 000000000000..8317b67102bd
--- /dev/null
+++ b/devel/py-setproctitle/distinfo
@@ -0,0 +1,3 @@
+MD5 (setproctitle-1.0.tar.gz) = 27504766d1a0ea30a88d8eaf1e311fa3
+SHA256 (setproctitle-1.0.tar.gz) = a8b08c7a589aa6b76729bdee25d5a5e6b4c85415e30f356e308366711b98db48
+SIZE (setproctitle-1.0.tar.gz) = 12003
diff --git a/devel/py-setproctitle/pkg-descr b/devel/py-setproctitle/pkg-descr
new file mode 100644
index 000000000000..c5eb74f0fbc3
--- /dev/null
+++ b/devel/py-setproctitle/pkg-descr
@@ -0,0 +1,6 @@
+A setproctitle implementation for Python.
+
+The library allows a process to change its title (as displayed by system tools
+such as ps(1) and top(1).
+
+WWW: http://pypi.python.org/pypi/setproctitle/