aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-01-06 06:35:33 +0800
committermiwi <miwi@FreeBSD.org>2007-01-06 06:35:33 +0800
commitcfe935116196dc7f8ce73be7992e745bd4efee6f (patch)
tree976ff64e2b489bf887293544d3b465b8956da06d /devel
parent07bebb240c55d9e5dbc52092e231948ecda278ab (diff)
downloadfreebsd-ports-gnome-cfe935116196dc7f8ce73be7992e745bd4efee6f.tar.gz
freebsd-ports-gnome-cfe935116196dc7f8ce73be7992e745bd4efee6f.tar.zst
freebsd-ports-gnome-cfe935116196dc7f8ce73be7992e745bd4efee6f.zip
Argparse takes the best of the optparse command-line parsing module and brings
it new life. Argparse adds positional as well as optional arguments, the ability to create parsers for sub-commands, more informative help and usage messages, and much more. At the same time, it retains the ease and flexibility of use that made optparse so popular. WWW: http://argparse.python-hosting.com/ PR: ports/107556 Submitted by: Li-Wen Hsu <lwhsu at lwhsu.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-argparse/Makefile26
-rw-r--r--devel/py-argparse/distinfo3
-rw-r--r--devel/py-argparse/pkg-descr7
4 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c09be4af3130..1134e45b1091 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1706,6 +1706,7 @@
SUBDIR += publib
SUBDIR += pwlib
SUBDIR += py-anonfunc
+ SUBDIR += py-argparse
SUBDIR += py-asn1
SUBDIR += py-astng
SUBDIR += py-bison
diff --git a/devel/py-argparse/Makefile b/devel/py-argparse/Makefile
new file mode 100644
index 000000000000..7ce216ff1fc5
--- /dev/null
+++ b/devel/py-argparse/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: py-argparse
+# Date created: Jan. 05, 2007
+# Whom: Li-Wen Hsu <lwhsu@lwhsu.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= argparse
+PORTVERSION= 0.4.0
+CATEGORIES= devel python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/a/argparse/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@lwhsu.org
+COMMENT= An optparse-inspired command-line parsing library
+
+USE_ZIP= yes
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/argparse.py \
+ %%PYTHON_SITELIBDIR%%/argparse.pyc \
+ %%PYTHON_SITELIBDIR%%/argparse.pyo
+
+.include <bsd.port.mk>
diff --git a/devel/py-argparse/distinfo b/devel/py-argparse/distinfo
new file mode 100644
index 000000000000..da5d5ef8bb87
--- /dev/null
+++ b/devel/py-argparse/distinfo
@@ -0,0 +1,3 @@
+MD5 (argparse-0.4.0.zip) = 9240b1183f2c08a1eb5b48e0adae689b
+SHA256 (argparse-0.4.0.zip) = ced2c1a18794fbd6232780f050e77f86a1e1a6ab28e1fce1aacc97b2b18b0618
+SIZE (argparse-0.4.0.zip) = 15031
diff --git a/devel/py-argparse/pkg-descr b/devel/py-argparse/pkg-descr
new file mode 100644
index 000000000000..e3695583b712
--- /dev/null
+++ b/devel/py-argparse/pkg-descr
@@ -0,0 +1,7 @@
+Argparse takes the best of the optparse command-line parsing module and brings
+it new life. Argparse adds positional as well as optional arguments, the
+ability to create parsers for sub-commands, more informative help and usage
+messages, and much more. At the same time, it retains the ease and flexibility
+of use that made optparse so popular.
+
+WWW: http://argparse.python-hosting.com/