aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-26 11:28:37 +0800
committermarcus <marcus@FreeBSD.org>2004-06-26 11:28:37 +0800
commitd16c96bd099c7c2ebba94d296660659798ef8a50 (patch)
tree2a76b49dcafc6264be1162f63fadc95d46c94b0a /devel
parentec42cd092e6b11dd74e12bef81f9e08f113a31d7 (diff)
downloadfreebsd-ports-gnome-d16c96bd099c7c2ebba94d296660659798ef8a50.tar.gz
freebsd-ports-gnome-d16c96bd099c7c2ebba94d296660659798ef8a50.tar.zst
freebsd-ports-gnome-d16c96bd099c7c2ebba94d296660659798ef8a50.zip
Add support for a mime database in ${X11BASE} as well as ${LOCALBASE}.
Requested by: pav
Diffstat (limited to 'devel')
-rw-r--r--devel/gnome-vfs/Makefile6
-rw-r--r--devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c11
-rw-r--r--devel/gnomevfs2/Makefile6
-rw-r--r--devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c11
4 files changed, 30 insertions, 4 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 5b79b7171707..55a2134cf8b1 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomevfs2
PORTVERSION= 2.6.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-vfs/2.6
@@ -83,8 +83,10 @@ post-patch:
's|\@datadir\@/gnome|\@datadir\@|g'
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/Makefile.in \
- ${WRKSRC}/libgnomevfs/xdgmime.c \
${WRKSRC}/modules/vfolder/applications-all-users.vfolder-info.in
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/libgnomevfs/xdgmime.c
.if !defined(WITHOUT_KDE_MENUS)
@${SED} -e 's|/usr/local|${LOCALBASE}|g' \
< ${FILESDIR}/KDE.directory > ${WRKSRC}/KDE.directory
diff --git a/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
new file mode 100644
index 000000000000..213ed03ece45
--- /dev/null
+++ b/devel/gnome-vfs/files/patch-libgnomevfs_xdgmime.c
@@ -0,0 +1,11 @@
+--- libgnomevfs/xdgmime.c.orig Wed Jun 23 20:15:25 2004
++++ libgnomevfs/xdgmime.c Wed Jun 23 20:15:41 2004
+@@ -97,7 +97,7 @@
+
+ xdg_data_dirs = getenv ("XDG_DATA_DIRS");
+ if (xdg_data_dirs == NULL)
+- xdg_data_dirs = "/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "/usr/local/share/:%%X11BASE%%/share/:/usr/share/";
+
+ ptr = xdg_data_dirs;
+
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index 5b79b7171707..55a2134cf8b1 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomevfs2
PORTVERSION= 2.6.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-vfs/2.6
@@ -83,8 +83,10 @@ post-patch:
's|\@datadir\@/gnome|\@datadir\@|g'
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
${WRKSRC}/libgnomevfs/Makefile.in \
- ${WRKSRC}/libgnomevfs/xdgmime.c \
${WRKSRC}/modules/vfolder/applications-all-users.vfolder-info.in
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
+ s|%%X11BASE%%|${X11BASE}|g' \
+ ${WRKSRC}/libgnomevfs/xdgmime.c
.if !defined(WITHOUT_KDE_MENUS)
@${SED} -e 's|/usr/local|${LOCALBASE}|g' \
< ${FILESDIR}/KDE.directory > ${WRKSRC}/KDE.directory
diff --git a/devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c b/devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c
new file mode 100644
index 000000000000..213ed03ece45
--- /dev/null
+++ b/devel/gnomevfs2/files/patch-libgnomevfs_xdgmime.c
@@ -0,0 +1,11 @@
+--- libgnomevfs/xdgmime.c.orig Wed Jun 23 20:15:25 2004
++++ libgnomevfs/xdgmime.c Wed Jun 23 20:15:41 2004
+@@ -97,7 +97,7 @@
+
+ xdg_data_dirs = getenv ("XDG_DATA_DIRS");
+ if (xdg_data_dirs == NULL)
+- xdg_data_dirs = "/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "/usr/local/share/:%%X11BASE%%/share/:/usr/share/";
+
+ ptr = xdg_data_dirs;
+