aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-01-15 21:40:28 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-01-15 21:40:28 +0800
commitd17f4033ae11c1ef211b336b25eb38a014e0c74b (patch)
tree98f96307b5a32cecd5d4e2104c22673c560b9789 /devel
parent7e85483bc4dd371692cb42e0670e76bc41c0a5ba (diff)
downloadfreebsd-ports-gnome-d17f4033ae11c1ef211b336b25eb38a014e0c74b.tar.gz
freebsd-ports-gnome-d17f4033ae11c1ef211b336b25eb38a014e0c74b.tar.zst
freebsd-ports-gnome-d17f4033ae11c1ef211b336b25eb38a014e0c74b.zip
- Use DOC instead of NOPORTDOCS
- Pacify portlint - Convert header
Diffstat (limited to 'devel')
-rw-r--r--devel/bunny/Makefile12
-rw-r--r--devel/ccache/Makefile4
-rw-r--r--devel/cvsspam/Makefile12
3 files changed, 14 insertions, 14 deletions
diff --git a/devel/bunny/Makefile b/devel/bunny/Makefile
index 27c2e7e79eaf..904d022f5a7e 100644
--- a/devel/bunny/Makefile
+++ b/devel/bunny/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bunny
-# Date created: 28 Jan 2008
-# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
-#
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= bunny
PORTVERSION= 0.93
@@ -26,6 +22,10 @@ PLIST_FILES= bin/bunny-trace bin/bunny-gcc bin/bunny-flow bin/bunny-exec \
ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON= Fails to compile: invokes i386 asm
+OPTIONS_DEFINE=DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e '/^CFLAGS/d' ${WRKSRC}/${MAKEFILE}
@@ -34,7 +34,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${f:C/bin\///} ${PREFIX}/bin
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
.endif
diff --git a/devel/ccache/Makefile b/devel/ccache/Makefile
index 6195b4847512..ee2e7059064d 100644
--- a/devel/ccache/Makefile
+++ b/devel/ccache/Makefile
@@ -21,7 +21,7 @@ MAN1= ccache.1
PORTDOCS= ccache-howto-freebsd.txt MANUAL.html
-OPTIONS_DEFINE= CLANGLINK LLVMLINK STATIC
+OPTIONS_DEFINE= CLANGLINK LLVMLINK STATIC DOCS
CLANGLINK_DESC= Create clang compiler links if clang is installed
LLVMLINK_DESC= Create llvm compiler links if llvm is installed
@@ -75,7 +75,7 @@ do-install:
${PREFIX}/bin/ccache-update-links
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.tar ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/MANUAL.html ${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/${HOWTO} ${DOCSDIR}
diff --git a/devel/cvsspam/Makefile b/devel/cvsspam/Makefile
index 096aaa1440af..79d4264787ea 100644
--- a/devel/cvsspam/Makefile
+++ b/devel/cvsspam/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvsspam
-# Date created: 16 Sep 2005
-# Whom: Emanuel Haupt <ehaupt@critical.ch>
-#
+# Created by: Emanuel Haupt <ehaupt@critical.ch>
# $FreeBSD$
-#
PORTNAME= cvsspam
PORTVERSION= 0.2.12
@@ -21,6 +17,10 @@ NO_BUILD= yes
PORTDOCS= COPYING CREDITS TODO cvsspam-doc.html cvsspam-doc.pdf
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
.for f in collect_diffs.rb cvsspam.rb record_lastdir.rb
@${REINPLACE_CMD} -e 's|/usr/bin/ruby|${RUBY}|' \
@@ -39,7 +39,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/cvsspam.conf ${PREFIX}/etc/cvsspam.conf
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}