aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2014-03-31 02:01:41 +0800
committersunpoet <sunpoet@FreeBSD.org>2014-03-31 02:01:41 +0800
commitd3ac73cd5a3ca554fc7ab6a27996367959e0a5cb (patch)
treed53d16366d2429937e9432d415dcd180d18570b6 /devel
parent432f30af06dfde0b6e347bc05828b690786038ec (diff)
downloadfreebsd-ports-gnome-d3ac73cd5a3ca554fc7ab6a27996367959e0a5cb.tar.gz
freebsd-ports-gnome-d3ac73cd5a3ca554fc7ab6a27996367959e0a5cb.tar.zst
freebsd-ports-gnome-d3ac73cd5a3ca554fc7ab6a27996367959e0a5cb.zip
- Fix *_DEPENDS:
- Add missing dependencies, including security/p5-Net-SSLGlue - Drop unused dependencies - Fix installation issues - Bump PORTREVISION for dependency and package change PR: ports/187736 Submitted by: Ryder Dain <ryder.dain@gmail.com> Approved by: Mikhail Tsatsenko <m.tsatsenko@gmail.com> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/otrs/Makefile25
-rw-r--r--devel/otrs/pkg-plist26
2 files changed, 31 insertions, 20 deletions
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index 84f75d2643fb..8f780cc24211 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -3,6 +3,7 @@
PORTNAME= otrs
PORTVERSION= 3.3.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://ftp.otrs.org/pub/otrs/ \
ftp://ftp.samurai.com/pub/otrs/ \
@@ -34,7 +35,13 @@ BUILD_DEPENDS= p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
p5-Date-Pcalc>=0:${PORTSDIR}/devel/p5-Date-Pcalc \
p5-Text-CSV>=0:${PORTSDIR}/textproc/p5-Text-CSV \
p5-XML-FeedPP>=0:${PORTSDIR}/textproc/p5-XML-FeedPP \
- p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML
+ p5-YAML-LibYAML>=0:${PORTSDIR}/textproc/p5-YAML-LibYAML \
+ p5-JavaScript-Minifier>=0:${PORTSDIR}/textproc/p5-JavaScript-Minifier \
+ p5-CSS-Minifier>=0:${PORTSDIR}/textproc/p5-CSS-Minifier \
+ p5-SOAP-Lite>=0:${PORTSDIR}/net/p5-SOAP-Lite \
+ p5-Class-Inspector>=0:${PORTSDIR}/devel/p5-Class-Inspector \
+ p5-Mozilla-CA>=0:${PORTSDIR}/www/p5-Mozilla-CA
+
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= shebangfix perl5
@@ -61,7 +68,7 @@ GROUPS= ${USERS} www
SUB_FILES= pkg-install pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-ROOT_DIRS_LIST= Kernel bin scripts
+ROOT_DIRS_LIST= Kernel bin scripts doc
BIN_DIRS_LIST= "" cgi-bin fcgi-bin
PM_DIRS_LIST= Kernel Kernel/Config Kernel/Config/Files Kernel/Language \
Modules Kernel/Output/HTML Kernel/Output/HTML/Lite \
@@ -72,6 +79,7 @@ DOCS_DIRS_LIST= "" manual/en
DOCS_FILES_LIST= C[A-Z]* INSTALL.md RE* UPGRADING.md
SCRIPTS_DIRS_LIST= "" database/update test tools
+CRON_SCRIPTS= ${OTRSDIR}/var/cron/
CLEAN_FILES= scripts/suse* scripts/redhat* \
var/httpd/htdocs/js/thirdparty/ckeditor-4.0/_source \
var/httpd/htdocs/skins/Agent/*/img/source
@@ -103,18 +111,17 @@ RUN_DEPENDS+= p5-GD>=0:${PORTSDIR}/graphics/p5-GD \
.endif
.if ${PORT_OPTIONS:MSMTP}
-RUN_DEPENDS+= p5-Net-SMTP-SSL>=0:${PORTSDIR}/mail/p5-Net-SMTP-SSL \
- p5-Net-SMTP-TLS>=0:${PORTSDIR}/mail/p5-Net-SMTP-TLS \
- p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL
+RUN_DEPENDS+= p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL \
+ p5-Net-SSLGlue>=0:${PORTSDIR}/security/p5-Net-SSLGlue
.endif
.if ${PORT_OPTIONS:MPOP3}
-RUN_DEPENDS+= p5-Mail-POP3Client>=0:${PORTSDIR}/mail/p5-Mail-POP3Client \
- p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
+RUN_DEPENDS+= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Net-SSLGlue>=0:${PORTSDIR}/security/p5-Net-SSLGlue
.endif
.if ${PORT_OPTIONS:MIMAP}
-RUN_DEPENDS+= p5-Net-IMAP-Simple-SSL>=0:${PORTSDIR}/mail/p5-Net-IMAP-Simple-SSL
+RUN_DEPENDS+= p5-Mail-IMAPClient>=0:${PORTSDIR}/mail/p5-Mail-IMAPClient
.endif
.if ${PORT_OPTIONS:MLDAP}
@@ -171,6 +178,7 @@ do-install:
${SCRIPTS_DIRS_LIST:S!^!${OTRSDIR}/scripts/!}
@${INSTALL_DATA} ${WRKSRC}/.*.dist ${OTRSDIR}/
@${INSTALL_DATA} ${WRKSRC}/RELEASE ${OTRSDIR}/
+ @${INSTALL_DATA} ${WRKSRC}/ARCHIVE ${OTRSDIR}/
.for D in ${BIN_DIRS_LIST}
@${INSTALL_SCRIPT} ${WRKSRC}/bin/${D}/*.* ${OTRSDIR}/bin/${D}/
.endfor
@@ -197,6 +205,7 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/doc/${D}/*.* ${DOCSDIR}/${D}/
.endfor
.endif
+ @${FIND} ${CRON_SCRIPTS} -type f -name *.dist | ${SED} -e "p;s/\.dist//" | ${XARGS} -n2 ${MV}
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
post-install:
diff --git a/devel/otrs/pkg-plist b/devel/otrs/pkg-plist
index ba59b5bfcbef..668b072d7759 100644
--- a/devel/otrs/pkg-plist
+++ b/devel/otrs/pkg-plist
@@ -764,6 +764,7 @@ otrs/Kernel/System/Web/UploadCache/FS.pm
otrs/Kernel/System/WebUserAgent.pm
otrs/Kernel/System/XML.pm
otrs/Kernel/System/YAML.pm
+otrs/ARCHIVE
otrs/RELEASE
otrs/bin/Cron.sh
otrs/bin/cgi-bin/app.psgi
@@ -951,18 +952,18 @@ otrs/scripts/tools/md5sum.pl
otrs/scripts/tools/sync-ldap2db.pl
otrs/scripts/tools/xml2html.pl
otrs/scripts/webform.pl
-otrs/var/cron/aaa_base.dist
-otrs/var/cron/cache.dist
-otrs/var/cron/fetchmail.dist
-otrs/var/cron/generate_dashboard_stats.dist
-otrs/var/cron/generic_agent-database.dist
-otrs/var/cron/generic_agent.dist
-otrs/var/cron/pending_jobs.dist
-otrs/var/cron/postmaster.dist
-otrs/var/cron/postmaster_mailbox.dist
-otrs/var/cron/rebuild_ticket_index.dist
-otrs/var/cron/session.dist
-otrs/var/cron/unlock.dist
+otrs/var/cron/aaa_base
+otrs/var/cron/cache
+otrs/var/cron/fetchmail
+otrs/var/cron/generate_dashboard_stats
+otrs/var/cron/generic_agent-database
+otrs/var/cron/generic_agent
+otrs/var/cron/pending_jobs
+otrs/var/cron/postmaster
+otrs/var/cron/postmaster_mailbox
+otrs/var/cron/rebuild_ticket_index
+otrs/var/cron/session
+otrs/var/cron/unlock
otrs/var/fonts/DejaVuSans-Bold.ttf
otrs/var/fonts/DejaVuSans-BoldOblique.ttf
otrs/var/fonts/DejaVuSans-Oblique.ttf
@@ -2472,6 +2473,7 @@ otrs/var/stats/Stats.TicketOverview.en.xml
@dirrm otrs/bin/fcgi-bin
@dirrm otrs/bin/cgi-bin
@dirrm otrs/bin
+@dirrm otrs/doc
@dirrm otrs/Kernel/System/Web/UploadCache
@dirrm otrs/Kernel/System/Web
@dirrm otrs/Kernel/System/VirtualFS