aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-12-09 04:03:48 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-12-09 04:03:48 +0800
commitd559add8785512843b66bfc2dfddba96110e933d (patch)
tree1d2a89ab6ddd0a9fe18fce36a6890f395e9d4257 /devel
parent827c6381d11bd79a10cffc8155bc2913200b45da (diff)
downloadfreebsd-ports-gnome-d559add8785512843b66bfc2dfddba96110e933d.tar.gz
freebsd-ports-gnome-d559add8785512843b66bfc2dfddba96110e933d.tar.zst
freebsd-ports-gnome-d559add8785512843b66bfc2dfddba96110e933d.zip
Fast-stemmer is simply a wrapping around multithreaded Porter stemming algorithm.
This gem adds a String#stem method, and it conflicts with the stemmer gem. It's in order of magnitude faster (and uses much less memory) than the latter. For the original work please see: tartarus.org/~martin/PorterStemmer/ WWW: https://github.com/romanbsd/fast-stemmer
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-fast-stemmer/Makefile19
-rw-r--r--devel/rubygem-fast-stemmer/distinfo2
-rw-r--r--devel/rubygem-fast-stemmer/pkg-descr8
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a5570803dd0b..9d9b8d9f3cae 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3116,6 +3116,7 @@
SUBDIR += rubygem-eventmachine
SUBDIR += rubygem-extlib
SUBDIR += rubygem-facets
+ SUBDIR += rubygem-fast-stemmer
SUBDIR += rubygem-fastercsv
SUBDIR += rubygem-fastthread
SUBDIR += rubygem-fattr
diff --git a/devel/rubygem-fast-stemmer/Makefile b/devel/rubygem-fast-stemmer/Makefile
new file mode 100644
index 000000000000..ddacae9d5b73
--- /dev/null
+++ b/devel/rubygem-fast-stemmer/Makefile
@@ -0,0 +1,19 @@
+# Ports collection makefile for: rubygem-fast-stemmer
+# Date created: 2010-12-08
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+
+PORTNAME= fast-stemmer
+PORTVERSION= 1.0.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Fast Porter stemmer based on a C version of algorithm
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-fast-stemmer/distinfo b/devel/rubygem-fast-stemmer/distinfo
new file mode 100644
index 000000000000..f3aea008415a
--- /dev/null
+++ b/devel/rubygem-fast-stemmer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/fast-stemmer-1.0.0.gem) = c30bb85906d60733832ce9549db2673ff44342a65e546dbdfc3744c107fb024c
+SIZE (rubygem/fast-stemmer-1.0.0.gem) = 9728
diff --git a/devel/rubygem-fast-stemmer/pkg-descr b/devel/rubygem-fast-stemmer/pkg-descr
new file mode 100644
index 000000000000..b08112b224a6
--- /dev/null
+++ b/devel/rubygem-fast-stemmer/pkg-descr
@@ -0,0 +1,8 @@
+Fast-stemmer is simply a wrapping around multithreaded Porter stemming algorithm.
+
+This gem adds a String#stem method, and it conflicts with the stemmer gem.
+It's in order of magnitude faster (and uses much less memory) than the latter.
+
+For the original work please see: tartarus.org/~martin/PorterStemmer/
+
+WWW: https://github.com/romanbsd/fast-stemmer