aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-08-13 23:07:24 +0800
committermiwi <miwi@FreeBSD.org>2009-08-13 23:07:24 +0800
commitd72fd6910ee57a4dbd13d703416fe736c5f53a6f (patch)
treed3d698236ade4c7e1e124b0b19ef9748477f8ff4 /devel
parent31258a5489ecdc1c832db540a8013ca2ea444cd7 (diff)
downloadfreebsd-ports-gnome-d72fd6910ee57a4dbd13d703416fe736c5f53a6f.tar.gz
freebsd-ports-gnome-d72fd6910ee57a4dbd13d703416fe736c5f53a6f.tar.zst
freebsd-ports-gnome-d72fd6910ee57a4dbd13d703416fe736c5f53a6f.zip
Perl common defaults with lower memory usage
WWW: http://search.cpan.org/dist/common-sense/ PR: ports/137693 Submitted by: Mons Anderson <mons at cpan.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-common-sense/Makefile22
-rw-r--r--devel/p5-common-sense/distinfo3
-rw-r--r--devel/p5-common-sense/pkg-descr3
-rw-r--r--devel/p5-common-sense/pkg-plist6
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 768560c7a2c1..7fff712e84f9 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2065,6 +2065,7 @@
SUBDIR += p5-base
SUBDIR += p5-boolean
SUBDIR += p5-capitalization
+ SUBDIR += p5-common-sense
SUBDIR += p5-constant-def
SUBDIR += p5-constant-lexical
SUBDIR += p5-doxygenfilter
diff --git a/devel/p5-common-sense/Makefile b/devel/p5-common-sense/Makefile
new file mode 100644
index 000000000000..130687d1c650
--- /dev/null
+++ b/devel/p5-common-sense/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-common-sense
+# Date created: 2009-08-12
+# Whom: Mons Anderson <mons@cpan.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= common-sense
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/M/ML/MLEHMANN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mons@cpan.org
+COMMENT= Perl common defaults with lower memory usage
+
+PERL_CONFIGURE= yes
+
+MAN3= common::sense.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-common-sense/distinfo b/devel/p5-common-sense/distinfo
new file mode 100644
index 000000000000..fb017a2503d6
--- /dev/null
+++ b/devel/p5-common-sense/distinfo
@@ -0,0 +1,3 @@
+MD5 (common-sense-0.04.tar.gz) = 53b913c385384b17cd439a01b3d323e9
+SHA256 (common-sense-0.04.tar.gz) = e2a8a6d8a7f9ec480e9dc01366e2f5bb95ee73fca6a2e2428aa280603f1485fa
+SIZE (common-sense-0.04.tar.gz) = 4576
diff --git a/devel/p5-common-sense/pkg-descr b/devel/p5-common-sense/pkg-descr
new file mode 100644
index 000000000000..647f67494621
--- /dev/null
+++ b/devel/p5-common-sense/pkg-descr
@@ -0,0 +1,3 @@
+Perl common defaults with lower memory usage
+
+WWW: http://search.cpan.org/dist/common-sense/
diff --git a/devel/p5-common-sense/pkg-plist b/devel/p5-common-sense/pkg-plist
new file mode 100644
index 000000000000..fdf3b5c613c7
--- /dev/null
+++ b/devel/p5-common-sense/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/common/sense.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/common/sense/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/common/sense
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/common
+@dirrmtry %%SITE_PERL%%/common