aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-11-16 22:52:00 +0800
committerantoine <antoine@FreeBSD.org>2013-11-16 22:52:00 +0800
commitd767cd37b75601174023065f8432a9fa2f228c61 (patch)
tree6a765ae480486de52eaea1033abe337083027d6c /devel
parentb6d44f97638c605f48cece66d7614f005b8897e1 (diff)
downloadfreebsd-ports-gnome-d767cd37b75601174023065f8432a9fa2f228c61.tar.gz
freebsd-ports-gnome-d767cd37b75601174023065f8432a9fa2f228c61.tar.zst
freebsd-ports-gnome-d767cd37b75601174023065f8432a9fa2f228c61.zip
Stage support
Diffstat (limited to 'devel')
-rw-r--r--devel/py-binplist/Makefile1
-rw-r--r--devel/py-docopt/Makefile9
2 files changed, 4 insertions, 6 deletions
diff --git a/devel/py-binplist/Makefile b/devel/py-binplist/Makefile
index dcbafb71623c..8b2e48b52352 100644
--- a/devel/py-binplist/Makefile
+++ b/devel/py-binplist/Makefile
@@ -20,5 +20,4 @@ USE_PYDISTUTILS=easy_install
PLIST_FILES= bin/plist.py \
%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/py-docopt/Makefile b/devel/py-docopt/Makefile
index 069a4ebdde9c..de73df31e451 100644
--- a/devel/py-docopt/Makefile
+++ b/devel/py-docopt/Makefile
@@ -25,17 +25,16 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>