aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-05 15:53:27 +0800
committerbapt <bapt@FreeBSD.org>2013-05-05 15:53:27 +0800
commitda644d746b21d80b4fb72e1a6e3173793aab4eab (patch)
treebaef3d3e8685643ba5d51ed92d6f0a8be9479c6c /devel
parentc355f27cf3f5ec27ddcf7e50c1cafff3bb40b17a (diff)
downloadfreebsd-ports-gnome-da644d746b21d80b4fb72e1a6e3173793aab4eab.tar.gz
freebsd-ports-gnome-da644d746b21d80b4fb72e1a6e3173793aab4eab.tar.zst
freebsd-ports-gnome-da644d746b21d80b4fb72e1a6e3173793aab4eab.zip
Fix build with bmake and convert to new options framework
Diffstat (limited to 'devel')
-rw-r--r--devel/gsoap/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/gsoap/Makefile b/devel/gsoap/Makefile
index 765bd55bb4a1..b9bb3407417c 100644
--- a/devel/gsoap/Makefile
+++ b/devel/gsoap/Makefile
@@ -5,14 +5,14 @@ PORTNAME= gsoap
PORTVERSION= 2.8.10
PORTREVISION= 1
CATEGORIES= devel
-MASTER_SITES= SF/${PORTNAME}2/gSOAP
+MASTER_SITES= SF/${PORTNAME}2/gSOAP
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= sem@FreeBSD.org
COMMENT= Generator Tools for Coding SOAP/XML Web Services in C and C++
-OPTIONS= OPENSSL "Enable SSL/TLS (OpenSSL from base)" on \
- GNUTLS "Enable SSL/TLS (GnuTLS)" off
+OPTIONS_DEFINE= OPENSSL GNUTLS
+OPTIONS_DEFAULT= OPENSSL
USE_ZIP= yes
GNU_CONFIGURE= yes
@@ -21,6 +21,10 @@ MAKE_JOBS_UNSAFE= yes
CFLAGS+= -DWSDL_TYPEMAP_FILE=\\\"${DATADIR}/WS/typemap.dat\\\" \
-DSOAPCPP2_IMPORT_PATH=\\\"${DATADIR}/import\\\"
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
ONLY_FOR_ARCHS= i386 amd64
@@ -31,11 +35,11 @@ ONLY_FOR_ARCHS= i386 amd64
CFLAGS+= -fPIC
.endif
-.if defined(WITHOUT_OPENSSL) && defined(WITHOUT_GNUTLS)
+.if ! ${PORT_OPTIONS:MOPENSSL} && ! ${PORT_OPTIONS:MGNUTLS}
CONFIGURE_ARGS+=--disable-ssl
.endif
-.if defined(WITH_GNUTLS)
+.if ${PORT_OPTIONS:MGNUTLS}
LIB_DEPENDS+= gnutls.47:${PORTSDIR}/security/gnutls \
gcrypt:${PORTSDIR}/security/libgcrypt \
gpg-error.0:${PORTSDIR}/security/libgpg-error