aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-02-11 21:07:44 +0800
committergahr <gahr@FreeBSD.org>2013-02-11 21:07:44 +0800
commitdbec973b3a6c6cffb249ca02dc40630066ad5dcc (patch)
tree50238a0427427faf5241941368be311348297312 /devel
parent2ee6b9386c3a98768260f89fc58e5531a23738fe (diff)
downloadfreebsd-ports-gnome-dbec973b3a6c6cffb249ca02dc40630066ad5dcc.tar.gz
freebsd-ports-gnome-dbec973b3a6c6cffb249ca02dc40630066ad5dcc.tar.zst
freebsd-ports-gnome-dbec973b3a6c6cffb249ca02dc40630066ad5dcc.zip
- Fix build
- While at it, get rid of PTHREAD_ variables
Diffstat (limited to 'devel')
-rw-r--r--devel/clanlib/Makefile4
-rw-r--r--devel/clanlib/files/patch-Sources__Network__Socket__socket_name.cpp10
2 files changed, 12 insertions, 2 deletions
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index eaafa6cb9571..b536305390e0 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -33,8 +33,8 @@ USE_PKGCONFIG= yes
USE_SQLITE= yes
MAKE_JOBS_SAFE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15 ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+LDFLAGS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-docs \
--enable-clanDisplay \
diff --git a/devel/clanlib/files/patch-Sources__Network__Socket__socket_name.cpp b/devel/clanlib/files/patch-Sources__Network__Socket__socket_name.cpp
new file mode 100644
index 000000000000..044cb745f411
--- /dev/null
+++ b/devel/clanlib/files/patch-Sources__Network__Socket__socket_name.cpp
@@ -0,0 +1,10 @@
+--- ./Sources/Network/Socket/socket_name.cpp.orig 2013-02-11 14:02:51.000000000 +0100
++++ ./Sources/Network/Socket/socket_name.cpp 2013-02-11 14:04:33.000000000 +0100
+@@ -34,6 +34,7 @@
+ #ifdef WIN32
+ typedef unsigned long in_addr_t;
+ #else
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>