aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2013-11-30 04:15:48 +0800
committernox <nox@FreeBSD.org>2013-11-30 04:15:48 +0800
commitdca5d074407211a1c9861c90de0d278574b4f017 (patch)
tree0383f80b214bcaec1055c57c462ef1e0285abe6e /devel
parent267c2934f0aeeaeacfe8333a8e4bbcc38cb766c7 (diff)
downloadfreebsd-ports-gnome-dca5d074407211a1c9861c90de0d278574b4f017.tar.gz
freebsd-ports-gnome-dca5d074407211a1c9861c90de0d278574b4f017.tar.zst
freebsd-ports-gnome-dca5d074407211a1c9861c90de0d278574b4f017.zip
Add devel/py-singledispatch:
This library brings functools.singledispatch from Python 3.4 to Python 2.6-3.3. PEP 443 proposed to expose a mechanism in the functools standard library module in Python 3.4 that provides a simple form of generic programming known as single-dispatch generic functions. This library is a backport of this functionality to Python 2.6 - 3.3. WWW: https://pypi.python.org/pypi/singledispatch
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-singledispatch/Makefile19
-rw-r--r--devel/py-singledispatch/distinfo2
-rw-r--r--devel/py-singledispatch/pkg-descr10
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 15ad0f3f7e5b..c01ba88409f6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3766,6 +3766,7 @@
SUBDIR += py-simpleparse
SUBDIR += py-simpletal
SUBDIR += py-simpy
+ SUBDIR += py-singledispatch
SUBDIR += py-sip
SUBDIR += py-six
SUBDIR += py-smmap
diff --git a/devel/py-singledispatch/Makefile b/devel/py-singledispatch/Makefile
new file mode 100644
index 000000000000..715e9eabc166
--- /dev/null
+++ b/devel/py-singledispatch/Makefile
@@ -0,0 +1,19 @@
+# Created by: Juergen Lock <nox@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= singledispatch
+PORTVERSION= 3.4.0.2
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= provides single-dispatch generic functions
+
+LICENSE= MIT
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-singledispatch/distinfo b/devel/py-singledispatch/distinfo
new file mode 100644
index 000000000000..803813059687
--- /dev/null
+++ b/devel/py-singledispatch/distinfo
@@ -0,0 +1,2 @@
+SHA256 (singledispatch-3.4.0.2.tar.gz) = 4bdd0307cae0d13abb0546df1ab85201b9067090d191e33387e27e1463a7bfd5
+SIZE (singledispatch-3.4.0.2.tar.gz) = 9499
diff --git a/devel/py-singledispatch/pkg-descr b/devel/py-singledispatch/pkg-descr
new file mode 100644
index 000000000000..a64bc682c7e9
--- /dev/null
+++ b/devel/py-singledispatch/pkg-descr
@@ -0,0 +1,10 @@
+This library brings functools.singledispatch from Python 3.4 to
+Python 2.6-3.3.
+
+PEP 443 proposed to expose a mechanism in the functools standard
+library module in Python 3.4 that provides a simple form of generic
+programming known as single-dispatch generic functions.
+
+This library is a backport of this functionality to Python 2.6 - 3.3.
+
+WWW: https://pypi.python.org/pypi/singledispatch