aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2011-05-25 08:09:22 +0800
committerbeech <beech@FreeBSD.org>2011-05-25 08:09:22 +0800
commitdd06ec9f3143e36a0eefb5890c685a9080df904f (patch)
tree05d1b82922a9083196463b3a8a4934e85d978371 /devel
parent0937d136fc78219b6595f1ebd44a087d7d3d5711 (diff)
downloadfreebsd-ports-gnome-dd06ec9f3143e36a0eefb5890c685a9080df904f.tar.gz
freebsd-ports-gnome-dd06ec9f3143e36a0eefb5890c685a9080df904f.tar.zst
freebsd-ports-gnome-dd06ec9f3143e36a0eefb5890c685a9080df904f.zip
Horde package for creating and manipulating dates.
Approved by: itetcu (mentor)(implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/horde4-date/Makefile41
-rw-r--r--devel/horde4-date/distinfo2
-rw-r--r--devel/horde4-date/files/pkg-message.in7
-rw-r--r--devel/horde4-date/pkg-descr4
-rw-r--r--devel/horde4-date/pkg-plist26
6 files changed, 81 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 767dab053831..43802018ed02 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -553,6 +553,7 @@
SUBDIR += horde-chora
SUBDIR += horde-whups
SUBDIR += horde4-content
+ SUBDIR += horde4-date
SUBDIR += horde4-rdo
SUBDIR += hp48cc
SUBDIR += hp48xgcc
diff --git a/devel/horde4-date/Makefile b/devel/horde4-date/Makefile
new file mode 100644
index 000000000000..050dc60dd9c0
--- /dev/null
+++ b/devel/horde4-date/Makefile
@@ -0,0 +1,41 @@
+# Ports collection makefile for: horde4-date
+# Date created: Tue May 24, 2011
+# Whom: Beech Rintoul (<beech@FreeBSD.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= date
+PORTVERSION= 1.0.1
+DISTVERSIONPREFIX=
+DISTVERSIONSUFFIX=
+CATEGORIES= devel www
+MASTER_SITES= http://pear.horde.org/get/ \
+ LOCAL/beech
+PKGNAMEPREFIX= horde4-
+DISTNAME= Horde_Date-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= beech@FreeBSD.org
+COMMENT= Horde date package
+
+USE_HORDE= base
+USE_GETTEXT= yes
+DATEDIR= Date
+HORDIR+= ${HORBAS}${DATEDIR:S|^|/|:S|/horde||}
+
+post-extract:
+ @${MKDIR} ${WRKSRC}/config && ${TOUCH} ${WRKSRC}/config/placeholder.dist
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/lib/Horde/Date.php ${HORBAS}/
+ @${CP} -Rp ${WRKSRC}/lib/Horde/Date/ ${HORDIR}/
+ @${ECHO_CMD} @exec ${CHOWN} -R ${WWWOWN}:${WWWGRP} %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} @exec ${CHMOD} -R o-rwx %D/${HORDIR:S|^${PREFIX}/||}/ >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec ${TOUCH} ${HORLOG};${CHOWN} ${WWWOWN}:${WWWGRP} ${HORLOG}" >> ${TMPPLIST}
+ @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
+
+.include "${.CURDIR}/../../www/horde4-base/bsd.horde4.mk"
+.include <bsd.port.mk>
diff --git a/devel/horde4-date/distinfo b/devel/horde4-date/distinfo
new file mode 100644
index 000000000000..c815d3538cdd
--- /dev/null
+++ b/devel/horde4-date/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Horde_Date-1.0.1.tgz) = 5c8c9db7d70206aed3fdfcf53b6a8a4c2c961754f3048633c694509ffa852ebe
+SIZE (Horde_Date-1.0.1.tgz) = 44856
diff --git a/devel/horde4-date/files/pkg-message.in b/devel/horde4-date/files/pkg-message.in
new file mode 100644
index 000000000000..505cb78797d0
--- /dev/null
+++ b/devel/horde4-date/files/pkg-message.in
@@ -0,0 +1,7 @@
+************************************************************************
+Date has been installed in %%HORDIR%%/.
+
+Horde must be configured and the tables created; if not, see
+`pkg_info -Dx horde-base'.
+
+************************************************************************
diff --git a/devel/horde4-date/pkg-descr b/devel/horde4-date/pkg-descr
new file mode 100644
index 000000000000..64ce8b8eddd0
--- /dev/null
+++ b/devel/horde4-date/pkg-descr
@@ -0,0 +1,4 @@
+Horde package for creating and manipulating dates.
+
+
+WWW: http://www.horde.org/
diff --git a/devel/horde4-date/pkg-plist b/devel/horde4-date/pkg-plist
new file mode 100644
index 000000000000..da077506dc2a
--- /dev/null
+++ b/devel/horde4-date/pkg-plist
@@ -0,0 +1,26 @@
+%%HORBAS%%/Date.php
+%%HORDIR%%/Exception.php
+%%HORDIR%%/Recurrence.php
+%%HORDIR%%/Repeater.php
+%%HORDIR%%/Repeater/Day.php
+%%HORDIR%%/Repeater/DayName.php
+%%HORDIR%%/Repeater/DayPortion.php
+%%HORDIR%%/Repeater/Exception.php
+%%HORDIR%%/Repeater/Fortnight.php
+%%HORDIR%%/Repeater/Hour.php
+%%HORDIR%%/Repeater/Minute.php
+%%HORDIR%%/Repeater/Month.php
+%%HORDIR%%/Repeater/MonthName.php
+%%HORDIR%%/Repeater/Season.php
+%%HORDIR%%/Repeater/SeasonName.php
+%%HORDIR%%/Repeater/Second.php
+%%HORDIR%%/Repeater/Time.php
+%%HORDIR%%/Repeater/Week.php
+%%HORDIR%%/Repeater/Weekend.php
+%%HORDIR%%/Repeater/Year.php
+%%HORDIR%%/Span.php
+%%HORDIR%%/Translation.php
+%%HORDIR%%/Utils.php
+@dirrm %%HORDIR%%/Repeater
+@dirrmtry %%HORDIR%%
+@dirrmtry %%HORBAS%%