aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2015-05-14 04:53:38 +0800
committerjgh <jgh@FreeBSD.org>2015-05-14 04:53:38 +0800
commitde2d44ff33e3b2f14c7e7e733fb2bcfdf6234ee1 (patch)
treea0e03a5a2b3952f7ba386911dd20e287d228b0c1 /devel
parent4aa75031d4ee116c3b3866c750297e31062175ca (diff)
downloadfreebsd-ports-gnome-de2d44ff33e3b2f14c7e7e733fb2bcfdf6234ee1.tar.gz
freebsd-ports-gnome-de2d44ff33e3b2f14c7e7e733fb2bcfdf6234ee1.tar.zst
freebsd-ports-gnome-de2d44ff33e3b2f14c7e7e733fb2bcfdf6234ee1.zip
Add new port: devel/spice-protocol
Spice protocol defines a set of protocol messages for accessing, controlling, and receiving inputs from remote computing devices (e.g., keyboard, video, mouse) across networks, and sending output to them. A controlled device can reside on either side, client and/or server. WWW: http://www.spice-space.org PR: 200046 (to support fixing)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/spice-protocol/Makefile17
-rw-r--r--devel/spice-protocol/distinfo2
-rw-r--r--devel/spice-protocol/pkg-descr7
-rw-r--r--devel/spice-protocol/pkg-plist17
5 files changed, 44 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a55c36b08894..af29bbd05e99 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4821,6 +4821,7 @@
SUBDIR += spark
SUBDIR += spatialindex
SUBDIR += spdict
+ SUBDIR += spice-protocol
SUBDIR += spin
SUBDIR += splint
SUBDIR += srecord
diff --git a/devel/spice-protocol/Makefile b/devel/spice-protocol/Makefile
new file mode 100644
index 000000000000..fc17e6bb41f4
--- /dev/null
+++ b/devel/spice-protocol/Makefile
@@ -0,0 +1,17 @@
+# Created by: Jason Helfman <jgh@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= spice-protocol
+PORTVERSION= 0.12.7
+CATEGORIES= devel
+MASTER_SITES= http://www.spice-space.org/download/releases/
+
+MAINTAINER= jgh@FreeBSD.org
+COMMENT= Simple Protocol for Independent Computing Environments
+
+LICENSE= BSD3CLAUSE
+
+GNU_CONFIGURE= yes
+USES= pathfix pkgconfig tar:bzip2
+
+.include <bsd.port.mk>
diff --git a/devel/spice-protocol/distinfo b/devel/spice-protocol/distinfo
new file mode 100644
index 000000000000..b55e1e08f440
--- /dev/null
+++ b/devel/spice-protocol/distinfo
@@ -0,0 +1,2 @@
+SHA256 (spice-protocol-0.12.7.tar.bz2) = 96c6cb73361816ed19bfd8536f65d4547da35709aa00af1380e650c1174916c2
+SIZE (spice-protocol-0.12.7.tar.bz2) = 71276
diff --git a/devel/spice-protocol/pkg-descr b/devel/spice-protocol/pkg-descr
new file mode 100644
index 000000000000..710563319907
--- /dev/null
+++ b/devel/spice-protocol/pkg-descr
@@ -0,0 +1,7 @@
+Spice protocol defines a set of protocol messages for accessing,
+controlling, and receiving inputs from remote computing devices
+(e.g., keyboard, video, mouse) across networks, and sending output
+to them. A controlled device can reside on either side, client
+and/or server.
+
+WWW: http://www.spice-space.org
diff --git a/devel/spice-protocol/pkg-plist b/devel/spice-protocol/pkg-plist
new file mode 100644
index 000000000000..a926906bf094
--- /dev/null
+++ b/devel/spice-protocol/pkg-plist
@@ -0,0 +1,17 @@
+include/spice-1/spice/barrier.h
+include/spice-1/spice/controller_prot.h
+include/spice-1/spice/end-packed.h
+include/spice-1/spice/enums.h
+include/spice-1/spice/error_codes.h
+include/spice-1/spice/foreign_menu_prot.h
+include/spice-1/spice/ipc_ring.h
+include/spice-1/spice/macros.h
+include/spice-1/spice/protocol.h
+include/spice-1/spice/qxl_dev.h
+include/spice-1/spice/qxl_windows.h
+include/spice-1/spice/start-packed.h
+include/spice-1/spice/stats.h
+include/spice-1/spice/types.h
+include/spice-1/spice/vd_agent.h
+include/spice-1/spice/vdi_dev.h
+libdata/pkgconfig/spice-protocol.pc