aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2012-10-30 06:58:42 +0800
committerbdrewery <bdrewery@FreeBSD.org>2012-10-30 06:58:42 +0800
commite0a57c1fe002556504d952608d74f1b206f6d71a (patch)
tree37b2c4e4a8f80305fd69cb4655a52f76e7df73fa /devel
parent2be249806d5ffdca2da5f135585e023c841aca7d (diff)
downloadfreebsd-ports-gnome-e0a57c1fe002556504d952608d74f1b206f6d71a.tar.gz
freebsd-ports-gnome-e0a57c1fe002556504d952608d74f1b206f6d71a.tar.zst
freebsd-ports-gnome-e0a57c1fe002556504d952608d74f1b206f6d71a.zip
The Automated Testing Framework (ATF) is a collection of libraries and
utilities designed to ease unattended application testing in the hands of developers and end users of a specific piece of software. As regards developers, ATF provides the necessary means to easily create test suites composed of multiple test programs, which in turn are a collection of test cases. It also attempts to simplify the debugging of problems when these test cases detect an error by providing as much information as possible about the failure. As regards users, it simplifies the process of running the test suites and, in special, encourages end users to run them often: they do not need to have source trees around nor any other development tools installed to be able to certify that a given piece of software works on their machine as advertised. Note that ATF is included in the base system since FreeBSD 10, so this port does not need to be installed on FreeBSD 10. WWW: http://code.google.com/p/kyua/wiki/ATF PR: ports/173197 Submitted by: Roman Naumann <namor@hemio.de> Reviewed by: bapt, eadler Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/atf/Makefile40
-rw-r--r--devel/atf/distinfo2
-rw-r--r--devel/atf/pkg-descr20
-rw-r--r--devel/atf/pkg-plist125
5 files changed, 188 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b2a8c7e6acc4..f44f9f6737da 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -75,6 +75,7 @@
SUBDIR += asmx
SUBDIR += astah-community
SUBDIR += astyle
+ SUBDIR += atf
SUBDIR += atlas
SUBDIR += atlas-devel
SUBDIR += ats-contrib-testing
diff --git a/devel/atf/Makefile b/devel/atf/Makefile
new file mode 100644
index 000000000000..e2fc0d5b421e
--- /dev/null
+++ b/devel/atf/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= atf
+PORTVERSION= 0.16
+CATEGORIES= devel
+MASTER_SITES= GOOGLE_CODE
+
+MAINTAINER= namor@hemio.de
+COMMENT= Automated Testing Framework
+
+LICENSE= BSD
+
+USE_LDCONFIG= yes
+
+PROJECTHOST= kyua
+
+MAN1= atf-check.1 \
+ atf-sh.1 \
+ atf-test-program.1
+MAN3= atf-c-api.3 \
+ atf-c++-api.3 \
+ atf-sh-api.3
+MAN4= atf-test-case.4
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 1000021
+IGNORE= is already in the base system
+.endif
+
+post-patch:
+.if empty(PORT_OPTIONS:MDOCS)
+ @${REINPLACE_CMD} -e 's|install-docDATA[^:]||' ${WRKSRC}/Makefile.in
+.endif
+ @${REINPLACE_CMD} -e 's|@atf_pkgconfigdir@|${PREFIX}/libdata/pkgconfig|' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/devel/atf/distinfo b/devel/atf/distinfo
new file mode 100644
index 000000000000..f95a0f117537
--- /dev/null
+++ b/devel/atf/distinfo
@@ -0,0 +1,2 @@
+SHA256 (atf-0.16.tar.gz) = f33a85f4a0677f40be406baaf6a5a749ca02870af9707f7606a0f3fa613c8339
+SIZE (atf-0.16.tar.gz) = 662290
diff --git a/devel/atf/pkg-descr b/devel/atf/pkg-descr
new file mode 100644
index 000000000000..8f22185ea8d1
--- /dev/null
+++ b/devel/atf/pkg-descr
@@ -0,0 +1,20 @@
+The Automated Testing Framework (ATF) is a collection of libraries and
+utilities designed to ease unattended application testing in the hands of
+developers and end users of a specific piece of software.
+
+As regards developers, ATF provides the necessary means to easily create
+test suites composed of multiple test programs, which in turn are a
+collection of test cases. It also attempts to simplify the debugging of
+problems when these test cases detect an error by providing as much
+information as possible about the failure.
+
+As regards users, it simplifies the process of running the test suites and,
+in special, encourages end users to run them often: they do not need to
+have source trees around nor any other development tools installed to be
+able to certify that a given piece of software works on their machine as
+advertised.
+
+Note that ATF is included in the base system since FreeBSD 10, so this
+port does not need to be installed on FreeBSD 10.
+
+WWW: http://code.google.com/p/kyua/wiki/ATF
diff --git a/devel/atf/pkg-plist b/devel/atf/pkg-plist
new file mode 100644
index 000000000000..06ca706ffd28
--- /dev/null
+++ b/devel/atf/pkg-plist
@@ -0,0 +1,125 @@
+bin/atf-sh
+include/atf-c++.hpp
+include/atf-c++/build.hpp
+include/atf-c++/check.hpp
+include/atf-c++/config.hpp
+include/atf-c++/macros.hpp
+include/atf-c++/tests.hpp
+include/atf-c++/utils.hpp
+include/atf-c.h
+include/atf-c/build.h
+include/atf-c/check.h
+include/atf-c/config.h
+include/atf-c/defs.h
+include/atf-c/error.h
+include/atf-c/error_fwd.h
+include/atf-c/macros.h
+include/atf-c/tc.h
+include/atf-c/tp.h
+include/atf-c/utils.h
+lib/libatf-c++.a
+lib/libatf-c++.la
+lib/libatf-c++.so
+lib/libatf-c++.so.0
+lib/libatf-c.a
+lib/libatf-c.la
+lib/libatf-c.so
+lib/libatf-c.so.0
+libdata/pkgconfig/atf-c++.pc
+libdata/pkgconfig/atf-c.pc
+libdata/pkgconfig/atf-sh.pc
+libexec/atf-check
+share/aclocal/atf-c++.m4
+share/aclocal/atf-c.m4
+share/aclocal/atf-common.m4
+share/aclocal/atf-sh.m4
+%%DATADIR%%/libatf-sh.subr
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+tests/atf/Kyuafile
+tests/atf/atf-c++/Atffile
+tests/atf/atf-c++/Kyuafile
+tests/atf/atf-c++/atf_c++_test
+tests/atf/atf-c++/build_test
+tests/atf/atf-c++/check_test
+tests/atf/atf-c++/config_test
+tests/atf/atf-c++/detail/Atffile
+tests/atf/atf-c++/detail/Kyuafile
+tests/atf/atf-c++/detail/application_test
+tests/atf/atf-c++/detail/env_test
+tests/atf/atf-c++/detail/exceptions_test
+tests/atf/atf-c++/detail/expand_test
+tests/atf/atf-c++/detail/fs_test
+tests/atf/atf-c++/detail/parser_test
+tests/atf/atf-c++/detail/process_test
+tests/atf/atf-c++/detail/sanity_test
+tests/atf/atf-c++/detail/text_test
+tests/atf/atf-c++/detail/ui_test
+tests/atf/atf-c++/macros_hpp_test.cpp
+tests/atf/atf-c++/macros_test
+tests/atf/atf-c++/pkg_config_test
+tests/atf/atf-c++/tests_test
+tests/atf/atf-c++/unused_test.cpp
+tests/atf/atf-c++/utils_test
+tests/atf/atf-c/Atffile
+tests/atf/atf-c/Kyuafile
+tests/atf/atf-c/atf_c_test
+tests/atf/atf-c/build_test
+tests/atf/atf-c/check_test
+tests/atf/atf-c/config_test
+tests/atf/atf-c/detail/Atffile
+tests/atf/atf-c/detail/Kyuafile
+tests/atf/atf-c/detail/dynstr_test
+tests/atf/atf-c/detail/env_test
+tests/atf/atf-c/detail/fs_test
+tests/atf/atf-c/detail/list_test
+tests/atf/atf-c/detail/map_test
+tests/atf/atf-c/detail/process_helpers
+tests/atf/atf-c/detail/process_test
+tests/atf/atf-c/detail/sanity_test
+tests/atf/atf-c/detail/test_helpers_test
+tests/atf/atf-c/detail/text_test
+tests/atf/atf-c/detail/user_test
+tests/atf/atf-c/error_test
+tests/atf/atf-c/macros_h_test.c
+tests/atf/atf-c/macros_test
+tests/atf/atf-c/pkg_config_test
+tests/atf/atf-c/tc_test
+tests/atf/atf-c/tp_test
+tests/atf/atf-c/unused_test.c
+tests/atf/atf-c/utils_test
+tests/atf/atf-sh/Atffile
+tests/atf/atf-sh/Kyuafile
+tests/atf/atf-sh/atf-check_test
+tests/atf/atf-sh/atf_check_test
+tests/atf/atf-sh/config_test
+tests/atf/atf-sh/integration_test
+tests/atf/atf-sh/misc_helpers
+tests/atf/atf-sh/normalize_test
+tests/atf/atf-sh/tc_test
+tests/atf/atf-sh/tp_test
+tests/atf/test-programs/Atffile
+tests/atf/test-programs/Kyuafile
+tests/atf/test-programs/c_helpers
+tests/atf/test-programs/config_test
+tests/atf/test-programs/cpp_helpers
+tests/atf/test-programs/expect_test
+tests/atf/test-programs/fork_test
+tests/atf/test-programs/meta_data_test
+tests/atf/test-programs/result_test
+tests/atf/test-programs/sh_helpers
+tests/atf/test-programs/srcdir_test
+@dirrm tests/atf/test-programs
+@dirrm tests/atf/atf-sh
+@dirrm tests/atf/atf-c/detail
+@dirrm tests/atf/atf-c++/detail
+@dirrm tests/atf/atf-c++
+@dirrm tests/atf/atf-c
+@dirrm tests/atf
+@dirrm tests
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%
+@dirrm include/atf-c++
+@dirrm include/atf-c