aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-12-23 05:19:26 +0800
committermiwi <miwi@FreeBSD.org>2008-12-23 05:19:26 +0800
commite3db5f8e986abcb9bf3e5fc2ac9ca74654c875b6 (patch)
treed87788c8497f7d42aa41257ba611640d0d5fb781 /devel
parentad26dff78c96d4d65329d39d6e5650d7cc5f5225 (diff)
downloadfreebsd-ports-gnome-e3db5f8e986abcb9bf3e5fc2ac9ca74654c875b6.tar.gz
freebsd-ports-gnome-e3db5f8e986abcb9bf3e5fc2ac9ca74654c875b6.tar.zst
freebsd-ports-gnome-e3db5f8e986abcb9bf3e5fc2ac9ca74654c875b6.zip
py-demjson provides classes and functions for encoding or decoding
data represented in the language-neutral JSON format (which is often used as a simpler substitute for XML in Ajax web applications). This implementation tries to be as compliant to the JSON specification (RFC 4627) as possible, while still providing many optional extensions to allow less restrictive JavaScript syntax. It includes complete Unicode support, including UTF-32, BOM, and surrogate pair processing. It can also support JavaScript's NaN and Infinity numeric types as well as it's 'undefined' type. It also includes a lint-like JSON syntax validator which tests JSON text for strict compliance to the standard. WWW: http://deron.meranda.us/python/demjson/ PR: ports/129711 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-demjson/Makefile21
-rw-r--r--devel/py-demjson/distinfo3
-rw-r--r--devel/py-demjson/pkg-descr12
-rw-r--r--devel/py-demjson/pkg-plist3
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 69f0123ab2ec..fc9f8f700e91 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2163,6 +2163,7 @@
SUBDIR += py-dbus
SUBDIR += py-decorator
SUBDIR += py-decoratortools
+ SUBDIR += py-demjson
SUBDIR += py-dialog
SUBDIR += py-distorm
SUBDIR += py-durus
diff --git a/devel/py-demjson/Makefile b/devel/py-demjson/Makefile
new file mode 100644
index 000000000000..5a98c1ddcde6
--- /dev/null
+++ b/devel/py-demjson/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: py-demjson
+# Date created: 2008-12-17
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= demjson
+PORTVERSION= 1.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP \
+ http://deron.meranda.us/python/demjson/dist/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Encoder, Decoder, and Lint/Validator for JSON
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-demjson/distinfo b/devel/py-demjson/distinfo
new file mode 100644
index 000000000000..c365743ce21b
--- /dev/null
+++ b/devel/py-demjson/distinfo
@@ -0,0 +1,3 @@
+MD5 (demjson-1.4.tar.gz) = 6f6c88bfe2443390230109c709243fcd
+SHA256 (demjson-1.4.tar.gz) = e5858dc54a80290cecbc1d1514c6ce50dca44fbd15ccc195c4a8b6969b45a41f
+SIZE (demjson-1.4.tar.gz) = 62439
diff --git a/devel/py-demjson/pkg-descr b/devel/py-demjson/pkg-descr
new file mode 100644
index 000000000000..1713de966cd5
--- /dev/null
+++ b/devel/py-demjson/pkg-descr
@@ -0,0 +1,12 @@
+py-demjson provides classes and functions for encoding or decoding
+data represented in the language-neutral JSON format (which is often
+used as a simpler substitute for XML in Ajax web applications). This
+implementation tries to be as compliant to the JSON specification (RFC
+4627) as possible, while still providing many optional extensions to
+allow less restrictive JavaScript syntax. It includes complete Unicode
+support, including UTF-32, BOM, and surrogate pair processing. It can
+also support JavaScript's NaN and Infinity numeric types as well as
+it's 'undefined' type. It also includes a lint-like JSON syntax
+validator which tests JSON text for strict compliance to the standard.
+
+WWW: http://deron.meranda.us/python/demjson/
diff --git a/devel/py-demjson/pkg-plist b/devel/py-demjson/pkg-plist
new file mode 100644
index 000000000000..8102f26f4449
--- /dev/null
+++ b/devel/py-demjson/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/demjson.py
+%%PYTHON_SITELIBDIR%%/demjson.pyo
+%%PYTHON_SITELIBDIR%%/demjson.pyc