aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjoe <joe@FreeBSD.org>2001-04-28 22:39:59 +0800
committerjoe <joe@FreeBSD.org>2001-04-28 22:39:59 +0800
commite48b24b857ce023bac05b10c7a038899ce0b5de2 (patch)
tree7e1bf403020f18551f84ed586fb2100690c277a6 /devel
parent264a3dedbe5c19daa950f94944753674a8036458 (diff)
downloadfreebsd-ports-gnome-e48b24b857ce023bac05b10c7a038899ce0b5de2.tar.gz
freebsd-ports-gnome-e48b24b857ce023bac05b10c7a038899ce0b5de2.tar.zst
freebsd-ports-gnome-e48b24b857ce023bac05b10c7a038899ce0b5de2.zip
This perl routine will take a prompt, a default response and a list
of possible responses and deal with the user interface, (and the user!), by displaying the prompt, showing the default, and checking to be sure that the response is one of the legal choices. PR: ports/26850
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Term-Prompt/Makefile25
-rw-r--r--devel/p5-Term-Prompt/distinfo1
-rw-r--r--devel/p5-Term-Prompt/pkg-comment1
-rw-r--r--devel/p5-Term-Prompt/pkg-descr7
-rw-r--r--devel/p5-Term-Prompt/pkg-plist4
6 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8263cb8826ef..8913d58da969 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -334,6 +334,7 @@
SUBDIR += p5-String-Random
SUBDIR += p5-String-RexxParse
SUBDIR += p5-Term-ANSIColor
+ SUBDIR += p5-Term-Prompt
SUBDIR += p5-Term-Query
SUBDIR += p5-Term-ReadKey
SUBDIR += p5-Term-Screen
diff --git a/devel/p5-Term-Prompt/Makefile b/devel/p5-Term-Prompt/Makefile
new file mode 100644
index 000000000000..ac4a0f97ad0b
--- /dev/null
+++ b/devel/p5-Term-Prompt/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Term-Prompt
+# Date created: 25 April 2001
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Term-Prompt
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Term
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Term::Prompt.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Term-Prompt/distinfo b/devel/p5-Term-Prompt/distinfo
new file mode 100644
index 000000000000..1bd59f967c70
--- /dev/null
+++ b/devel/p5-Term-Prompt/distinfo
@@ -0,0 +1 @@
+MD5 (Term-Prompt-0.10.tar.gz) = 3de1db62672ba0dfed167543886688c1
diff --git a/devel/p5-Term-Prompt/pkg-comment b/devel/p5-Term-Prompt/pkg-comment
new file mode 100644
index 000000000000..91681abc389c
--- /dev/null
+++ b/devel/p5-Term-Prompt/pkg-comment
@@ -0,0 +1 @@
+Perl extension for prompting a user for information
diff --git a/devel/p5-Term-Prompt/pkg-descr b/devel/p5-Term-Prompt/pkg-descr
new file mode 100644
index 000000000000..4d0aa36636f0
--- /dev/null
+++ b/devel/p5-Term-Prompt/pkg-descr
@@ -0,0 +1,7 @@
+This perl routine will take a prompt, a default response and a list
+of possible responses and deal with the user interface, (and the
+user!), by displaying the prompt, showing the default, and checking
+to be sure that the response is one of the legal choices.
+
+-Anton
+<tobez@tobez.org>
diff --git a/devel/p5-Term-Prompt/pkg-plist b/devel/p5-Term-Prompt/pkg-plist
new file mode 100644
index 000000000000..f4d1e17b8db9
--- /dev/null
+++ b/devel/p5-Term-Prompt/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Term/Prompt/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Term/Prompt.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Term/Prompt
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Term 2>/dev/null || true