aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2012-01-22 21:04:30 +0800
committertota <tota@FreeBSD.org>2012-01-22 21:04:30 +0800
commite6b4eb2517675352afab3042b07c90c46e3c09c5 (patch)
treeb1e12eba087646ebd502dfe4541647413532a7c8 /devel
parent86acf617019558296450fdf83baea294d9569ecc (diff)
downloadfreebsd-ports-gnome-e6b4eb2517675352afab3042b07c90c46e3c09c5.tar.gz
freebsd-ports-gnome-e6b4eb2517675352afab3042b07c90c46e3c09c5.tar.zst
freebsd-ports-gnome-e6b4eb2517675352afab3042b07c90c46e3c09c5.zip
- Add a new port: devel/rubygem-rainbow
Rainbow extends ruby String class adding methods to wrap the string with ANSI escape codes. Rainbow adds following methods to String class: * foreground(color) (with color and colour aliases) * background(color) * reset * bright * italic (not well supported by terminal emulators). * underline * blink * inverse * hide. WWW: https://github.com/sickill/rainbow
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-rainbow/Makefile20
-rw-r--r--devel/rubygem-rainbow/distinfo2
-rw-r--r--devel/rubygem-rainbow/pkg-descr16
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cbb9534e4023..fe1701c773a0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3657,6 +3657,7 @@
SUBDIR += rubygem-posix-spawn
SUBDIR += rubygem-ptreloaded
SUBDIR += rubygem-railsless-deploy
+ SUBDIR += rubygem-rainbow
SUBDIR += rubygem-rake
SUBDIR += rubygem-rake-compiler
SUBDIR += rubygem-rapt
diff --git a/devel/rubygem-rainbow/Makefile b/devel/rubygem-rainbow/Makefile
new file mode 100644
index 000000000000..583cc27280a6
--- /dev/null
+++ b/devel/rubygem-rainbow/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: rubygem-rainbow
+# Date created: 2012-01-11
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rainbow
+PORTVERSION= 1.1.3
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= Extends ruby String class enabling coloring text on ANSI terminals
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-rainbow/distinfo b/devel/rubygem-rainbow/distinfo
new file mode 100644
index 000000000000..bbfbb794ec3b
--- /dev/null
+++ b/devel/rubygem-rainbow/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/rainbow-1.1.3.gem) = e5726405e3ee2ec7fedc2e38b111bf3dd14e430b0d7dcc9bfd38c25e748bd9e2
+SIZE (rubygem/rainbow-1.1.3.gem) = 7680
diff --git a/devel/rubygem-rainbow/pkg-descr b/devel/rubygem-rainbow/pkg-descr
new file mode 100644
index 000000000000..1a957f52ca64
--- /dev/null
+++ b/devel/rubygem-rainbow/pkg-descr
@@ -0,0 +1,16 @@
+Rainbow extends ruby String class adding methods to wrap the string
+with ANSI escape codes.
+
+Rainbow adds following methods to String class:
+
+ * foreground(color) (with color and colour aliases)
+ * background(color)
+ * reset
+ * bright
+ * italic (not well supported by terminal emulators).
+ * underline
+ * blink
+ * inverse
+ * hide.
+
+WWW: https://github.com/sickill/rainbow