aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbms <bms@FreeBSD.org>2009-07-05 06:11:48 +0800
committerbms <bms@FreeBSD.org>2009-07-05 06:11:48 +0800
commiteb7724636811da6c9d54dbb0bfcb00f83f231dfd (patch)
tree4e9dfa3ed8416992e87e6af173cdc177b33e99c9 /devel
parent0e90a4e78df471279b81915d08be9dce704d0113 (diff)
downloadfreebsd-ports-gnome-eb7724636811da6c9d54dbb0bfcb00f83f231dfd.tar.gz
freebsd-ports-gnome-eb7724636811da6c9d54dbb0bfcb00f83f231dfd.tar.zst
freebsd-ports-gnome-eb7724636811da6c9d54dbb0bfcb00f83f231dfd.zip
Update to Apache Incubator snapshot as of 20090622.
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-thrift/Makefile10
-rw-r--r--devel/ruby-thrift/pkg-descr2
-rw-r--r--devel/ruby-thrift/pkg-plist40
-rw-r--r--devel/rubygem-thrift/Makefile10
-rw-r--r--devel/rubygem-thrift/pkg-descr2
-rw-r--r--devel/rubygem-thrift/pkg-plist40
6 files changed, 84 insertions, 20 deletions
diff --git a/devel/ruby-thrift/Makefile b/devel/ruby-thrift/Makefile
index b5423b4b3a02..cd1463e64420 100644
--- a/devel/ruby-thrift/Makefile
+++ b/devel/ruby-thrift/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= thrift
-PORTVERSION= 20070917
+PORTVERSION= 20090622
CATEGORIES= devel
PKGNAMEPREFIX= ruby-
DISTFILES=
@@ -14,13 +14,17 @@ DISTFILES=
MAINTAINER= skv@FreeBSD.org
COMMENT= Ruby interface to thrift
-BROKEN= needs updating for Apache Incubator version
-
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/thrift:extract
USE_RUBY= yes
USE_RUBY_SETUP= yes
+# XXX: Because this port will call ruby again to build binary extensions,
+# it is not suitable for building when PREFIX != LOCALBASE.
+# This seems to be a Ruby limitation, and the following does not help:
+#USE_RUBY_EXTCONF= yes
+#RUBY_EXTCONF_SUBDIRS= ext
+
post-extract:
@${LN} -sfh \
`cd ${PORTSDIR}/devel/thrift && ${MAKE} -V WRKSRC`/lib/rb ${WRKSRC}
diff --git a/devel/ruby-thrift/pkg-descr b/devel/ruby-thrift/pkg-descr
index 634be3a51ada..5bc0a5de8c4e 100644
--- a/devel/ruby-thrift/pkg-descr
+++ b/devel/ruby-thrift/pkg-descr
@@ -1,3 +1,3 @@
Ruby interface to Thrift.
-WWW: http://developers.facebook.com/thrift/
+WWW: http://incubator.apache.org/thrift/
diff --git a/devel/ruby-thrift/pkg-plist b/devel/ruby-thrift/pkg-plist
index 17eb6129084a..7e0643ac204f 100644
--- a/devel/ruby-thrift/pkg-plist
+++ b/devel/ruby-thrift/pkg-plist
@@ -1,10 +1,38 @@
-%%RUBY_SITELIBDIR%%/thrift/thrift.rb
-%%RUBY_SITELIBDIR%%/thrift/protocol/tbinaryprotocol.rb
-%%RUBY_SITELIBDIR%%/thrift/protocol/tprotocol.rb
-%%RUBY_SITELIBDIR%%/thrift/server/tserver.rb
-%%RUBY_SITELIBDIR%%/thrift/transport/tsocket.rb
-%%RUBY_SITELIBDIR%%/thrift/transport/ttransport.rb
+%%RUBY_SITEARCHLIBDIR%%/thrift_native.so
+%%RUBY_SITELIBDIR%%/thrift/client.rb
+%%RUBY_SITELIBDIR%%/thrift/exceptions.rb
+%%RUBY_SITELIBDIR%%/thrift/processor.rb
+%%RUBY_SITELIBDIR%%/thrift/struct.rb
+%%RUBY_SITELIBDIR%%/thrift/thrift_native.rb
+%%RUBY_SITELIBDIR%%/thrift/types.rb
+%%RUBY_SITELIBDIR%%/thrift/core_ext.rb
+%%RUBY_SITELIBDIR%%/thrift/core_ext/fixnum.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/base_protocol.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/binary_protocol.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/binary_protocol_accelerated.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/compact_protocol.rb
+%%RUBY_SITELIBDIR%%/thrift/serializer/deserializer.rb
+%%RUBY_SITELIBDIR%%/thrift/serializer/serializer.rb
+%%RUBY_SITELIBDIR%%/thrift/server/base_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/mongrel_http_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/nonblocking_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/simple_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/thread_pool_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/threaded_server.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/base_server_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/base_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/buffered_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/framed_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/http_client_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/io_stream_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/memory_buffer_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/server_socket.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/socket.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/unix_server_socket.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/unix_socket.rb
@dirrm %%RUBY_SITELIBDIR%%/thrift/transport
@dirrm %%RUBY_SITELIBDIR%%/thrift/server
+@dirrm %%RUBY_SITELIBDIR%%/thrift/serializer
@dirrm %%RUBY_SITELIBDIR%%/thrift/protocol
+@dirrm %%RUBY_SITELIBDIR%%/thrift/core_ext
@dirrm %%RUBY_SITELIBDIR%%/thrift
diff --git a/devel/rubygem-thrift/Makefile b/devel/rubygem-thrift/Makefile
index b5423b4b3a02..cd1463e64420 100644
--- a/devel/rubygem-thrift/Makefile
+++ b/devel/rubygem-thrift/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= thrift
-PORTVERSION= 20070917
+PORTVERSION= 20090622
CATEGORIES= devel
PKGNAMEPREFIX= ruby-
DISTFILES=
@@ -14,13 +14,17 @@ DISTFILES=
MAINTAINER= skv@FreeBSD.org
COMMENT= Ruby interface to thrift
-BROKEN= needs updating for Apache Incubator version
-
BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/thrift:extract
USE_RUBY= yes
USE_RUBY_SETUP= yes
+# XXX: Because this port will call ruby again to build binary extensions,
+# it is not suitable for building when PREFIX != LOCALBASE.
+# This seems to be a Ruby limitation, and the following does not help:
+#USE_RUBY_EXTCONF= yes
+#RUBY_EXTCONF_SUBDIRS= ext
+
post-extract:
@${LN} -sfh \
`cd ${PORTSDIR}/devel/thrift && ${MAKE} -V WRKSRC`/lib/rb ${WRKSRC}
diff --git a/devel/rubygem-thrift/pkg-descr b/devel/rubygem-thrift/pkg-descr
index 634be3a51ada..5bc0a5de8c4e 100644
--- a/devel/rubygem-thrift/pkg-descr
+++ b/devel/rubygem-thrift/pkg-descr
@@ -1,3 +1,3 @@
Ruby interface to Thrift.
-WWW: http://developers.facebook.com/thrift/
+WWW: http://incubator.apache.org/thrift/
diff --git a/devel/rubygem-thrift/pkg-plist b/devel/rubygem-thrift/pkg-plist
index 17eb6129084a..7e0643ac204f 100644
--- a/devel/rubygem-thrift/pkg-plist
+++ b/devel/rubygem-thrift/pkg-plist
@@ -1,10 +1,38 @@
-%%RUBY_SITELIBDIR%%/thrift/thrift.rb
-%%RUBY_SITELIBDIR%%/thrift/protocol/tbinaryprotocol.rb
-%%RUBY_SITELIBDIR%%/thrift/protocol/tprotocol.rb
-%%RUBY_SITELIBDIR%%/thrift/server/tserver.rb
-%%RUBY_SITELIBDIR%%/thrift/transport/tsocket.rb
-%%RUBY_SITELIBDIR%%/thrift/transport/ttransport.rb
+%%RUBY_SITEARCHLIBDIR%%/thrift_native.so
+%%RUBY_SITELIBDIR%%/thrift/client.rb
+%%RUBY_SITELIBDIR%%/thrift/exceptions.rb
+%%RUBY_SITELIBDIR%%/thrift/processor.rb
+%%RUBY_SITELIBDIR%%/thrift/struct.rb
+%%RUBY_SITELIBDIR%%/thrift/thrift_native.rb
+%%RUBY_SITELIBDIR%%/thrift/types.rb
+%%RUBY_SITELIBDIR%%/thrift/core_ext.rb
+%%RUBY_SITELIBDIR%%/thrift/core_ext/fixnum.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/base_protocol.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/binary_protocol.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/binary_protocol_accelerated.rb
+%%RUBY_SITELIBDIR%%/thrift/protocol/compact_protocol.rb
+%%RUBY_SITELIBDIR%%/thrift/serializer/deserializer.rb
+%%RUBY_SITELIBDIR%%/thrift/serializer/serializer.rb
+%%RUBY_SITELIBDIR%%/thrift/server/base_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/mongrel_http_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/nonblocking_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/simple_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/thread_pool_server.rb
+%%RUBY_SITELIBDIR%%/thrift/server/threaded_server.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/base_server_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/base_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/buffered_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/framed_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/http_client_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/io_stream_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/memory_buffer_transport.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/server_socket.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/socket.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/unix_server_socket.rb
+%%RUBY_SITELIBDIR%%/thrift/transport/unix_socket.rb
@dirrm %%RUBY_SITELIBDIR%%/thrift/transport
@dirrm %%RUBY_SITELIBDIR%%/thrift/server
+@dirrm %%RUBY_SITELIBDIR%%/thrift/serializer
@dirrm %%RUBY_SITELIBDIR%%/thrift/protocol
+@dirrm %%RUBY_SITELIBDIR%%/thrift/core_ext
@dirrm %%RUBY_SITELIBDIR%%/thrift