aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2014-05-08 22:44:50 +0800
committervanilla <vanilla@FreeBSD.org>2014-05-08 22:44:50 +0800
commitf3b953e64fcd54706849095c939ae7202d1fea98 (patch)
tree5eeadaba6333f6f7eae28d44da3d50e7ef99b129 /devel
parent49d3ee132b6d7efa99174b0e3e43132af5c8ae34 (diff)
downloadfreebsd-ports-gnome-f3b953e64fcd54706849095c939ae7202d1fea98.tar.gz
freebsd-ports-gnome-f3b953e64fcd54706849095c939ae7202d1fea98.tar.zst
freebsd-ports-gnome-f3b953e64fcd54706849095c939ae7202d1fea98.zip
Support STAGEDIR.
PR: ports/188501 Submitted by: Bartek Rutkowski <ports@robakdesign.com> Approved by: portmgr@
Diffstat (limited to 'devel')
-rw-r--r--devel/py-interface/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/devel/py-interface/Makefile b/devel/py-interface/Makefile
index e1f2aaf358be..afb765929581 100644
--- a/devel/py-interface/Makefile
+++ b/devel/py-interface/Makefile
@@ -9,7 +9,9 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= py_${PORTNAME}-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
-COMMENT= A Python implementation of an Erlang node
+COMMENT= Python implementation of an Erlang node
+
+LICENSE= GPLv2
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -17,16 +19,15 @@ PYDISTUTILS_PKGNAME= py_${PORTNAME}
DOCSDIR= ${PREFIX}/share/doc/py_${PORTNAME}
EXAMPLESDIR= ${PREFIX}/share/examples/py_${PORTNAME}
-NO_STAGE= yes
post-install:
@${TRUE}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} README ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} README ${STAGEDIR}${DOCSDIR}
.endif
.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/examples && ${INSTALL_DATA} * ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ cd ${WRKSRC}/examples && ${INSTALL_DATA} * ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>