aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2013-05-29 12:46:28 +0800
committerjgh <jgh@FreeBSD.org>2013-05-29 12:46:28 +0800
commitf99f20daefb4daa83f7f85652ce7b36642ce77aa (patch)
treec41990d4d5346247ec9d02aca23475ebb296dcf9 /devel
parent4a6750948b180ff1689bf6dd5276eee253688e9f (diff)
downloadfreebsd-ports-gnome-f99f20daefb4daa83f7f85652ce7b36642ce77aa.tar.gz
freebsd-ports-gnome-f99f20daefb4daa83f7f85652ce7b36642ce77aa.tar.zst
freebsd-ports-gnome-f99f20daefb4daa83f7f85652ce7b36642ce77aa.zip
- adoption of optionsNG
- add trace options to ncurses{-deve} - doc knob conversion in subversion{16} - trim headers/comments - eliminate some processing of bsd.port.pre.mk Approved by: portmgr (miwi)
Diffstat (limited to 'devel')
-rw-r--r--devel/asdlgen/Makefile38
-rw-r--r--devel/avr-libc/Makefile27
-rw-r--r--devel/gdb66/Makefile9
-rw-r--r--devel/hs-hat/Makefile58
-rw-r--r--devel/libparserutils/Makefile26
-rw-r--r--devel/msp430-libc/Makefile23
-rw-r--r--devel/ncurses-devel/Makefile18
-rw-r--r--devel/ncurses/Makefile24
-rw-r--r--devel/p5-Event-RPC/Makefile20
-rw-r--r--devel/py-Products.LDAPUserFolder/Makefile15
-rw-r--r--devel/py-dynrules/Makefile2
-rw-r--r--devel/subversion/Makefile2
-rw-r--r--devel/subversion16/Makefile2
13 files changed, 118 insertions, 146 deletions
diff --git a/devel/asdlgen/Makefile b/devel/asdlgen/Makefile
index cfa0ed3d751c..b755a5ff0964 100644
--- a/devel/asdlgen/Makefile
+++ b/devel/asdlgen/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: asdlgen
-# Date created: 5 October 2007
-# Whom: Johannes 5 Joemann <joemann@beefree.free.de>
-#
+# Created by: Johannes 5 Joemann <joemann@beefree.free.de>
# $FreeBSD$
-#
PORTNAME= asdlgen
PORTVERSION= 2.0.b20060323
@@ -16,22 +12,25 @@ MAINTAINER= joemann@beefree.free.de
COMMENT= Interoperable serializers for C,C++,Haskell,Icon,Java,ML
BUILD_DEPENDS= smlnj-devel>=110.65:${PORTSDIR}/lang/sml-nj-devel
-.if !defined(NOPORTDOCS)
-BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
-.endif
USE_DOS2UNIX= src/icon/libasdl.icn
-OPTIONS= CII "Install libcii for use by generated C and C++ code" on \
- EXAMPLES "Install the simple 'arithexp' usage example" off
+OPTIONS_DEFINE= CII EXAMPLES
+CII_DESC= libcii for use by generated C and C++ code
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= CII
-.if defined(WITH_CII)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCII}
RUN_DEPENDS+= libcii>=1.1:${PORTSDIR}/devel/libcii
.endif
-.if defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
DEMOVERSION= 20071030
DEMOARCHIVE= asdlgen-demo.${DEMOVERSION}.tar.gz
DEMODIR= arithexp
@@ -57,7 +56,7 @@ pre-patch:
post-build:
cd ${WRKSRC}/src/sml && heap2exec asdlGen.*-bsd asdlGen
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
.for format in ascii html ps
@${MKDIR} ${WRKSRC}/doc-build/README
cd ${WRKSRC}/doc-build/README && \
@@ -73,12 +72,13 @@ do-install:
@${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/src/asdl/tests && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
${INSTALL_DATA} -p ${WRKSRC}/src/asdl/std-types.asdl ${EXAMPLESDIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_MAN} -p ${WRKSRC}/COPYRIGHT ${DOCSDIR}
cd ${WRKSRC}/doc-build && ${COPYTREE_SHARE} \* ${DOCSDIR}
.endif
-.if defined(WITH_EXAMPLES)
+
+.if ${PORT_OPTIONS:MEXAMPLES}
cd ${WRKDIR}/${DEMODIR} && ${MAKE} clean
cd ${WRKDIR} && ${COPYTREE_SHARE} ${DEMODIR} ${EXAMPLESDIR}
.endif
@@ -98,7 +98,7 @@ BUILD_DEPENDS+= libcii>=1.1:${PORTSDIR}/devel/libcii \
# for all supported languages. The "Test" structure is defined in
# ${WRKSRC}/src/sml/test/harness.sml .
test-compile: depends clean-depends build
-.if defined(WITH_CII)
+.if ${PORT_OPTIONS:MCII}
cd ${WRKSRC}/src/sml && export SMLNJ_DEVEL=yes && \
${ECHO_CMD} "Test.do_it ();" | sml -m sources.cm
.else
@@ -110,7 +110,7 @@ test-compile: depends clean-depends build
.ifmake test-demo
test-demo: clean depends clean-depends build
-.if defined(WITH_CII) && defined(WITH_EXAMPLES)
+.if ${PORT_OPTIONS:MCII) && ${PORT_OPTIONS:MEXAMPLES}
cd ${WRKDIR}/${DEMODIR} && ${MAKE} ASDLGEN=${WRKSRC}/src/sml/asdlGen
.else
@${ECHO_CMD} "You have to set the CII and EXAMPLES options"
@@ -120,4 +120,4 @@ test-demo: clean depends clean-depends build
.endif
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/avr-libc/Makefile b/devel/avr-libc/Makefile
index dee83f179142..6a4f9b575ad7 100644
--- a/devel/avr-libc/Makefile
+++ b/devel/avr-libc/Makefile
@@ -1,19 +1,15 @@
-# New ports collection makefile for: avr-libc
-# Date created: 04 Dec 2000
-# Whom: Joerg Wunsch <joerg@freebsd.org>
-#
+# Created by: Joerg Wunsch <joerg@freebsd.org>
# $FreeBSD$
-#
PORTNAME= avr-libc
PORTVERSION= 1.8.0
PORTEPOCH= 1
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITES= SAVANNAH
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= joerg@FreeBSD.org
-COMMENT= A C and math library for the Atmel AVR controller family
+COMMENT= C and math library for the Atmel AVR controller family
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -25,18 +21,15 @@ RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
avr-ld:${PORTSDIR}/devel/avr-binutils \
avr-gcc:${PORTSDIR}/devel/avr-gcc
-.if !defined(NOPORTDOCS)
-OPTIONS= AVRLIBCDOCS "Build avr-libc documents" off
-.endif
+OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
-.if defined(WITHOUT_AVRLIBCDOCS) || defined(NOPORTDOCS)
-WITHOUT_AVRLIBCDOCS= true
-.undef WITH_AVRLIBCDOCS
+.if ! ${PORT_OPTIONS:MDOCS}
+.undef WITHOUT_AVRLIBCDOCS= true
.endif
-.if defined(WITH_AVRLIBCDOCS)
+.if ${PORT_OPTIONS:MDOCS}
USE_TEX= latex:build
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen \
fig2dev:${PORTSDIR}/print/transfig \
@@ -52,7 +45,7 @@ MAKE_JOBS_SAFE= yes
CONFLICTS= avr-libc-devel-[0-9]*
CONFIGURE_ENV= CC=avr-gcc PREFIX=${PREFIX}
-.if defined(WITH_AVRLIBCDOCS)
+.if ${PORT_OPTIONS:MDOCS}
CONFIGURE_ARGS= --build=`./config.guess` --host=avr \
--enable-doc --disable-versioned-doc --prefix=${PREFIX} \
--mandir=${PREFIX}/share/doc/avr-libc/man
@@ -69,13 +62,13 @@ CFLAGS= -O
CXXFLAGS= -O
post-patch:
-.if defined(WITHOUT_AVRLIBCDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
${REINPLACE_CMD} -e '/SUBDIRS/s,examples,,' ${WRKSRC}/doc/Makefile.in
.endif
do-install:
${RM} -f ${TMPPLIST}
-.if defined(WITH_AVRLIBCDOCS)
+.if ${PORT_OPTIONS:MDOCS}
(cd ${BUILD_WRKSRC}/doc/api/avr-libc-user-manual && \
${FIND} . -type f \
\( -name '*.html' -or -name '*.css' -or \
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 571200ecef04..83b8bc9ea712 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -15,9 +15,8 @@ COMMENT?= GNU GDB of newer version than comes with the system
LATEST_LINK?= gdb66
-.ifndef(WITH_INSIGHT)
-OPTIONS= INSIGHT "Build the Tcl/Tk GUI (experimental!)" off
-.endif
+OPTIONS_DEFINE= INSIGHT
+INSIGHT_DESC= Tcl/Tk GUI (experimental!)
CONFLICTS?= gdb-[7-9]*
MAKE_JOBS_SAFE= yes
@@ -40,7 +39,7 @@ MAN1= gdb${VER}.1
.include <bsd.port.options.mk>
-.if defined(WITH_INSIGHT)
+.if ${PORT_OPTIONS:MINSIGHT}
PKGNAMESUFFIX= -insight
USE_TK= 84+
LIB_DEPENDS= itk:${PORTSDIR}/x11-toolkits/itk
@@ -95,7 +94,7 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${PREFIX}/bin/gdb${VER}
${LN} ${PREFIX}/bin/gdb${VER} ${PREFIX}/bin/gdbtui${VER}
${INSTALL_MAN} ${WRKSRC}/gdb/gdb.1 ${MAN1PREFIX}/man/man1/gdb${VER}.1
-.if defined(WITH_INSIGHT)
+.if ${PORT_OPTIONS:MINSIGHT}
${LN} ${PREFIX}/bin/gdb${VER} ${PREFIX}/bin/insight
${MKDIR} ${PREFIX}/share/redhat/gui
${CP} -p ${WRKSRC}/libgui/library/*.tcl \
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index 4a010517130e..9fb6b822f024 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: hs-hat
-# Date created: February 4, 2009
-# Whom: Gabor Pali <pgj@FreeBSD.org>
-#
+# Created by: Gabor Pali <pgj@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= hat
PORTVERSION= 2.06
@@ -13,30 +9,26 @@ MASTER_SITES= ftp://ftp.cs.york.ac.uk/pub/haskell/${PORTNAME}/
PKGNAMEPREFIX= hs-
MAINTAINER= haskell@FreeBSD.org
-COMMENT= A source-level tracer for Haskell 98
+COMMENT= Source-level tracer for Haskell 98
USE_GMAKE= yes
HAS_CONFIGURE= yes
USE_GNOME= glib12
-OPTIONS= GHC "Build with GHC" off \
- NHC98 "Build with NHC98" on
+OPTIONS_SINGLE= SG1
+OPTIONS_SINGLE_SG1= GHC NHC98
+GHC_DESC= GHC support
+NHC98_DESC= NHC98 support
-.include <bsd.port.pre.mk>
+OPTIONS_DEFAULT= NHC98
-.if !defined(WITH_GHC) && !defined(WITH_NHC98)
-IGNORE= cannot be compiled without a compiler. Please (re)run 'make config' and choose either GHC or NHC98
-.endif
-
-.if defined(WITH_GHC) && defined(WITH_NHC98)
-IGNORE= can be compiled only with one of the compilers. Please (re)run 'make config' and choose either GHC or NHC98
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITH_NHC98) && ${ARCH} == "amd64"
+.if ${PORT_OPTIONS:MNHC98} && ${ARCH} == "amd64"
IGNORE= is not supported on AMD64 by NHC98.
.endif
-.if defined(WITH_GHC)
+.if ${PORT_OPTIONS:MGHC}
IGNORE= is only supported by NHC98. Please (re)run 'make config' and choose NHC98
.endif
@@ -50,37 +42,37 @@ IGNORE= is not supported on your architecture as there is no compiler for it
PLIST_SUB+= ARCH=${ARCHITECTURE}
-.if defined(WITH_NHC98)
+.if ${PORT_OPTIONS:MNHC98}
BUILD_DEPENDS+= nhc98:${PORTSDIR}/lang/nhc98
RUN_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
PKGNAMESUFFIX= -nhc98
.endif
-.if defined(WITH_GHC)
+.if ${PORT_OPTIONS:MGHC}
BUILD_DEPENDS+= hs-hmake>=3.0:${PORTSDIR}/devel/hs-hmake \
ghc:${PORTSDIR}/lang/ghc
RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
PKGNAMESUFFIX= -ghc
.endif
-.if defined(WITH_NHC98)
+.if ${PORT_OPTIONS:MNHC98}
ALL_TARGET= hat-nhc
ALL_TARGET+= hat-lib-nhc
.endif
-.if defined(WITH_GHC)
+.if ${PORT_OPTIONS:MGHC}
ALL_TARGET= hat-ghc
ALL_TARGET+= hat-lib-ghc
.endif
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-.if defined(WITH_NHC98)
+.if ${PORT_OPTIONS:MNHC98}
PLIST_SUB+= NHC98=""
PLIST_SUB+= GHC="@comment "
.endif
-.if defined(WITH_GHC)
+.if ${PORT_OPTIONS:MGHC}
GHC_VERSION= 6.10.4
PLIST_SUB+= NHC98="@comment "
PLIST_SUB+= GHC=""
@@ -90,11 +82,11 @@ PLIST_SUB+= GHC_VERSION=${GHC_VERSION}
CONFIGURE_ARGS= --prefix=${PREFIX} --libdir=${PREFIX}/lib
-.if defined(WITH_NHC98)
+.if ${PORT_OPTIONS:MNHC98}
CONFIGURE_ARGS+= --buildwith=nhc98
.endif
-.if defined(WITH_GHC)
+.if ${PORT_OPTIONS:MGHC}
CONFIGURE_ARGS+= --buildwith=ghc
.endif
@@ -108,28 +100,28 @@ MAN1= black-hat.1 hat-anim.1 hat-cover.1 hat-delta.1 hat-detect.1 hat-nonterm.1
pre-everything::
@${ECHO_CMD} ""
-.if defined(WITH_GHC)
+.if ${PORT_OPTIONS:MGHC}
@${ECHO_CMD} " HAT will be built and installed with ghc."
- @${ECHO_CMD} " Define WITH_NHC98 to install with nhc98."
+ @${ECHO_CMD} " Define NHC98 to install with nhc98."
.endif
-.if defined(WITH_NHC98)
+.if ${PORT_OPTIONS:MNHC98}
@${ECHO_CMD} " HAT will be built and installed with nhc98."
- @${ECHO_CMD} " Define WITH_GHC to install with ghc."
+ @${ECHO_CMD} " Define GHC to install with ghc."
.endif
@${ECHO_CMD} ""
post-patch:
-.if defined(WITH_NHC98)
+.if ${PORT_OPTIONS:MNHC98}
@${REINPLACE_CMD} -e "s/-package containers//" ${WRKSRC}/src/tools/Makefile
.endif
post-install:
-.if defined(WITH_GHC)
+.if ${PORT_OPTIONS:MGHC}
@${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
.endif
@${INSTALL_DATA} ${WRKSRC}/src/lib/hat.cabal \
${PREFIX}/lib/${ARCHITECTURE}-FreeBSD
@${RM} -rf ${PREFIX}/share/doc/hat/private
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libparserutils/Makefile b/devel/libparserutils/Makefile
index 2e3fccc55980..d203739167c5 100644
--- a/devel/libparserutils/Makefile
+++ b/devel/libparserutils/Makefile
@@ -1,9 +1,5 @@
-# ports collection makefile for: libparserutils
-# Date created: 20 August 2011
-# Whom: David Romano <unobe@cpan.org>
-#
+# Created by: David Romano <unobe@cpan.org>
# $FreeBSD$
-#
PORTNAME= libparserutils
PORTVERSION= 0.1.1
@@ -13,7 +9,7 @@ MASTER_SITES= http://www.netsurf-browser.org/projects/releases/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= unobe@cpan.org
-COMMENT= A library useful when writing parsers (formerly a part of NetSurf)
+COMMENT= Library useful when writing parsers (formerly a part of NetSurf)
USE_GMAKE= yes
@@ -22,34 +18,32 @@ LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-OPTIONS= ICONV "Adds iconv support" On \
- STATIC "Build statically linked library" On \
- TEST "Enable tests" On \
- DOXYGEN "Build Doxygen Documentation" On
+OPTIONS_DEFINE= ICONV STATIC TEST DOXYGEN
+OPTIONS_DEFAULT= ICONV STATIC TEST DOXYGEN
.include <bsd.port.options.mk>
-.if defined(WITH_ICONV)
+.if ${PORT_OPTIONS:MICONV}
CFLAGS+= -DWITH_ICONV_FILTER
LDFLAGS+= -liconv
.endif
-.if !defined(WITH_STATIC)
+.if ${PORT_OPTIONS:MSTATIC}
+PLIST_SUB+= NO_STATIC="@comment " STATIC=""
+.else
USE_PERL5_BUILD=yes
USE_LDCONFIG= yes
COMPONENT_TYPE= lib-shared
MAKE_ENV+= COMPONENT_TYPE=${COMPONENT_TYPE}
PLIST_SUB+= NO_STATIC="" STATIC="@comment "
-.else
-PLIST_SUB+= NO_STATIC="@comment " STATIC=""
.endif
-.if defined(WITH_TEST)
+.if ${PORT_OPTIONS:MTEST}
USE_PERL5_BUILD=yes
ALL_TARGET+= test
.endif
-.if defined(WITH_DOXYGEN)
+.if ${PORT_OPTIONS:MDOXYGEN}
DOXYGEN_PORTDIR=${PORTSDIR}/devel/doxygen
BUILD_DEPENDS+= doxygen:${DOXYGEN_PORTDIR}:build
PATH:=${PATH}:`cd ${DOXYGEN_PORTDIR}; make -V WRKSRC`/bin
diff --git a/devel/msp430-libc/Makefile b/devel/msp430-libc/Makefile
index 2d6e1f7b1ff9..e070fdf6c438 100644
--- a/devel/msp430-libc/Makefile
+++ b/devel/msp430-libc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: msp430-libc
-# Date created: 15 October 2002
-# Whom: Lev Serebryakov <lev@serebryakov.spb.ru>
-#
+# Created by: Lev Serebryakov <lev@serebryakov.spb.ru>
# $FreeBSD$
-#
PORTNAME= libc
PORTVERSION= 1.0.${LIBCVERSION}
@@ -29,8 +25,12 @@ RUN_DEPENDS= ${LOCALBASE}/${LIBCTARGET}/include/${LIBCTARGET}.h:${PORTSDIR}/deve
CONFLICTS= ${PKGNAMEPREFIX}${PORTNAME}-gcc${OTHERGCCVERSION}-[0-9]*
-OPTIONS= GCC4 "Use new msp430-gcc4 compiler" on \
- GCC3 "Use old msp430-gcc3 compiler" off
+OPTIONS_SINGLE= SG1
+OPTIONS_SINGLE_SG1= GCC4 GCC3
+GCC4_DESC= Use new msp430-gcc4 compiler
+GCC3_DESC= Use old msp430-gcc3 compiler
+
+OPTIONS_DEFAULT= GCC4
LIBCTARGET= msp430
LIBCVERSION= 20120224
@@ -46,22 +46,17 @@ PATCH_WRKSRC= ${WRKDIR}/${PKGNAMEPREFIX}libc-${LIBCVERSION}
.include <bsd.port.options.mk>
-.if defined(WITH_GCC4)
-.if defined(WITH_GCC3)
-BROKEN= Please, select msp430-gcc-4 or msp430-gcc-3, not both
-.endif
+.if ${PORT_OPTIONS:MGCC4}
BUILD_DEPENDS+= ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc
PLIST_SUB+= GCC3="@comment " GCC4=""
NEEDGCCVERSION= 4
PORTGCCVERSION=
OTHEGCCVERSION= 3
-.elif defined(WITH_GCC3)
+.elif ${PORT_OPTIONS:MGCC3}
PLIST_SUB+= GCC3="" GCC4="@comment "
NEEDGCCVERSION= 3
PORTGCCVERSION= ${NEEDGCCVERSION}
OTHEGCCVERSION= 4
-.else
-BROKEN= Please, select msp430-gcc-4 either msp430-gcc-3
.endif
pre-configure:
diff --git a/devel/ncurses-devel/Makefile b/devel/ncurses-devel/Makefile
index a5fb96d37f52..297fe6deb25f 100644
--- a/devel/ncurses-devel/Makefile
+++ b/devel/ncurses-devel/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ncurses-devel
-# Date created: Jan 28 2006
-# Whom: Rong-En Fan <rafan@FreeBSD.org>
-#
+# Created by: Rong-En Fan <rafan@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= ncurses
PORTVERSION= ${RELEASE}.${PATCHDATE}
@@ -46,7 +42,9 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share/misc --disable-overwrite \
--with-manpage-format=gzip --srcdir=../
MAKE_JOBS_UNSAFE= yes
-OPTIONS= EXTCOLORS "Enable 256-color support (only for ncursesw)" off
+OPTIONS_DEFINE= EXTCOLORS TRACE
+EXTCOLORS_DESC= 256-color support (only for ncursesw)
+TRACE_DESC= Add trace() function to all models of ncurses
CONFIGURE_ENV= gnat_exists="no"
@@ -98,14 +96,14 @@ EXAMPLES_CPP= Makefile NEWS PROBLEMS README-first cursesapp.cc \
.include "${.CURDIR}/Makefile.man"
CONFIGURE_ARGS_WIDEC=--enable-widec
-.if defined(WITH_EXTCOLORS)
+.if ${PORT_OPTIONS:MEXTCOLORS}
CONFIGURE_ARGS_WIDEC+=--enable-ext-colors
NCURSESW_ABI_VER= 6
NCURSESW_REL_VER= 6.0
.endif
# needed by devel/py-ncurses port
-.if defined(WITH_TRACE)
+.if ${PORT_OPTIONS:MTRACE}
CONFIGURE_ARGS+= --with-trace
.endif
@@ -173,7 +171,7 @@ post-install:
${MAKE} ${.MAKEFLAGS} INSTALL_WRKSRC=${WIDEC_WRKSRC} do-install
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
. for i in ${EXAMPLES_TARGETS}
${MKDIR} ${${i}_EXAMPLESDIR}/c++
. for f in ${EXAMPLES}
@@ -190,7 +188,7 @@ post-install:
${FIND} ${PREFIX}/share/misc -name "*.terminfo" -exec ${PREFIX}/bin/tic {} \;
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
diff --git a/devel/ncurses/Makefile b/devel/ncurses/Makefile
index 99dfda554f05..c1552e2df9b9 100644
--- a/devel/ncurses/Makefile
+++ b/devel/ncurses/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ncurses
-# Date created: 23 September 1997
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
-#
PORTNAME= ncurses
PORTVERSION= ${RELEASE}
@@ -33,7 +29,9 @@ CONFIGURE_ARGS= --datadir=${PREFIX}/share/misc --disable-overwrite \
--with-manpage-format=gzip --srcdir=../
MAKE_JOBS_UNSAFE= yes
-OPTIONS= EXTCOLORS "Enable 256-color support (only for ncursesw)" off
+OPTIONS_DEFINE= EXTCOLORS TRACE DEBUG
+EXTCOLORS_DESC= 256-color support (only for ncursesw)
+TRACE_DESC= Add trace() function to all models of ncurses
CONFIGURE_ENV= gnat_exists="no"
@@ -80,19 +78,19 @@ EXAMPLES_CPP= Makefile NEWS PROBLEMS README-first cursesapp.cc \
cursesw.h cursslk.cc cursslk.h demo.cc etip.h \
internal.h
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.include "${.CURDIR}/Makefile.man"
CONFIGURE_ARGS_WIDEC=--enable-widec
-.if defined(WITH_EXTCOLORS)
+.if ${PORT_OPTIONS:MEXTCOLORS}
CONFIGURE_ARGS_WIDEC+=--enable-ext-colors
NCURSESW_ABI_VER= 6
NCURSESW_REL_VER= 6.0
.endif
# needed by devel/py-ncurses port
-.if defined(WITH_TRACE)
+.if ${PORT_OPTIONS:MTRACE}
CONFIGURE_ARGS+= --with-trace
.endif
@@ -104,7 +102,7 @@ CONFIGURE_ARGS+=--without-profile
PLIST_SUB+= PROFILE="@comment "
.endif
-.if !defined(WITH_DEBUG)
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+=--without-debug
PLIST_SUB+= DEBUG="@comment "
.else
@@ -160,7 +158,7 @@ post-install:
${MAKE} ${.MAKEFLAGS} INSTALL_WRKSRC=${WIDEC_WRKSRC} do-install
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
. for i in ${EXAMPLES_TARGETS}
${MKDIR} ${${i}_EXAMPLESDIR}/c++
. for f in ${EXAMPLES}
@@ -177,11 +175,11 @@ post-install:
${FIND} ${PREFIX}/share/misc -name "*.terminfo" -exec ${PREFIX}/bin/tic {} \;
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
. for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
. endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Event-RPC/Makefile b/devel/p5-Event-RPC/Makefile
index 6636f58c4c3b..be36003c4781 100644
--- a/devel/p5-Event-RPC/Makefile
+++ b/devel/p5-Event-RPC/Makefile
@@ -27,28 +27,32 @@ MAN3= Event::RPC.3 \
Event::RPC::Message.3 \
Event::RPC::Server.3
-OPTIONS= GLIB "Register dependency to Glib event handler" off \
- EVENT "Register dependency to Event.pm event handler" on \
- ANYEVENT "Register dependency to AnyEvent event handler" on \
- SSL "Register dependency to SSL lib" on
+OPTIONS_DEFINE= GLIB EVENT ANYEVENT SSL
+GLIB_DESC= Dependency to Glib event handler
+EVENT_DESC= Dependency to Event.pm event handler
+ANYEVENT_DESC= Dependency to AnyEvent event handler
+SSL_DESC= Dependency to SSL lib
+OPTIONS_DEFAULT= EVENT ANYEVENT SSL
+
+.include <bsd.port.options.mk>
.include <bsd.port.pre.mk>
BUILD_DEPENDS= p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
-.if !defined(WITHOUT_EVENT)
+.if ${PORT_OPTIONS:MEVENT}
BUILD_DEPENDS+= p5-Event>=0:${PORTSDIR}/devel/p5-Event
.endif
-.if defined(WITH_ANYEVENT)
+.if ${PORT_OPTIONS:MANYEVENT}
BUILD_DEPENDS+= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent
.endif
-.if defined(WITH_GLIB)
+.if ${PORT_OPTIONS:MGLIB}
BUILD_DEPENDS+= p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2
.endif
-.if !defined(WITHOUT_SSL)
+.if ${PORT_OPTIONS:MSSL}
# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
BUILD_DEPENDS+= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
diff --git a/devel/py-Products.LDAPUserFolder/Makefile b/devel/py-Products.LDAPUserFolder/Makefile
index 13f2c4a169cd..010c4c4062ce 100644
--- a/devel/py-Products.LDAPUserFolder/Makefile
+++ b/devel/py-Products.LDAPUserFolder/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: py-Products.LDAPUserFolder
-# Date created: 20 May 2012
-# Whom: Lawrence Stewart <lstewart@freebsd.org>
-#
+# Created by: Lawrence Stewart <lstewart@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Products.LDAPUserFolder
PORTVERSION= 2.23
@@ -13,14 +9,17 @@ MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= zope@FreeBSD.org
-COMMENT= A LDAP-enabled Zope 2 user folder
+COMMENT= LDAP-enabled Zope 2 user folder
LICENSE= ZPL21
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools-git>=0.4.2:${PORTSDIR}/devel/py-setuptools-git
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ldap2>=2.0.6:${PORTSDIR}/net/py-ldap2
-OPTIONS= POSIXGROUP_PATCH "Use posixGroup for group membership" On
+OPTIONS_DEFINE= POSIXGROUP_PATCH
+POSIXGROUP_PATCH_DESC= Use posixGroup for group membership
+
+OPTIONS_DEFAULT= POSIXGROUP_PATCH
DIST_SUBDIR= zope
USE_PYTHON= -2.7
@@ -29,7 +28,7 @@ USE_PYDISTUTILS= easy_install
.include <bsd.port.options.mk>
-.if defined(WITH_POSIXGROUP_PATCH)
+.if ${PORT_OPTIONS:MPOSIXGROUP_PATCH}
EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-posixgroup
.endif
diff --git a/devel/py-dynrules/Makefile b/devel/py-dynrules/Makefile
index 66c9d73beb41..fe9696a2dc3f 100644
--- a/devel/py-dynrules/Makefile
+++ b/devel/py-dynrules/Makefile
@@ -11,7 +11,7 @@ COMMENT= Dynamic Scripting for adaptive AI systems
USE_PYTHON= yes
USE_PYDISTUTILS=yes
-OPTIONS= DOCS
+OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index d815494b79e8..2df935d3f3f0 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -94,7 +94,7 @@ PLIST_SUB+= SVNMUCC=""
PLIST_SUB+= SVNMUCC="@comment "
.endif
-.if !defined(NOPORTDOCS) && ${PORT_OPTIONS:MBOOK}
+.if ${PORT_OPTIONS:MDOCS} && ${PORT_OPTIONS:MBOOK}
BOOK_HTML= svn-book-html-r${BOOK_VERSION}.tar.bz2
BOOK_PDF= svn-book-r${BOOK_VERSION}.pdf
DISTFILES+= ${BOOK_HTML}:book ${BOOK_PDF}:book
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index 1a434b4a3c52..bc1ee97ef0e1 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -236,7 +236,7 @@ post-install: ${MKREPOS_TARGET}
cd ${WRKSRC}/tools ; \
${TAR} --exclude '*.in' -cf - * | ${TAR} -C ${DATADIR} -xf -
@${CHMOD} -R a-st,o+rX ${DATADIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
for f in ${TXT_DOCS}; do \
${INSTALL_MAN} ${WRKSRC}/$$f ${DOCSDIR}; \