aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-07-11 15:55:31 +0800
committerjylefort <jylefort@FreeBSD.org>2005-07-11 15:55:31 +0800
commitfa7787ef71ced5e7f511e5c5bb7d826f5c40c2bc (patch)
tree763b6b8f43cf3663d35d5b6bb4c849e091f30871 /devel
parent8caac2220197ad07631bd135300788ca32ed1ffb (diff)
downloadfreebsd-ports-gnome-fa7787ef71ced5e7f511e5c5bb7d826f5c40c2bc.tar.gz
freebsd-ports-gnome-fa7787ef71ced5e7f511e5c5bb7d826f5c40c2bc.tar.zst
freebsd-ports-gnome-fa7787ef71ced5e7f511e5c5bb7d826f5c40c2bc.zip
Add p5-Sort-Array.
This extended sorting algorithm allows you to a) sort an array by ANY field number, not only the first b) find duplicates in your data-set and sort them out. WWW: http://search.cpan.org/dist/Sort-Array/ PR: ports/82968 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sort-Array/Makefile22
-rw-r--r--devel/p5-Sort-Array/distinfo2
-rw-r--r--devel/p5-Sort-Array/pkg-descr9
-rw-r--r--devel/p5-Sort-Array/pkg-plist5
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6478b8ea6547..16beefc3c359 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1070,6 +1070,7 @@
SUBDIR += p5-Shell-Base
SUBDIR += p5-Shell-Parser
SUBDIR += p5-Smart-Comments
+ SUBDIR += p5-Sort-Array
SUBDIR += p5-Sort-ArrayOfArrays
SUBDIR += p5-Sort-Tree
SUBDIR += p5-Sort-Versions
diff --git a/devel/p5-Sort-Array/Makefile b/devel/p5-Sort-Array/Makefile
new file mode 100644
index 000000000000..e7a887930051
--- /dev/null
+++ b/devel/p5-Sort-Array/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Sort-Array
+# Date created: 4 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sort-Array
+DISTVERSION= 0.26
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sort
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A powerful array sorting Perl interface
+
+PERL_CONFIGURE= yes
+
+MAN3= Sort::Array.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Sort-Array/distinfo b/devel/p5-Sort-Array/distinfo
new file mode 100644
index 000000000000..ed9f08c921da
--- /dev/null
+++ b/devel/p5-Sort-Array/distinfo
@@ -0,0 +1,2 @@
+MD5 (Sort-Array-0.26.tar.gz) = 9743023430bc3f5ccd8afc7ebd72d91a
+SIZE (Sort-Array-0.26.tar.gz) = 5191
diff --git a/devel/p5-Sort-Array/pkg-descr b/devel/p5-Sort-Array/pkg-descr
new file mode 100644
index 000000000000..d97879819da3
--- /dev/null
+++ b/devel/p5-Sort-Array/pkg-descr
@@ -0,0 +1,9 @@
+This extended sorting algorithm allows you to
+
+ a) sort an array by ANY field number, not only the first
+ b) find duplicates in your data-set and sort them out.
+
+WWW: http://search.cpan.org/dist/Sort-Array/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/devel/p5-Sort-Array/pkg-plist b/devel/p5-Sort-Array/pkg-plist
new file mode 100644
index 000000000000..12878f3307aa
--- /dev/null
+++ b/devel/p5-Sort-Array/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Sort/Array.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Array/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort/Array
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sort 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Sort 2>/dev/null || true