aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-08-15 23:36:19 +0800
committertcberner <tcberner@FreeBSD.org>2016-08-15 23:36:19 +0800
commitfcca967cd7da755e20bf46668dd45fe4cc6acfa3 (patch)
tree846e4a8aef1ef6a96234bbd3dee3b2437dae21be /devel
parent477a7c64d48c979a63e2b8ae84f2000248dfb22f (diff)
downloadfreebsd-ports-gnome-fcca967cd7da755e20bf46668dd45fe4cc6acfa3.tar.gz
freebsd-ports-gnome-fcca967cd7da755e20bf46668dd45fe4cc6acfa3.tar.zst
freebsd-ports-gnome-fcca967cd7da755e20bf46668dd45fe4cc6acfa3.zip
New port: devel/grantlee5 and Uses/grantlee.mk
The upcoming KDE Frameworks ports need grantlee5 * Add devel/grantlee5 and move installed headers into a subdirectory include/grantlee5 * Move header files from devel/grantlee into a subdirectory include/grantlee4 to make sure ports do not pick up the wrong headers * Add Uses/grantlee.mk to handle the PLIST_SUB and LIB_DEEPENDS needed by ports using grantlee (before we set the PLIST_SUB manual in very of the depending ports, which now should not be needed anymore). * The ports depending on devel/grantlee have been modified from LIB_DEPENDS=libgrantlee_gui.so:devel/grantlee to USES=grantlee:4 as this does not affect the package no version bumped was made. Reviewed by: mat, rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D7434
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/grantlee/Makefile16
-rw-r--r--devel/grantlee/distinfo1
-rw-r--r--devel/grantlee/files/patch-CMakeLists.txt14
-rw-r--r--devel/grantlee/files/patch-templates_lib_CMakeLists.txt14
-rw-r--r--devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt14
-rw-r--r--devel/grantlee/pkg-plist80
-rw-r--r--devel/grantlee5/Makefile20
-rw-r--r--devel/grantlee5/distinfo3
-rw-r--r--devel/grantlee5/files/patch-CMakeLists.txt14
-rw-r--r--devel/grantlee5/files/patch-templates_lib_CMakeLists.txt14
-rw-r--r--devel/grantlee5/files/patch-textdocument_lib_CMakeLists.txt14
-rw-r--r--devel/grantlee5/pkg-descr4
-rw-r--r--devel/grantlee5/pkg-plist47
-rw-r--r--devel/kdevplatform/Makefile8
-rw-r--r--devel/kdevplatform/pkg-plist2
16 files changed, 207 insertions, 59 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e788f61ef002..59029e9ad670 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -767,6 +767,7 @@
SUBDIR += gputils
SUBDIR += gradle
SUBDIR += grantlee
+ SUBDIR += grantlee5
SUBDIR += gsettings-desktop-schemas
SUBDIR += gsoap
SUBDIR += gstreamer-plugins-gconf
diff --git a/devel/grantlee/Makefile b/devel/grantlee/Makefile
index 4dae451a7391..c4199058f525 100644
--- a/devel/grantlee/Makefile
+++ b/devel/grantlee/Makefile
@@ -1,16 +1,9 @@
# Created by: Dima Panov <fluffy@FreeBSD.org>
# $FreeBSD$
-# Some ports install files into versioned grantlee directory (GRANTLEE_VER)
-# they must be fixed whenever grantlee gets version bump
-# Known ports:
-# deskutils/kdepim4
-# devel/kdevplatform
-# finance/skrooge
-#
-
PORTNAME= grantlee
-DISTVERSION= 0.5.1
+DISTVERSION= ${GRANTLEE_VERSION}
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://downloads.${PORTNAME}.org/ \
http://www.loegria.net/${PORTNAME}/
@@ -22,11 +15,8 @@ LICENSE= LGPL21
USE_QT4= corelib gui qtestlib_build script \
qmake_build moc_build rcc_build uic_build
-USES= cmake:outsource
+USES= cmake:outsource grantlee:4,selfbuild
CMAKE_ARGS+= -DBUILD_TESTS:BOOL=FALSE
USE_LDCONFIG= yes
-PLIST_SUB= SHLIB_VER=${PORTVERSION} \
- GRANTLEE_VER=${PORTVERSION:R}
-
.include <bsd.port.mk>
diff --git a/devel/grantlee/distinfo b/devel/grantlee/distinfo
index f406f1511c25..7256e098384e 100644
--- a/devel/grantlee/distinfo
+++ b/devel/grantlee/distinfo
@@ -1,2 +1,3 @@
+TIMESTAMP = 1471275288
SHA256 (grantlee-0.5.1.tar.gz) = 191809bf4c9b7ef877af0fd29345061c2372edfb4506aa7d5df5c71a570fa0ac
SIZE (grantlee-0.5.1.tar.gz) = 1172769
diff --git a/devel/grantlee/files/patch-CMakeLists.txt b/devel/grantlee/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..2e8adb558485
--- /dev/null
+++ b/devel/grantlee/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+Install headers prefixed, as to not cause a possible conflict with
+different versions.
+
+--- CMakeLists.txt.orig 2016-08-10 16:05:25 UTC
++++ CMakeLists.txt
+@@ -96,7 +96,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define
+ set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
+ set( PLUGIN_INSTALL_DIR lib${LIB_SUFFIX}/grantlee/${Grantlee_MAJOR_MINOR_VERSION_STRING} )
+ set( BIN_INSTALL_DIR bin )
+-set( INCLUDE_INSTALL_DIR include )
++set( INCLUDE_INSTALL_DIR include/grantlee4 )
+ set( DATA_INSTALL_DIR share/apps )
+
+ # set up RPATH/install_name_dir
diff --git a/devel/grantlee/files/patch-templates_lib_CMakeLists.txt b/devel/grantlee/files/patch-templates_lib_CMakeLists.txt
new file mode 100644
index 000000000000..8a75d97f7d32
--- /dev/null
+++ b/devel/grantlee/files/patch-templates_lib_CMakeLists.txt
@@ -0,0 +1,14 @@
+Install headers prefixed, as to not cause a possible conflict with
+different versions.
+
+--- templates/lib/CMakeLists.txt.orig 2016-08-10 16:06:08 UTC
++++ templates/lib/CMakeLists.txt
+@@ -119,7 +119,7 @@ install(TARGETS grantlee_core EXPORT gra
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR} COMPONENT Templates
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR} COMPONENT Templates
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR} COMPONENT Templates
+- INCLUDES DESTINATION include
++ INCLUDES DESTINATION include/grantlee4
+ )
+
+ install(FILES
diff --git a/devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt b/devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt
new file mode 100644
index 000000000000..281965e48c09
--- /dev/null
+++ b/devel/grantlee/files/patch-textdocument_lib_CMakeLists.txt
@@ -0,0 +1,14 @@
+Install headers prefixed, as to not cause a possible conflict with
+different versions.
+
+--- textdocument/lib/CMakeLists.txt.orig 2016-08-10 16:06:47 UTC
++++ textdocument/lib/CMakeLists.txt
+@@ -44,7 +44,7 @@ install(TARGETS grantlee_gui EXPORT gran
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR} COMPONENT TextDocument
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR} COMPONENT TextDocument
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR} COMPONENT TextDocument
+- INCLUDES DESTINATION include
++ INCLUDES DESTINATION include/grantlee4
+ )
+
+ install(FILES
diff --git a/devel/grantlee/pkg-plist b/devel/grantlee/pkg-plist
index 8713f40b8c5f..5bc54019344c 100644
--- a/devel/grantlee/pkg-plist
+++ b/devel/grantlee/pkg-plist
@@ -1,49 +1,49 @@
-include/grantlee/abstractlocalizer.h
-include/grantlee/abstractmarkupbuilder.h
-include/grantlee/bbcodebuilder.h
-include/grantlee/cachingloaderdecorator.h
-include/grantlee/containeraccessor.h
-include/grantlee/context.h
-include/grantlee/engine.h
-include/grantlee/exception.h
-include/grantlee/filter.h
-include/grantlee/filterexpression.h
-include/grantlee/grantlee_core_export.h
-include/grantlee/grantlee_gui_export.h
-include/grantlee/grantlee_version.h
-include/grantlee/markupdirector.h
-include/grantlee/mediawikimarkupbuilder.h
-include/grantlee/metatype.h
-include/grantlee/node.h
-include/grantlee/outputstream.h
-include/grantlee/parser.h
-include/grantlee/plaintextmarkupbuilder.h
-include/grantlee/qtlocalizer.h
-include/grantlee/rendercontext.h
-include/grantlee/safestring.h
-include/grantlee/taglibraryinterface.h
-include/grantlee/template.h
-include/grantlee/templateloader.h
-include/grantlee/texthtmlbuilder.h
-include/grantlee/token.h
-include/grantlee/typeaccessor.h
-include/grantlee/util.h
-include/grantlee/variable.h
-include/grantlee_core.h
-include/grantlee_templates.h
-include/grantlee_textdocument.h
+include/grantlee4/grantlee/abstractlocalizer.h
+include/grantlee4/grantlee/abstractmarkupbuilder.h
+include/grantlee4/grantlee/bbcodebuilder.h
+include/grantlee4/grantlee/cachingloaderdecorator.h
+include/grantlee4/grantlee/containeraccessor.h
+include/grantlee4/grantlee/context.h
+include/grantlee4/grantlee/engine.h
+include/grantlee4/grantlee/exception.h
+include/grantlee4/grantlee/filter.h
+include/grantlee4/grantlee/filterexpression.h
+include/grantlee4/grantlee/grantlee_core_export.h
+include/grantlee4/grantlee/grantlee_gui_export.h
+include/grantlee4/grantlee/grantlee_version.h
+include/grantlee4/grantlee/markupdirector.h
+include/grantlee4/grantlee/mediawikimarkupbuilder.h
+include/grantlee4/grantlee/metatype.h
+include/grantlee4/grantlee/node.h
+include/grantlee4/grantlee/outputstream.h
+include/grantlee4/grantlee/parser.h
+include/grantlee4/grantlee/plaintextmarkupbuilder.h
+include/grantlee4/grantlee/qtlocalizer.h
+include/grantlee4/grantlee/rendercontext.h
+include/grantlee4/grantlee/safestring.h
+include/grantlee4/grantlee/taglibraryinterface.h
+include/grantlee4/grantlee/template.h
+include/grantlee4/grantlee/templateloader.h
+include/grantlee4/grantlee/texthtmlbuilder.h
+include/grantlee4/grantlee/token.h
+include/grantlee4/grantlee/typeaccessor.h
+include/grantlee4/grantlee/util.h
+include/grantlee4/grantlee/variable.h
+include/grantlee4/grantlee_core.h
+include/grantlee4/grantlee_templates.h
+include/grantlee4/grantlee_textdocument.h
lib/cmake/grantlee/GrantleeConfig.cmake
lib/cmake/grantlee/GrantleeConfigVersion.cmake
lib/cmake/grantlee/GrantleeTargets-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/grantlee/GrantleeTargets.cmake
lib/cmake/grantlee/GrantleeUse.cmake
-lib/grantlee/%%GRANTLEE_VER%%/grantlee_defaultfilters.so
-lib/grantlee/%%GRANTLEE_VER%%/grantlee_defaulttags.so
-lib/grantlee/%%GRANTLEE_VER%%/grantlee_i18ntags.so
-lib/grantlee/%%GRANTLEE_VER%%/grantlee_loadertags.so
+lib/grantlee/%%GRANTLEE_VERSION_SHORT%%/grantlee_defaultfilters.so
+lib/grantlee/%%GRANTLEE_VERSION_SHORT%%/grantlee_defaulttags.so
+lib/grantlee/%%GRANTLEE_VERSION_SHORT%%/grantlee_i18ntags.so
+lib/grantlee/%%GRANTLEE_VERSION_SHORT%%/grantlee_loadertags.so
lib/libgrantlee_core.so
lib/libgrantlee_core.so.0
-lib/libgrantlee_core.so.%%SHLIB_VER%%
+lib/libgrantlee_core.so.%%GRANTLEE_VERSION_FULL%%
lib/libgrantlee_gui.so
lib/libgrantlee_gui.so.0
-lib/libgrantlee_gui.so.%%SHLIB_VER%%
+lib/libgrantlee_gui.so.%%GRANTLEE_VERSION_FULL%%
diff --git a/devel/grantlee5/Makefile b/devel/grantlee5/Makefile
new file mode 100644
index 000000000000..6cdd56134ca1
--- /dev/null
+++ b/devel/grantlee5/Makefile
@@ -0,0 +1,20 @@
+# Created by: Tobias C. Berner <tcberner@gmail.com>
+# $FreeBSD$
+
+PORTNAME= grantlee
+PORTVERSION= ${GRANTLEE_VERSION}
+CATEGORIES= devel
+MASTER_SITES= http://downloads.${PORTNAME}.org/
+PKGNAMESUFFIX= 5
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= String template engine for Qt 5
+
+LICENSE= LGPL21
+
+USE_QT5= buildtools_build core gui qmake_build script
+USES= cmake:outsource compiler:c++11-lib grantlee:5,selfbuild
+CMAKE_ARGS+= -DBUILD_TESTS:BOOL=FALSE
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/grantlee5/distinfo b/devel/grantlee5/distinfo
new file mode 100644
index 000000000000..e0e3d3c28c6a
--- /dev/null
+++ b/devel/grantlee5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1471275306
+SHA256 (grantlee-5.1.0.tar.gz) = ea2e402466c74bb533eee2c7252209ec61cd93a5d236fecd625b4a0eb13a1478
+SIZE (grantlee-5.1.0.tar.gz) = 1175380
diff --git a/devel/grantlee5/files/patch-CMakeLists.txt b/devel/grantlee5/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..30572ec98532
--- /dev/null
+++ b/devel/grantlee5/files/patch-CMakeLists.txt
@@ -0,0 +1,14 @@
+Install headers prefixed, as to not cause a possible conflict with
+different versions.
+
+--- CMakeLists.txt.orig 2016-08-10 16:09:20 UTC
++++ CMakeLists.txt
+@@ -100,7 +100,7 @@ set (LIB_SUFFIX "" CACHE STRING "Define
+ set( LIB_INSTALL_DIR lib${LIB_SUFFIX} )
+ set( PLUGIN_INSTALL_DIR ${LIB_INSTALL_DIR}/grantlee/${Grantlee5_MAJOR_MINOR_VERSION_STRING} )
+ set( BIN_INSTALL_DIR bin )
+-set( INCLUDE_INSTALL_DIR include )
++set( INCLUDE_INSTALL_DIR include/grantlee5 )
+ set( DATA_INSTALL_DIR share/apps )
+
+ # set up RPATH/install_name_dir
diff --git a/devel/grantlee5/files/patch-templates_lib_CMakeLists.txt b/devel/grantlee5/files/patch-templates_lib_CMakeLists.txt
new file mode 100644
index 000000000000..dd067584192f
--- /dev/null
+++ b/devel/grantlee5/files/patch-templates_lib_CMakeLists.txt
@@ -0,0 +1,14 @@
+Install headers prefixed, as to not cause a possible conflict with
+different versions.
+
+--- templates/lib/CMakeLists.txt.orig 2016-08-10 16:09:48 UTC
++++ templates/lib/CMakeLists.txt
+@@ -137,7 +137,7 @@ install(TARGETS Grantlee_Templates EXPOR
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR} COMPONENT Templates
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR} COMPONENT Templates
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR} COMPONENT Templates
+- INCLUDES DESTINATION include
++ INCLUDES DESTINATION include/grantlee5
+ )
+
+ install(FILES
diff --git a/devel/grantlee5/files/patch-textdocument_lib_CMakeLists.txt b/devel/grantlee5/files/patch-textdocument_lib_CMakeLists.txt
new file mode 100644
index 000000000000..860b0cd03c32
--- /dev/null
+++ b/devel/grantlee5/files/patch-textdocument_lib_CMakeLists.txt
@@ -0,0 +1,14 @@
+Install headers prefixed, as to not cause a possible conflict with
+different versions.
+
+--- textdocument/lib/CMakeLists.txt.orig 2016-08-10 16:10:17 UTC
++++ textdocument/lib/CMakeLists.txt
+@@ -58,7 +58,7 @@ install(TARGETS Grantlee_TextDocument EX
+ RUNTIME DESTINATION ${BIN_INSTALL_DIR} COMPONENT TextDocument
+ LIBRARY DESTINATION ${LIB_INSTALL_DIR} COMPONENT TextDocument
+ ARCHIVE DESTINATION ${LIB_INSTALL_DIR} COMPONENT TextDocument
+- INCLUDES DESTINATION include
++ INCLUDES DESTINATION include/grantlee5
+ )
+
+ install(FILES
diff --git a/devel/grantlee5/pkg-descr b/devel/grantlee5/pkg-descr
new file mode 100644
index 000000000000..8a750ca1b966
--- /dev/null
+++ b/devel/grantlee5/pkg-descr
@@ -0,0 +1,4 @@
+Grantlee is a string template engine based on the Django template
+system and written using the Qt framework.
+
+WWW: https://github.com/steveire/grantlee
diff --git a/devel/grantlee5/pkg-plist b/devel/grantlee5/pkg-plist
new file mode 100644
index 000000000000..d4670410cd89
--- /dev/null
+++ b/devel/grantlee5/pkg-plist
@@ -0,0 +1,47 @@
+include/grantlee5/grantlee/abstractlocalizer.h
+include/grantlee5/grantlee/abstractmarkupbuilder.h
+include/grantlee5/grantlee/bbcodebuilder.h
+include/grantlee5/grantlee/cachingloaderdecorator.h
+include/grantlee5/grantlee/context.h
+include/grantlee5/grantlee/engine.h
+include/grantlee5/grantlee/exception.h
+include/grantlee5/grantlee/filter.h
+include/grantlee5/grantlee/filterexpression.h
+include/grantlee5/grantlee/grantlee_templates_export.h
+include/grantlee5/grantlee/grantlee_textdocument_export.h
+include/grantlee5/grantlee/grantlee_version.h
+include/grantlee5/grantlee/markupdirector.h
+include/grantlee5/grantlee/mediawikimarkupbuilder.h
+include/grantlee5/grantlee/metatype.h
+include/grantlee5/grantlee/node.h
+include/grantlee5/grantlee/outputstream.h
+include/grantlee5/grantlee/parser.h
+include/grantlee5/grantlee/plaintextmarkupbuilder.h
+include/grantlee5/grantlee/qtlocalizer.h
+include/grantlee5/grantlee/rendercontext.h
+include/grantlee5/grantlee/safestring.h
+include/grantlee5/grantlee/taglibraryinterface.h
+include/grantlee5/grantlee/template.h
+include/grantlee5/grantlee/templateloader.h
+include/grantlee5/grantlee/texthtmlbuilder.h
+include/grantlee5/grantlee/token.h
+include/grantlee5/grantlee/typeaccessor.h
+include/grantlee5/grantlee/util.h
+include/grantlee5/grantlee/variable.h
+include/grantlee5/grantlee_templates.h
+include/grantlee5/grantlee_textdocument.h
+lib/cmake/Grantlee5/Grantlee5Config.cmake
+lib/cmake/Grantlee5/Grantlee5ConfigVersion.cmake
+lib/cmake/Grantlee5/GrantleeMacros.cmake
+lib/cmake/Grantlee5/GrantleeTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Grantlee5/GrantleeTargets.cmake
+lib/grantlee/%%GRANTLEE_VERSION_SHORT%%/grantlee_defaultfilters.so
+lib/grantlee/%%GRANTLEE_VERSION_SHORT%%/grantlee_defaulttags.so
+lib/grantlee/%%GRANTLEE_VERSION_SHORT%%/grantlee_i18ntags.so
+lib/grantlee/%%GRANTLEE_VERSION_SHORT%%/grantlee_loadertags.so
+lib/libGrantlee_Templates.so
+lib/libGrantlee_Templates.so.5
+lib/libGrantlee_Templates.so.%%GRANTLEE_VERSION_FULL%%
+lib/libGrantlee_TextDocument.so
+lib/libGrantlee_TextDocument.so.5
+lib/libGrantlee_TextDocument.so.%%GRANTLEE_VERSION_FULL%%
diff --git a/devel/kdevplatform/Makefile b/devel/kdevplatform/Makefile
index 25464fce21ed..c080069d9d21 100644
--- a/devel/kdevplatform/Makefile
+++ b/devel/kdevplatform/Makefile
@@ -12,20 +12,18 @@ COMMENT= Set of libraries for KDE IDE-like programs
LIB_DEPENDS= libsvn_client-1.so:devel/subversion \
libboost_thread.so:devel/boost-libs \
- libqjson.so:devel/qjson \
- libgrantlee_gui.so:devel/grantlee
+ libqjson.so:devel/qjson
USE_KDE4= kate_run kdelibs automoc4
USE_QT4= qmake_build moc_build uic_build rcc_build \
corelib designer_build gui webkit
-USES= cmake:outsource compiler:c++11-lib shebangfix tar:bz2
+USES= cmake:outsource compiler:c++11-lib grantlee:4 shebangfix tar:bz2
USE_LDCONFIG= yes
SHEBANG_FILES= util/kdev_format_source util/kdevplatform_shell_environment.sh
PLIST_SUB+= SHLIB_VER=8.0.0 \
- SHLIB_SHVER=8 \
- GRANTLEE_VER=0.5
+ SHLIB_SHVER=8
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
diff --git a/devel/kdevplatform/pkg-plist b/devel/kdevplatform/pkg-plist
index 08c3100df9c2..602ae158fed0 100644
--- a/devel/kdevplatform/pkg-plist
+++ b/devel/kdevplatform/pkg-plist
@@ -405,7 +405,7 @@ lib/kde4/kdevtemplatemanager_config.so
lib/kde4/kdevtestview.so
lib/kde4/kdevvcschangesviewplugin.so
lib/kde4/plasma_kdev_projectfileelement.so
-lib/kde4/plugins/grantlee/%%GRANTLEE_VER%%/kdev_filters.so
+lib/kde4/plugins/grantlee/%%GRANTLEE_VERSION_SHORT%%/kdev_filters.so
lib/libkdevplatformdebugger.so
lib/libkdevplatformdebugger.so.%%SHLIB_SHVER%%
lib/libkdevplatformdebugger.so.%%SHLIB_VER%%