aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2010-08-18 04:32:16 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2010-08-18 04:32:16 +0800
commitfed83c190450ad4a7c700ca0bdfb212fdc3bfa67 (patch)
tree09da9fee333af653c1bf885756e28711b30a197b /devel
parent491b3ef3c8f65d30e495dbb7c963db664452dd95 (diff)
downloadfreebsd-ports-gnome-fed83c190450ad4a7c700ca0bdfb212fdc3bfa67.tar.gz
freebsd-ports-gnome-fed83c190450ad4a7c700ca0bdfb212fdc3bfa67.tar.zst
freebsd-ports-gnome-fed83c190450ad4a7c700ca0bdfb212fdc3bfa67.zip
CMPH - C Minimal Perfect Hashing Library
A perfect hash function maps a static set of n keys into a set of m integer numbers without collisions, where m is greater than or equal to n. If m is equal to n, the function is called minimal. Minimal perfect hash functions are widely used for memory efficient storage and fast retrieval of items from static sets, such as words in natural languages, reserved words in programming languages or interactive systems, universal resource locations (URLs) in Web search engines, or item sets in data mining techniques. Therefore, there are applications for minimal perfect hash functions in information retrieval systems, database systems, language translation systems, electronic commerce systems, compilers, operating systems, among others. WWW: http://cmph.sourceforge.net/ PR: 149248 Submitted by: Jesse Kempf <jkempf@davisvision.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cmph/Makefile21
-rw-r--r--devel/cmph/distinfo3
-rw-r--r--devel/cmph/pkg-descr16
-rw-r--r--devel/cmph/pkg-plist9
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2079cb40aad0..03e360f4726c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -204,6 +204,7 @@
SUBDIR += clisp-hyperspec
SUBDIR += cmake
SUBDIR += cmake-gui
+ SUBDIR += cmph
SUBDIR += cmunge
SUBDIR += cobf
SUBDIR += cocktail
diff --git a/devel/cmph/Makefile b/devel/cmph/Makefile
new file mode 100644
index 000000000000..e25db7a6523d
--- /dev/null
+++ b/devel/cmph/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: cmph
+# Date created: 30 Jul 2010
+# Whom: Jesse Kempf (jessekempf@gmail.com)
+# $FreeBSD$
+#
+
+PORTNAME= cmph
+PORTVERSION= 0.9
+CATEGORIES= devel
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= jessekempf@gmail.com
+COMMENT= Minimal perfect hashes for C
+
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack
+USE_LDCONFIG= yes
+
+MAN1= cmph.1
+
+.include <bsd.port.mk>
diff --git a/devel/cmph/distinfo b/devel/cmph/distinfo
new file mode 100644
index 000000000000..71f8038c54f0
--- /dev/null
+++ b/devel/cmph/distinfo
@@ -0,0 +1,3 @@
+MD5 (cmph-0.9.tar.gz) = 14c17e3058174e9333936caa8e18ed28
+SHA256 (cmph-0.9.tar.gz) = dbdd870083d57bbe69a5096d6e5b6fca0d4a2b30b32c046e8c53e068d54eb09b
+SIZE (cmph-0.9.tar.gz) = 372609
diff --git a/devel/cmph/pkg-descr b/devel/cmph/pkg-descr
new file mode 100644
index 000000000000..fa5c013ec0d6
--- /dev/null
+++ b/devel/cmph/pkg-descr
@@ -0,0 +1,16 @@
+CMPH - C Minimal Perfect Hashing Library
+
+A perfect hash function maps a static set of n keys into a set of m integer
+numbers without collisions, where m is greater than or equal to n. If m is equal
+to n, the function is called minimal.
+
+Minimal perfect hash functions are widely used for memory efficient storage and
+fast retrieval of items from static sets, such as words in natural languages,
+reserved words in programming languages or interactive systems, universal
+resource locations (URLs) in Web search engines, or item sets in data mining
+techniques. Therefore, there are applications for minimal perfect hash functions
+in information retrieval systems, database systems, language translation
+systems, electronic commerce systems, compilers, operating systems, among
+others.
+
+WWW: http://cmph.sourceforge.net/
diff --git a/devel/cmph/pkg-plist b/devel/cmph/pkg-plist
new file mode 100644
index 000000000000..2f5b030f94ce
--- /dev/null
+++ b/devel/cmph/pkg-plist
@@ -0,0 +1,9 @@
+bin/cmph
+include/cmph.h
+include/cmph_time.h
+include/cmph_types.h
+lib/libcmph.a
+lib/libcmph.la
+lib/libcmph.so
+lib/libcmph.so.0
+libdata/pkgconfig/cmph.pc