aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-10 11:34:04 +0800
committerclsung <clsung@FreeBSD.org>2006-08-10 11:34:04 +0800
commitff9443b8a3eba3969a0bbea499ff7b043c1f4b9a (patch)
treed2948b825c06ad8f1015fb7701d6ab2ce480e61b /devel
parentee08f793fe0483fd0418c113bcb464ee60ee31b9 (diff)
downloadfreebsd-ports-gnome-ff9443b8a3eba3969a0bbea499ff7b043c1f4b9a.tar.gz
freebsd-ports-gnome-ff9443b8a3eba3969a0bbea499ff7b043c1f4b9a.tar.zst
freebsd-ports-gnome-ff9443b8a3eba3969a0bbea499ff7b043c1f4b9a.zip
Add p5-Contextual-Return 0.1.0, create context-senstive return values.
PR: ports/101682 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Contextual-Return/Makefile32
-rw-r--r--devel/p5-Contextual-Return/distinfo3
-rw-r--r--devel/p5-Contextual-Return/pkg-descr3
-rw-r--r--devel/p5-Contextual-Return/pkg-plist8
5 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index c38be4769362..2081003e3244 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -879,6 +879,7 @@
SUBDIR += p5-Config-Tiny
SUBDIR += p5-ConfigReader
SUBDIR += p5-ConfigReader-Simple
+ SUBDIR += p5-Contextual-Return
SUBDIR += p5-Coro
SUBDIR += p5-Curses
SUBDIR += p5-Curses-Application
diff --git a/devel/p5-Contextual-Return/Makefile b/devel/p5-Contextual-Return/Makefile
new file mode 100644
index 000000000000..2aa934fab59d
--- /dev/null
+++ b/devel/p5-Contextual-Return/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-Contextual-Return
+# Date created: 2006-08-09
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Contextual-Return
+PORTVERSION= 0.1.0
+DISTVERSIONPREFIX= v
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/D/DC/DCONWAY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Create context-senstive return values
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Want.pm:${PORTSDIR}/devel/p5-Want \
+ ${SITE_PERL}/version.pm:${PORTSDIR}/devel/p5-version
+
+PERL_CONFIGURE= yes
+
+MAN3= Contextual::Return.3 Contextual::Return::Failure.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # Inherited from p5-Want & p5-version
+IGNORE= requires Perl 5.6 or newer. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Contextual-Return/distinfo b/devel/p5-Contextual-Return/distinfo
new file mode 100644
index 000000000000..d56e99a9c8c9
--- /dev/null
+++ b/devel/p5-Contextual-Return/distinfo
@@ -0,0 +1,3 @@
+MD5 (Contextual-Return-v0.1.0.tar.gz) = 2651c1c521ad4b42e0efbeac664fade6
+SHA256 (Contextual-Return-v0.1.0.tar.gz) = a693850e5e1e0a65eafa51e2ac10d2b3ed7bb32d23902663d53520ac6a498c49
+SIZE (Contextual-Return-v0.1.0.tar.gz) = 22969
diff --git a/devel/p5-Contextual-Return/pkg-descr b/devel/p5-Contextual-Return/pkg-descr
new file mode 100644
index 000000000000..87d6af7b3c78
--- /dev/null
+++ b/devel/p5-Contextual-Return/pkg-descr
@@ -0,0 +1,3 @@
+Contextual::Return - Create context-senstive return values.
+
+WWW: http://search.cpan.org/dist/Contextual-Return/
diff --git a/devel/p5-Contextual-Return/pkg-plist b/devel/p5-Contextual-Return/pkg-plist
new file mode 100644
index 000000000000..6aa5f6826272
--- /dev/null
+++ b/devel/p5-Contextual-Return/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Contextual/Return/.packlist
+%%SITE_PERL%%/Contextual/Return.pm
+%%SITE_PERL%%/Contextual/Return/Failure.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Contextual/Return
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Contextual
+@dirrmtry %%SITE_PERL%%/Contextual/Return
+@dirrmtry %%SITE_PERL%%/Contextual