aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-08 20:15:02 +0800
committerstas <stas@FreeBSD.org>2008-04-08 20:15:02 +0800
commit00371bad5b36987be29d348edabf030dfc09f2d4 (patch)
treec8d6fcaff2fb63471b96d96b7ab9633f53420dac /devel
parent1475db87d14916797ed024ee3a411bad5cf82712 (diff)
downloadfreebsd-ports-gnome-00371bad5b36987be29d348edabf030dfc09f2d4.tar.gz
freebsd-ports-gnome-00371bad5b36987be29d348edabf030dfc09f2d4.tar.zst
freebsd-ports-gnome-00371bad5b36987be29d348edabf030dfc09f2d4.zip
- Add ocaml-typeconv, a mini library required for some
other preprocessing libraries. WWW: http://www.janestcapital.com/ocaml/index.html
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-typeconv/Makefile35
-rw-r--r--devel/ocaml-typeconv/distinfo3
-rw-r--r--devel/ocaml-typeconv/pkg-descr7
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index faa6400566d9..8e382cf7e390 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -847,6 +847,7 @@
SUBDIR += ocaml-sdl
SUBDIR += ocaml-sem
SUBDIR += ocaml-sexplib
+ SUBDIR += ocaml-typeconv
SUBDIR += ocaml-ulex
SUBDIR += ocaml-xstr
SUBDIR += ocaml-xstrp4
diff --git a/devel/ocaml-typeconv/Makefile b/devel/ocaml-typeconv/Makefile
new file mode 100644
index 000000000000..456233276ed5
--- /dev/null
+++ b/devel/ocaml-typeconv/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ocaml-type-conv
+# Date created: 2008-04-08
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= type-conv
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+MASTER_SITES= http://janestcapital.com/ocaml/
+PKGNAMEPREFIX= ocaml-
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Type conversion routines for OCaml
+
+USE_GMAKE= yes
+USE_OCAML= yes
+USE_OCAML_FINDLIB=yes
+
+SA_DIR= ${LOCALBASE}/${OCAML_SITELIBDIR}
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+# For nonstandard prefixes
+.if !exists(${OCAMLFIND_DESTDIR})
+ ${MKDIR} ${OCAMLFIND_DESTDIR}
+.endif
+
+post-install:
+ @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+
+.include <bsd.port.post.mk>
diff --git a/devel/ocaml-typeconv/distinfo b/devel/ocaml-typeconv/distinfo
new file mode 100644
index 000000000000..fb4136dcaac0
--- /dev/null
+++ b/devel/ocaml-typeconv/distinfo
@@ -0,0 +1,3 @@
+MD5 (type-conv-1.0.0.tar.gz) = 703e7f74d9c01d5e49274011e846bba8
+SHA256 (type-conv-1.0.0.tar.gz) = 3435f00c1c56c9a4ba7a4281fd9f7eec5ee2cda75806498a11974a379e3f1870
+SIZE (type-conv-1.0.0.tar.gz) = 22456
diff --git a/devel/ocaml-typeconv/pkg-descr b/devel/ocaml-typeconv/pkg-descr
new file mode 100644
index 000000000000..59288aa141be
--- /dev/null
+++ b/devel/ocaml-typeconv/pkg-descr
@@ -0,0 +1,7 @@
+The type-conv mini library factors out functionality needed by different
+preprocessors that generate code from type specifications, because this
+functionality cannot be duplicated without losing the ability to use
+these preprocessors simultaneously.
+
+Author: Markus Mottl <markus.mottl@gmail.com>
+WWW: http://www.janestcapital.com/ocaml/index.html