aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-05-20 11:58:49 +0800
committerwill <will@FreeBSD.org>2001-05-20 11:58:49 +0800
commit0104e6a9e520d7d4696c212cd56e16d2363b6679 (patch)
tree1fca2273ee006619087c8e8b85163002737f1cb3 /devel
parentd83e0405c02732aeabd4212131a9bc35fe735d6b (diff)
downloadfreebsd-ports-gnome-0104e6a9e520d7d4696c212cd56e16d2363b6679.tar.gz
freebsd-ports-gnome-0104e6a9e520d7d4696c212cd56e16d2363b6679.tar.zst
freebsd-ports-gnome-0104e6a9e520d7d4696c212cd56e16d2363b6679.zip
Add libvanessa_socket 0.0.1, a library that provides a simple layer
for TCP/IP socket operations. PR: 26936 Submitted by: Konstantinos Konstantinidis <kkonstan@daemon.gr>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libvanessa_socket/Makefile33
-rw-r--r--devel/libvanessa_socket/distinfo1
-rw-r--r--devel/libvanessa_socket/pkg-comment1
-rw-r--r--devel/libvanessa_socket/pkg-descr8
-rw-r--r--devel/libvanessa_socket/pkg-plist5
6 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 116d582a481a..ef9bffe15015 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -210,6 +210,7 @@
SUBDIR += libusb
SUBDIR += libuta
SUBDIR += libvanessa_logger
+ SUBDIR += libvanessa_socket
SUBDIR += libxalloc
SUBDIR += lincvs
SUBDIR += linguist
diff --git a/devel/libvanessa_socket/Makefile b/devel/libvanessa_socket/Makefile
new file mode 100644
index 000000000000..a69ce0532d7f
--- /dev/null
+++ b/devel/libvanessa_socket/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: libvanessa_socket
+# Date created: 28 April 2001
+# Whom: Konstantinos Konstantinidis <kkonstan@daemon.gr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libvanessa_socket
+PORTVERSION= 0.0.1
+CATEGORIES= devel
+MASTER_SITES= ftp://vanessa.sourceforge.net/pub/vanessa/%SUBDIR%/ \
+ ftp://ftp.au.vergenet.net/pub/vanessa/%SUBDIR%/ \
+ ftp://ftp.nl.vergenet.net/pub/vanessa/%SUBDIR%/ \
+ ftp://ftp.jp.vergenet.net/pub/vanessa/%SUBDIR%/ \
+ ftp://ftp.us.vergenet.net/pub/vanessa/%SUBDIR%/
+MASTER_SITE_SUBDIR= vanessa_socket/${PORTVERSION}
+DISTNAME= vanessa_socket-${PORTVERSION}
+
+MAINTAINER= kkonstan@daemon.gr
+
+LIB_DEPENDS= vanessa_logger.0:${PORTSDIR}/devel/libvanessa_logger
+
+MAN1= vanessa_socket_pipe.1
+
+INSTALLS_SHLIB= YES
+
+USE_LIBTOOL= YES
+GNU_CONFIGURE= YES
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+WRKSRC= ${WRKDIR}/vanessa_socket-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/libvanessa_socket/distinfo b/devel/libvanessa_socket/distinfo
new file mode 100644
index 000000000000..98f21bdc24c3
--- /dev/null
+++ b/devel/libvanessa_socket/distinfo
@@ -0,0 +1 @@
+MD5 (vanessa_socket-0.0.1.tar.gz) = 6cc4a3fcdfb16ff0470c21b6aa5f22de
diff --git a/devel/libvanessa_socket/pkg-comment b/devel/libvanessa_socket/pkg-comment
new file mode 100644
index 000000000000..5d1e0b726ec3
--- /dev/null
+++ b/devel/libvanessa_socket/pkg-comment
@@ -0,0 +1 @@
+Library that provides a simple layer for TCP/IP socket operations
diff --git a/devel/libvanessa_socket/pkg-descr b/devel/libvanessa_socket/pkg-descr
new file mode 100644
index 000000000000..127f3c702344
--- /dev/null
+++ b/devel/libvanessa_socket/pkg-descr
@@ -0,0 +1,8 @@
+libvanessa_socket is a library that provides a simple layer for TCP/IP socket
+operations. It includes code to open a socket to a server as a client, to
+listen on sockets for clients as a server and to pipe information between
+sockets.
+
+WWW: http://vanessa.sourceforge.net/
+
+-- K. Konstantinidis <kkonstan@daemon.gr>
diff --git a/devel/libvanessa_socket/pkg-plist b/devel/libvanessa_socket/pkg-plist
new file mode 100644
index 000000000000..ef562dbe04dc
--- /dev/null
+++ b/devel/libvanessa_socket/pkg-plist
@@ -0,0 +1,5 @@
+bin/vanessa_socket_pipe
+include/vanessa_socket.h
+lib/libvanessa_socket.so.0
+lib/libvanessa_socket.so
+lib/libvanessa_socket.a